summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 07:38:30 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 07:38:30 +0000
commit91f4c760cfb85cc708660387726c2926c3e923b9 (patch)
tree3c9dffe34bf912730cc3c40c3920f574233a612b /sci-libs/scipy
parentRemoved old versions (diff)
downloadgentoo-2-91f4c760cfb85cc708660387726c2926c3e923b9.tar.gz
gentoo-2-91f4c760cfb85cc708660387726c2926c3e923b9.tar.bz2
gentoo-2-91f4c760cfb85cc708660387726c2926c3e923b9.zip
Drop pkg_setup() and use default fortran one. This gets rid of the forced ATLAS use and blas/lapack-config checks added in #129524. It seems to work OK with other implems as long as you're consistent about it, and it breaks in an annoying way with newer eselect modules (see #136023 e.g.). Also this drops the LDFLAGS stuff that was wrongly added, a better fix is already in here.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog10
-rw-r--r--sci-libs/scipy/scipy-0.5.1.ebuild49
2 files changed, 14 insertions, 45 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index b107c08f650e..91b258cb7c64 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.12 2006/09/24 07:31:47 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.13 2006/09/24 07:38:30 dberkholz Exp $
+
+ 24 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; scipy-0.5.1.ebuild:
+ Drop pkg_setup() and use default fortran one. This gets rid of the forced
+ ATLAS use and blas/lapack-config checks added in #129524. It seems to work
+ OK with other implems as long as you're consistent about it, and it breaks
+ in an annoying way with newer eselect modules (see #136023 e.g.). Also this
+ drops the LDFLAGS stuff that was wrongly added, a better fix is already in
+ here.
24 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; scipy-0.4.8.ebuild,
scipy-0.4.8-r1.ebuild, scipy-0.4.9.ebuild:
diff --git a/sci-libs/scipy/scipy-0.5.1.ebuild b/sci-libs/scipy/scipy-0.5.1.ebuild
index ff540df708fb..79d471c2060a 100644
--- a/sci-libs/scipy/scipy-0.5.1.ebuild
+++ b/sci-libs/scipy/scipy-0.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.1.ebuild,v 1.1 2006/09/24 07:29:56 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.1.ebuild,v 1.2 2006/09/24 07:38:30 dberkholz Exp $
-inherit distutils flag-o-matic fortran
+inherit distutils fortran
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
DESCRIPTION="Open source scientific tools for Python"
@@ -13,14 +13,11 @@ SLOT="0"
IUSE="fftw"
KEYWORDS="~amd64 ~ppc ~x86"
-# did not use virtual/blas and virtual/lapack
-# because doc says scipy needs to compile all libraries with the same compiler
+# doc says scipy needs to compile all libraries with the same compiler
RDEPEND=">=dev-lang/python-2.3.3
>=dev-python/numpy-1.0_beta1
- sci-libs/blas-atlas
- sci-libs/blas-config
- sci-libs/lapack-config
- sci-libs/lapack-atlas
+ virtual/blas
+ virtual/lapack
fftw? ( =sci-libs/fftw-2.1* )"
DEPEND="${RDEPEND}"
@@ -31,42 +28,6 @@ DEPEND="${RDEPEND}"
FORTRAN="g77 gfortran"
-pkg_setup() {
- fortran_pkg_setup
-
- einfo "Checking active BLAS implementations for ATLAS."
- blas-config -p
- if ! blas-config -p | grep "F77 BLAS:" | grep -q -i atlas; then
- eerror "Your F77 BLAS profile is not set to the ATLAS implementation,"
- eerror "which is required by ${PN} to compile and run properly."
- eerror "Use: 'blas-config -f ATLAS' to activate ATLAS."
- echo
- bad_profile=1
- fi
- if ! blas-config -p | grep "C BLAS:" | grep -q -i atlas; then
- eerror "Your C BLAS profile is not set to the ATLAS implementation,"
- eerror "Which is required by ${PN} to compile and run properly."
- eerror "Use: 'blas-config -c ATLAS' to activate ATLAS."
- echo
- bad_profile=1
- fi
- einfo "Checking active LAPACK implementation for ATLAS."
- lapack-config -p
- if ! lapack-config -p | grep "F77 LAPACK:" | grep -q -i atlas; then
- eerror "Your F77 LAPACK profile is not set to the ATLAS implementation,"
- eerror "which is required by ${PN} to compile and run properly."
- eerror "Use: 'lapack-config ATLAS' to activate ATLAS."
- bad_profile=1
- fi
- if ! [ -z ${bad_profile} ]; then
- die "Active BLAS/LAPACK implementations are not ATLAS."
- fi
-
- # -Wl,-O1 breaks the compilation
- filter-ldflags -O1
- filter-ldflags -Wl,-O1
-}
-
src_unpack() {
unpack ${A}
cd "${S}"