summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-16 20:08:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-16 20:08:39 +0000
commit9288dc98f3377dd1fdee9573c0db607a3a099580 (patch)
tree44c81ea80faf1aebb5cf0ecc22a4830aa753eab5 /sci-libs/punc
parentadd kissfft support (diff)
downloadgentoo-2-9288dc98f3377dd1fdee9573c0db607a3a099580.tar.gz
gentoo-2-9288dc98f3377dd1fdee9573c0db607a3a099580.tar.bz2
gentoo-2-9288dc98f3377dd1fdee9573c0db607a3a099580.zip
sci-libs/punc: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/punc')
-rw-r--r--sci-libs/punc/ChangeLog7
-rw-r--r--sci-libs/punc/punc-0.2_p1.ebuild66
-rw-r--r--sci-libs/punc/punc-1.4-r1.ebuild85
-rw-r--r--sci-libs/punc/punc-1.5.ebuild3
4 files changed, 7 insertions, 154 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index 6924f765faf5..bb5d6c97d47c 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/punc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.16 2012/05/21 19:22:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.17 2012/10/16 20:08:39 jlec Exp $
+
+ 16 Oct 2012; Justin Lecher <jlec@gentoo.org> -punc-0.2_p1.ebuild,
+ -punc-1.4-r1.ebuild, punc-1.5.ebuild:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org> punc-0.2_p1.ebuild,
punc-1.4-r1.ebuild:
diff --git a/sci-libs/punc/punc-0.2_p1.ebuild b/sci-libs/punc/punc-0.2_p1.ebuild
deleted file mode 100644
index b1c089074eac..000000000000
--- a/sci-libs/punc/punc-0.2_p1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-0.2_p1.ebuild,v 1.7 2012/05/21 19:22:54 xarthisius Exp $
-
-EAPI="3"
-
-inherit autotools eutils fortran-2 multilib
-
-MY_PV="${PV}"
-MY_P="${PN}-${MY_PV/_p/-}"
-
-DESCRIPTION="Portable Understructure for Numerical Computing"
-HOMEPAGE="http://fetk.org/codes/punc/index.html"
-SRC_URI="http://www.fetk.org/codes/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug mpi static-libs"
-
-DEPEND="
- dev-libs/maloc[mpi=]
- sci-libs/arpack[mpi=]
- sci-libs/superlu
- virtual/blas
- virtual/mpi"
-RDEPEND="
- virtual/fortran
- ${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- rm -rf src/{blas,lapack,arpack,superlu}
- epatch "${FILESDIR}"/${PV}-underlinking.patch
- epatch "${FILESDIR}"/${P}-libdir.patch
-
- cp tools/tests/pmg/*.f src/pmg/ -f
- cp tools/tests/pmg/*.c src/pmg/ -f
- cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h
-
- eautoreconf
-}
-
-src_configure() {
- export FETK_INCLUDE="${EPREFIX}/usr/include"
- export FETK_LIBRARY="${EPREFIX}/usr/$(get_libdir)"
- export FETK_LAPACK_LIBRARY="$(pkg-config --libs lapack)"
- export FETK_BLAS_LIBRARY="${FETK_LIBRARY}"
- export FETK_SUPERLU_LIBRARY="-lsuperlu"
- export FETK_ARPACK_LIBRARY="${EPREFIX}/usr/$(get_libdir)"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug vdebug) \
- --enable-shared \
- --enable-pmgforce \
- --enable-cgcodeforce \
- --enable-vf2cforce
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- dohtml doc/index.html || die "failed to install html docs"
-}
diff --git a/sci-libs/punc/punc-1.4-r1.ebuild b/sci-libs/punc/punc-1.4-r1.ebuild
deleted file mode 100644
index 2a4600a7c890..000000000000
--- a/sci-libs/punc/punc-1.4-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.4-r1.ebuild,v 1.6 2012/05/21 19:22:54 xarthisius Exp $
-
-EAPI="3"
-
-inherit autotools eutils fortran-2 multilib
-
-DESCRIPTION="Portable Understructure for Numerical Computing"
-HOMEPAGE="http://fetk.org/codes/punc/index.html"
-SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc mpi static-libs"
-
-RDEPEND="
- virtual/fortran
-
- dev-libs/maloc[mpi=]
- dev-libs/libf2c
- sci-libs/amd
- sci-libs/cgcode
- sci-libs/arpack[mpi=]
- sci-libs/superlu
- sci-libs/umfpack
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi )"
-DEPEND="
- ${RDEPEND}
- doc? (
- media-gfx/graphviz
- app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- rm -rf src/{amd,blas,lapack,arpack,superlu,umfpack}
- epatch \
- "${FILESDIR}"/${PV}-linking.patch \
- "${FILESDIR}"/${PV}-doc.patch \
- "${FILESDIR}"/${PV}-header.patch
-
- cp tools/tests/pmg/*.f src/pmg/ -f
- cp tools/tests/pmg/*.c src/pmg/ -f
- cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h
-
- eautoreconf
-}
-
-src_configure() {
- local fetk_include
- local fetk_lib
- local myconf
-
- use doc || myconf="${myconf} --with-doxygen= --with-dot="
-
- fetk_include="${EPREFIX}"/usr/include
- fetk_lib="${EPREFIX}"/usr/$(get_libdir)
- export FETK_INCLUDE="${fetk_include}"
- export FETK_LIBRARY="${fetk_lib}"
- export FETK_LAPACK_LIBRARY="$(pkg-config --libs lapack)"
- export FETK_BLAS_LIBRARY="${fetk_lib}"
- export FETK_SUPERLU_LIBRARY="-lsuperlu"
- export FETK_ARPACK_LIBRARY="${fetk_lib}"
- export FETK_UMFPACK_LIBRARY="${fetk_lib}"
- export FETK_CGCODE_LIBRARY="${fetk_lib}"
- export FETK_AMD_LIBRARY="${fetk_lib}"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug vdebug) \
- --enable-shared \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-triplet \
- ${myconf}
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- dohtml doc/index.html || die "failed to install html docs"
-}
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index 3ef84c19b039..d7c1eb5b2055 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.6 2012/04/30 17:40:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.7 2012/10/16 20:08:39 jlec Exp $
EAPI=4
@@ -26,7 +26,6 @@ RDEPEND="
sci-libs/superlu
sci-libs/umfpack
virtual/blas
- virtual/fortran
virtual/lapack
mpi? ( virtual/mpi )"
DEPEND="