summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 21:14:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 21:14:43 +0000
commit5d74a764c671101a88e2d3f322920041cf4d38fb (patch)
tree140961e7cbeaf136636fb59c9120758f8c8dc47e /sci-libs/netcdf
parentAdd USE=gme (bug #429520), drop HPPA because of unsatisfied dependencies (diff)
downloadgentoo-2-5d74a764c671101a88e2d3f322920041cf4d38fb.tar.gz
gentoo-2-5d74a764c671101a88e2d3f322920041cf4d38fb.tar.bz2
gentoo-2-5d74a764c671101a88e2d3f322920041cf4d38fb.zip
Version bump. Tests require ncgen and ncdump. Keyword amd64-linux x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog7
-rw-r--r--sci-libs/netcdf/netcdf-4.2.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index a98049ac0fe0..50d09a6b7d33 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.99 2012/07/06 07:50:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.100 2012/08/02 21:14:43 bicatali Exp $
+
+*netcdf-4.2.1 (02 Aug 2012)
+
+ 02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +netcdf-4.2.1.ebuild:
+ Version bump. Tests require ncgen and ncdump. Keyword amd64-linux x86-linux
06 Jul 2012; Justin Lecher <jlec@gentoo.org> -netcdf-3.6.3.ebuild:
Version 3* dropped, due to unfixed bfr overflow, #424976
diff --git a/sci-libs/netcdf/netcdf-4.2.1.ebuild b/sci-libs/netcdf/netcdf-4.2.1.ebuild
new file mode 100644
index 000000000000..464e150848c6
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.2.1.ebuild,v 1.1 2012/08/02 21:14:43 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap doc examples hdf +hdf5 mpi static-libs szip test tools"
+
+RDEPEND="dap? ( net-misc/curl )
+ hdf? ( sci-libs/hdf >=sci-libs/hdf5-1.8.8 )
+ hdf5? ( >=sci-libs/hdf5-1.8.8[mpi=,szip=,zlib] )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="test? ( tools )"
+
+src_configure() {
+ myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-examples
+ $(use_enable dap)
+ $(use_enable doc doxygen)
+ $(use_enable hdf hdf4)
+ $(use_enable hdf5 netcdf-4)
+ $(use_enable tools utilities)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}