summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-02 16:50:43 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-02 16:50:43 +0000
commit18b766fafb9664a881a116c73aad466848107d57 (patch)
tree7ed70fbfde9a35840f8997b328cff84223006dcf /sci-libs/indilib
parentbump to EAPI=4 (diff)
downloadgentoo-2-18b766fafb9664a881a116c73aad466848107d57.tar.gz
gentoo-2-18b766fafb9664a881a116c73aad466848107d57.tar.bz2
gentoo-2-18b766fafb9664a881a116c73aad466848107d57.zip
Version bump wrt bug #419145.
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/indilib')
-rw-r--r--sci-libs/indilib/ChangeLog10
-rw-r--r--sci-libs/indilib/files/0.9.1-fix_symlinks.patch23
-rw-r--r--sci-libs/indilib/indilib-0.9.1.ebuild43
3 files changed, 74 insertions, 2 deletions
diff --git a/sci-libs/indilib/ChangeLog b/sci-libs/indilib/ChangeLog
index cdd3fd250daf..3a0a950979ca 100644
--- a/sci-libs/indilib/ChangeLog
+++ b/sci-libs/indilib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/indilib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.21 2011/10/30 15:47:38 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.22 2012/06/02 16:50:43 kensington Exp $
+
+*indilib-0.9.1 (02 Jun 2012)
+
+ 02 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/0.9.1-fix_symlinks.patch, +indilib-0.9.1.ebuild:
+ Version bump wrt bug #419145.
30 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> indilib-0.6.ebuild,
indilib-0.7.2.ebuild:
diff --git a/sci-libs/indilib/files/0.9.1-fix_symlinks.patch b/sci-libs/indilib/files/0.9.1-fix_symlinks.patch
new file mode 100644
index 000000000000..c888498f0bed
--- /dev/null
+++ b/sci-libs/indilib/files/0.9.1-fix_symlinks.patch
@@ -0,0 +1,23 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -204,15 +204,11 @@
+
+ install(TARGETS indi_lx200generic RUNTIME DESTINATION bin )
+
+-file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake
+-"exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200classic)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200autostar)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200_16)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200gps)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200ap)\n
+-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200fs2)\n
+-")
+-set_target_properties(indi_lx200generic PROPERTIES POST_INSTALL_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake)
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200classic\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200autostar\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200_16\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200gps\" )" )
++install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200ap\" )" )
+ #################################################################################
+
+ ########### Celestron GPS ############
diff --git a/sci-libs/indilib/indilib-0.9.1.ebuild b/sci-libs/indilib/indilib-0.9.1.ebuild
new file mode 100644
index 000000000000..c73d8c80cb6b
--- /dev/null
+++ b/sci-libs/indilib/indilib-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.9.1.ebuild,v 1.1 2012/06/02 16:50:43 kensington Exp $
+
+EAPI=4
+
+MY_PN="lib${PN/lib/}"
+
+inherit cmake-utils
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="http://indi.sourceforge.net/index.php/Main_Page"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="nova v4l"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3.140
+ sys-libs/zlib
+ virtual/libusb:0
+ nova? ( >=sci-libs/libnova-0.12.1 )
+"
+DEPEND="${RDEPEND}
+ v4l? ( >=sys-kernel/linux-headers-2.6 )
+"
+
+DOCS=( AUTHORS ChangeLog README README.drivers TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PV}-fix_symlinks.patch"
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with nova)
+ )
+ cmake-utils_src_configure
+}