summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 19:26:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 19:26:09 +0000
commitebe2e5ea3bfba337f3945bf3234c99676d02d3fd (patch)
tree5670d628a76e282834f4c8dbef44f30704b3d4a7 /sci-libs/gsl
parentamd64 stable, bug #307045 (diff)
downloadgentoo-2-ebe2e5ea3bfba337f3945bf3234c99676d02d3fd.tar.gz
gentoo-2-ebe2e5ea3bfba337f3945bf3234c99676d02d3fd.tar.bz2
gentoo-2-ebe2e5ea3bfba337f3945bf3234c99676d02d3fd.zip
Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay, keyworded as in overlay
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/ChangeLog8
-rw-r--r--sci-libs/gsl/gsl-1.13-r2.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index ceea6dc9525f..845c129f2f13 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gsl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.65 2010/01/30 19:07:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.66 2010/03/07 19:26:09 jlec Exp $
+
+*gsl-1.13-r2 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +gsl-1.13-r2.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
30 Jan 2010; Raúl Porcel <armin76@gentoo.org> gsl-1.13-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #299826
diff --git a/sci-libs/gsl/gsl-1.13-r2.ebuild b/sci-libs/gsl/gsl-1.13-r2.ebuild
new file mode 100644
index 000000000000..a679d0007a6f
--- /dev/null
+++ b/sci-libs/gsl/gsl-1.13-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.13-r2.ebuild,v 1.1 2010/03/07 19:26:09 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="The GNU Scientific Library"
+HOMEPAGE="http://www.gnu.org/software/gsl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cblas"
+
+RDEPEND="cblas? ( virtual/cblas )"
+DEPEND="${RDEPEND}
+ app-admin/eselect-cblas
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ ESELECT_PROF="gsl"
+ # prevent to use external cblas from a previously installed gsl
+ local current_lib=$(eselect cblas show | cut -d' ' -f2)
+ if use cblas && [[ ${current_lib} == gsl ]]; then
+ ewarn "USE flag cblas is set: linking gsl with an external cblas."
+ ewarn "However the current selected external cblas is gsl."
+ ewarn "Please install and/or eselect another cblas"
+ die "Circular gsl dependency"
+ fi
+}
+
+src_prepare() {
+ filter-flags -ffast-math
+ epatch "${FILESDIR}"/${P}-cblas.patch
+ epatch "${FILESDIR}"/${P}-cblas-vars.patch
+ eautoreconf
+
+ cp "${FILESDIR}"/eselect.cblas.gsl "${T}"/
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.cblas.gsl || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.cblas.gsl || die
+ fi
+}
+
+src_configure() {
+ if use cblas; then
+ export CBLAS_LIBS="$(pkg-config --libs cblas)"
+ export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
+ fi
+ econf $(use_with cblas)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+
+ # take care of pkgconfig file for cblas implementation.
+ sed -e "s/@LIBDIR@/$(get_libdir)/" \
+ -e "s/@PV@/${PV}/" \
+ -e "/^prefix=/s:=:=${EPREFIX}:" \
+ -e "/^libdir=/s:=:=${EPREFIX}:" \
+ "${FILESDIR}"/cblas.pc.in > cblas.pc \
+ || die "sed cblas.pc failed"
+ insinto /usr/$(get_libdir)/blas/gsl
+ doins cblas.pc || die "installing cblas.pc failed"
+ eselect cblas add $(get_libdir) "${T}"/eselect.cblas.gsl \
+ ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}