summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:36:16 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:36:16 +0000
commit41b08f71859c170c881d131964ef44b748464336 (patch)
tree27bf68ac0d4f379623050fa1ccc71eef5891c440 /sci-libs/gsl
parentsci-libs/hypre: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of p... (diff)
downloadgentoo-2-41b08f71859c170c881d131964ef44b748464336.tar.gz
gentoo-2-41b08f71859c170c881d131964ef44b748464336.tar.bz2
gentoo-2-41b08f71859c170c881d131964ef44b748464336.zip
sci-libs/gsl: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; drop old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/ChangeLog10
-rw-r--r--sci-libs/gsl/gsl-1.13-r1.ebuild78
-rw-r--r--sci-libs/gsl/gsl-1.13-r2.ebuild88
-rw-r--r--sci-libs/gsl/gsl-1.14-r1.ebuild8
-rw-r--r--sci-libs/gsl/gsl-1.14.ebuild10
-rw-r--r--sci-libs/gsl/gsl-1.15.ebuild8
-rw-r--r--sci-libs/gsl/metadata.xml10
7 files changed, 26 insertions, 186 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index 700c5fbfc429..2dacb6a7b51c 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gsl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.83 2012/05/04 08:22:52 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.84 2013/02/21 21:36:16 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> -gsl-1.13-r1.ebuild,
+ -gsl-1.13-r2.ebuild, gsl-1.14.ebuild, gsl-1.14-r1.ebuild, gsl-1.15.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ drop old
04 May 2012; Jeff Horelick <jdhore@gentoo.org> gsl-1.13-r1.ebuild,
gsl-1.13-r2.ebuild, gsl-1.14.ebuild, gsl-1.14-r1.ebuild, gsl-1.15.ebuild:
diff --git a/sci-libs/gsl/gsl-1.13-r1.ebuild b/sci-libs/gsl/gsl-1.13-r1.ebuild
deleted file mode 100644
index b812b987956a..000000000000
--- a/sci-libs/gsl/gsl-1.13-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.13-r1.ebuild,v 1.9 2012/05/04 08:22:52 jdhore Exp $
-
-EAPI=2
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="cblas-external"
-
-RDEPEND="cblas-external? ( virtual/cblas )"
-DEPEND="${RDEPEND}
- app-admin/eselect-cblas
- virtual/pkgconfig"
-
-pkg_setup() {
- ESELECT_PROF="gsl"
- # prevent to use external cblas from a previously installed gsl
- local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas-external && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas-external is set: linking gsl with an external cblas."
- ewarn "However the current selected external cblas is gsl."
- ewarn "Please install and/or eselect another cblas"
- die "Circular gsl dependency"
- fi
-}
-
-src_prepare() {
- filter-flags -ffast-math
- epatch "${FILESDIR}"/${P}-cblas.patch
- epatch "${FILESDIR}"/${P}-cblas-vars.patch
- eautoreconf
-}
-
-src_configure() {
- if use cblas-external; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
- fi
- econf $(use_with cblas-external cblas)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
-
- # take care of pkgconfig file for cblas implementation.
- sed -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- "${FILESDIR}"/cblas.pc.in > cblas.pc \
- || die "sed cblas.pc failed"
- insinto /usr/$(get_libdir)/blas/gsl
- doins cblas.pc || die "installing cblas.pc failed"
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl \
- ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}
diff --git a/sci-libs/gsl/gsl-1.13-r2.ebuild b/sci-libs/gsl/gsl-1.13-r2.ebuild
deleted file mode 100644
index 73bd2904b80c..000000000000
--- a/sci-libs/gsl/gsl-1.13-r2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.13-r2.ebuild,v 1.3 2012/05/04 08:22:52 jdhore Exp $
-
-EAPI="3"
-
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="cblas-external"
-
-RDEPEND="cblas-external? ( virtual/cblas )"
-DEPEND="${RDEPEND}
- app-admin/eselect-cblas
- virtual/pkgconfig"
-
-pkg_setup() {
- ESELECT_PROF="gsl"
- # prevent to use external cblas from a previously installed gsl
- local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas-external && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas-external is set: linking gsl with an external cblas."
- ewarn "However the current selected external cblas is gsl."
- ewarn "Please install and/or eselect another cblas"
- die "Circular gsl dependency"
- fi
-}
-
-src_prepare() {
- filter-flags -ffast-math
- epatch "${FILESDIR}"/${P}-cblas.patch
- epatch "${FILESDIR}"/${P}-cblas-vars.patch
- eautoreconf
-
- cp "${FILESDIR}"/eselect.cblas.gsl "${T}"/
- sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.cblas.gsl || die
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
- "${T}"/eselect.cblas.gsl || die
- fi
-}
-
-src_configure() {
- if use cblas-external; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
- fi
- econf $(use_with cblas-external cblas)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
-
- # take care of pkgconfig file for cblas implementation.
- sed -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- -e "/^prefix=/s:=:=${EPREFIX}:" \
- -e "/^libdir=/s:=:=${EPREFIX}:" \
- "${FILESDIR}"/cblas.pc.in > cblas.pc \
- || die "sed cblas.pc failed"
- insinto /usr/$(get_libdir)/blas/gsl
- doins cblas.pc || die "installing cblas.pc failed"
- eselect cblas add $(get_libdir) "${T}"/eselect.cblas.gsl \
- ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}
diff --git a/sci-libs/gsl/gsl-1.14-r1.ebuild b/sci-libs/gsl/gsl-1.14-r1.ebuild
index e29b8448913b..8cd784d678e8 100644
--- a/sci-libs/gsl/gsl-1.14-r1.ebuild
+++ b/sci-libs/gsl/gsl-1.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14-r1.ebuild,v 1.6 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14-r1.ebuild,v 1.7 2013/02/21 21:36:16 jlec Exp $
EAPI="3"
@@ -53,8 +53,8 @@ src_prepare() {
src_configure() {
if use cblas-external; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
+ export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
+ export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
fi
econf \
--enable-shared \
diff --git a/sci-libs/gsl/gsl-1.14.ebuild b/sci-libs/gsl/gsl-1.14.ebuild
index 0715d4e49dfb..0fbdcc68eb35 100644
--- a/sci-libs/gsl/gsl-1.14.ebuild
+++ b/sci-libs/gsl/gsl-1.14.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14.ebuild,v 1.9 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14.ebuild,v 1.10 2013/02/21 21:36:16 jlec Exp $
EAPI="3"
-inherit eutils flag-o-matic autotools
+inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="The GNU Scientific Library"
HOMEPAGE="http://www.gnu.org/software/gsl/"
@@ -47,8 +47,8 @@ src_prepare() {
src_configure() {
if use cblas-external; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
+ export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
+ export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
fi
econf $(use_with cblas-external cblas)
}
diff --git a/sci-libs/gsl/gsl-1.15.ebuild b/sci-libs/gsl/gsl-1.15.ebuild
index 6d326e787fb8..00265481fc63 100644
--- a/sci-libs/gsl/gsl-1.15.ebuild
+++ b/sci-libs/gsl/gsl-1.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.15.ebuild,v 1.4 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.15.ebuild,v 1.5 2013/02/21 21:36:16 jlec Exp $
EAPI=4
@@ -61,8 +61,8 @@ src_prepare() {
src_configure() {
if use cblas-external; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
+ export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
+ export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
fi
econf \
--enable-shared \
diff --git a/sci-libs/gsl/metadata.xml b/sci-libs/gsl/metadata.xml
index a0c38aac7918..7ab2ed03c52f 100644
--- a/sci-libs/gsl/metadata.xml
+++ b/sci-libs/gsl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The GNU Scientific Library (GSL) is a collection of routines for
numerical analysis. The routines are written from scratch by the GSL
team in C, and present a modern API for C programmers, while allowing
@@ -15,8 +15,8 @@
differential equations, quadrature, Monte Carlo integration, special
functions, physical constants, and much more.
</longdescription>
-<use>
- <flag name='cblas-external'>Link gsl with external cblas provided by
+ <use>
+ <flag name="cblas-external">Link gsl with external cblas provided by
(<pkg>virtual/cblas</pkg>) instead of shipped internal version</flag>
-</use>
+ </use>
</pkgmetadata>