summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 07:36:41 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 07:36:41 +0000
commit697f4155dc6cc4966d0c0af645922c67f48a066d (patch)
tree769ea5fdb0984d85faedadac17d8f83496df39a2 /sci-libs/coinor-vol
parentFix metapost deps (bug #498704 by Aaron Pelton). (diff)
downloadgentoo-2-697f4155dc6cc4966d0c0af645922c67f48a066d.tar.gz
gentoo-2-697f4155dc6cc4966d0c0af645922c67f48a066d.tar.bz2
gentoo-2-697f4155dc6cc4966d0c0af645922c67f48a066d.zip
Fix the common coinor pkg-config installation problem, #500222
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/coinor-vol')
-rw-r--r--sci-libs/coinor-vol/ChangeLog5
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/sci-libs/coinor-vol/ChangeLog b/sci-libs/coinor-vol/ChangeLog
index b55e879b4617..bac738b6c4e7 100644
--- a/sci-libs/coinor-vol/ChangeLog
+++ b/sci-libs/coinor-vol/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/coinor-vol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-vol/ChangeLog,v 1.2 2014/01/15 19:52:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-vol/ChangeLog,v 1.3 2014/02/04 07:36:41 jlec Exp $
+
+ 04 Feb 2014; Justin Lecher <jlec@gentoo.org> coinor-vol-1.4.4.ebuild:
+ Fix the common coinor pkg-config installation problem, #500222
14 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org> coinor-vol-1.4.4.ebuild:
Cleanup, as-needed applied upstream
diff --git a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
index a2080ad899af..a248210d43b2 100644
--- a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
+++ b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild,v 1.2 2014/01/15 19:52:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild,v 1.3 2014/02/04 07:36:41 jlec Exp $
EAPI=5
@@ -27,9 +27,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+src_prepare() {
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
src_configure() {
+ # needed for the --with-coin-instdir
+ dodir /usr
local myeconfargs=(
--enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
$(use_with doc dot)
)
autotools-utils_src_configure