summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-31 10:37:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-31 10:37:29 +0000
commit25f812469205ceacee0cd1f0902312573fa5863e (patch)
treea9450e395f08f6bef58c6fe41f402f5b9af1ba5e /sci-libs/cgcode
parentold (diff)
downloadgentoo-2-25f812469205ceacee0cd1f0902312573fa5863e.tar.gz
gentoo-2-25f812469205ceacee0cd1f0902312573fa5863e.tar.bz2
gentoo-2-25f812469205ceacee0cd1f0902312573fa5863e.zip
New addition
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cgcode')
-rw-r--r--sci-libs/cgcode/ChangeLog10
-rw-r--r--sci-libs/cgcode/cgcode-1.0.ebuild39
-rw-r--r--sci-libs/cgcode/files/1.0-gentoo.patch83
-rw-r--r--sci-libs/cgcode/metadata.xml8
4 files changed, 140 insertions, 0 deletions
diff --git a/sci-libs/cgcode/ChangeLog b/sci-libs/cgcode/ChangeLog
new file mode 100644
index 000000000000..989b065063d6
--- /dev/null
+++ b/sci-libs/cgcode/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/cgcode
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/ChangeLog,v 1.1 2010/10/31 10:37:29 jlec Exp $
+
+*cgcode-1.0 (31 Oct 2010)
+
+ 31 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/1.0-gentoo.patch,
+ +cgcode-1.0.ebuild, +metadata.xml:
+ New addition
+
diff --git a/sci-libs/cgcode/cgcode-1.0.ebuild b/sci-libs/cgcode/cgcode-1.0.ebuild
new file mode 100644
index 000000000000..f2f4f112ac25
--- /dev/null
+++ b/sci-libs/cgcode/cgcode-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/cgcode-1.0.ebuild,v 1.1 2010/10/31 10:37:29 jlec Exp $
+
+EAPI="3"
+
+inherit eutils fortran
+
+FORTRNC="ifort gfortran"
+
+DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
+HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ cat >> make.inc <<- EOF
+ F77 = ${FORTRANC}
+ FFLAGS = ${FFLAGS}
+ BLASLIBS = $(pkg-config --libs blas)
+ EOF
+}
+
+src_install() {
+ dobin goos good || die
+ dolib.so lib${PN}.so* || die
+ dodoc INTRODUCTION NOTE README || die
+}
diff --git a/sci-libs/cgcode/files/1.0-gentoo.patch b/sci-libs/cgcode/files/1.0-gentoo.patch
new file mode 100644
index 000000000000..3313a5149181
--- /dev/null
+++ b/sci-libs/cgcode/files/1.0-gentoo.patch
@@ -0,0 +1,83 @@
+diff --git a/makefile b/makefile
+index 4813b55..f20af02 100644
+--- a/makefile
++++ b/makefile
+@@ -1,21 +1,23 @@
+
+ include make.inc
+
+-THELIBS = libcgcode.a libblas_mini.a
++THELIBS = -lcgcode
+
+ default : goos good
+
+-libs :
+- cd src ; make ; cd ../util ; make
++libs : src/libcgcode.so
++
++src/libcgcode.so:
++ $(MAKE) -C src
+
+ goos : mains.o libs
+- $(F77) $(DEBUG) $(OFLAGS) $(LFLAGS) mains.o $(THELIBS) -o goos
++ $(F77) $(LDFLAGS) mains.o -L. $(THELIBS) $(BLASLIBS) -o goos
+
+ good : maind.o libs
+- $(F77) $(DEBUG) $(OFLAGS) $(LFLAGS) maind.o $(THELIBS) -o good
++ $(F77) $(LDFLAGS) maind.o -L. $(THELIBS) $(BLASLIBS) -o good
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -c $<
+
+ clean :
+ rm -f *.o goos good
+diff --git a/src/makefile b/src/makefile
+index 10cf6c3..1dfd02d 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -1,16 +1,17 @@
+
+ include ../make.inc
+
+-THISLIB = libcgcode.a
++THISLIB = libcgcode.so
+ SOBJLIB = scgdrv.o scg.o scr.o scrind.o spcg.o scgnr.o scgne.o spcgnr.o spcgne.o sppcg.o spcgca.o sdpchb.o scbfix.o sckchb.o scgchk.o sonest.o msstop.o r1mach.o sratqr.o
+ DOBJLIB = dcgdrv.o dcg.o dcr.o dcrind.o dpcg.o dcgnr.o dcgne.o dpcgnr.o dpcgne.o dppcg.o dpcgca.o ddpchb.o dcbfix.o dckchb.o dcgchk.o donest.o mdstop.o d1mach.o dratqr.o depsln.o
+
+ $(THISLIB) : $(SOBJLIB) $(DOBJLIB)
+- $(AR) $(THISLIB) $(SOBJLIB) $(DOBJLIB)
+- cp $(THISLIB) ../.
++ $(F77) $(FFLAGS) $(LDFLAGS) -shared -fPIC -Wl,--soname,$(THISLIB).1 -o $(THISLIB).1.0 $(SOBJLIB) $(DOBJLIB)
++ ln -sf $(THISLIB).1.0 $(THISLIB)
++ cp $(THISLIB)* ../.
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -fPIC -c $<
+
+ clean :
+ rm -f *.o $(THISLIB)
+diff --git a/util/makefile b/util/makefile
+index 6dad0d1..5c9d24f 100644
+--- a/util/makefile
++++ b/util/makefile
+@@ -6,11 +6,12 @@ SOBJLIB = saxpy.o scopy.o sdot.o snrm2.o sscal.o
+ DOBJLIB = daxpy.o dcopy.o ddot.o dnrm2.o dscal.o
+
+ $(THISLIB) : $(SOBJLIB) $(DOBJLIB)
+- $(AR) $(THISLIB) $(SOBJLIB) $(DOBJLIB)
+- cp $(THISLIB) ../.
++ $(F77) $(FFLAGS) $(LDFLAGS) -shared -Wl,--soname,$(THISLIB).1 -o $(THISLIB).1.0 $(SOBJLIB) $(DOBJLIB)
++ ln -sf $(THISLIB).1.0 $(THISLIB)
++ cp $(THISLIB)* ../.
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -c $<
+
+ clean :
+ rm -f *.o $(THISLIB)
diff --git a/sci-libs/cgcode/metadata.xml b/sci-libs/cgcode/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-libs/cgcode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>