summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-29 08:46:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-29 08:46:15 +0000
commit809fe9d6d42fea4e6d9199cd6c6691e3179d86c0 (patch)
tree5db8033cab2e243ddaeafdb1db58a2787fd43829 /sci-libs/arpack
parentAdd gnutls USE flag to most recent version. (diff)
downloadgentoo-2-809fe9d6d42fea4e6d9199cd6c6691e3179d86c0.tar.gz
gentoo-2-809fe9d6d42fea4e6d9199cd6c6691e3179d86c0.tar.bz2
gentoo-2-809fe9d6d42fea4e6d9199cd6c6691e3179d86c0.zip
Changed sed separator to : for robust path string substitution (BLAS_LIBS)
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/arpack')
-rw-r--r--sci-libs/arpack/ChangeLog5
-rw-r--r--sci-libs/arpack/arpack-96-r2.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/sci-libs/arpack/ChangeLog b/sci-libs/arpack/ChangeLog
index f9d2adc8cbe4..043327009979 100644
--- a/sci-libs/arpack/ChangeLog
+++ b/sci-libs/arpack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/arpack
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/ChangeLog,v 1.7 2008/03/24 09:34:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/ChangeLog,v 1.8 2008/03/29 08:46:15 bicatali Exp $
+
+ 29 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> arpack-96-r2.ebuild:
+ Changed sed separator to : for robust path string substitution (BLAS_LIBS)
24 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> Manifest:
Fixed autotools patch to have it work with as-needed
diff --git a/sci-libs/arpack/arpack-96-r2.ebuild b/sci-libs/arpack/arpack-96-r2.ebuild
index f3d591e6cc8f..09cc55e2f24b 100644
--- a/sci-libs/arpack/arpack-96-r2.ebuild
+++ b/sci-libs/arpack/arpack-96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/arpack-96-r2.ebuild,v 1.2 2008/03/04 10:38:38 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/arpack-96-r2.ebuild,v 1.3 2008/03/29 08:46:15 bicatali Exp $
inherit eutils autotools fortran
@@ -37,17 +37,17 @@ src_unpack() {
# fix examples library paths
sed -i \
-e '/^include/d' \
- -e "s/\$(ALIBS)/-larpack ${BLAS_LIBS}/g" \
- -e 's/$(FC)/$(F77)/g' \
- -e 's/$(FFLAGS)/$(FFLAGS) $(LDFLAGS)/g' \
+ -e "s:\$(ALIBS):-larpack ${BLAS_LIBS}:g" \
+ -e 's:$(FC):$(F77):g' \
+ -e 's:$(FFLAGS):$(FFLAGS) $(LDFLAGS):g' \
EXAMPLES/*/makefile || die "sed failed"
sed -i \
-e '/^include/d' \
- -e "s/\$(PLIBS)/-larpack -lparpack ${BLAS_LIBS}/g" \
- -e 's/_$(PLAT)//g' \
- -e 's/$(PFC)/mpif77/g' \
- -e 's/$(PFFLAGS)/$(FFLAGS) $(LDFLAGS) $(EXTOBJS)/g' \
+ -e "s:\$(PLIBS):-larpack -lparpack ${BLAS_LIBS}:g" \
+ -e 's:_$(PLAT)::g' \
+ -e 's:$(PFC):mpif77:g' \
+ -e 's:$(PFFLAGS):$(FFLAGS) $(LDFLAGS) $(EXTOBJS):g' \
PARPACK/EXAMPLES/MPI/makefile || die "sed failed"
eautoreconf