summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 06:40:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 06:40:13 +0000
commitc50ddfaa263ac64a6ac2445a54f5e580cac9f979 (patch)
tree2a511995cb4ff4fc4de2d30e621e65f321207876 /sci-geosciences
parenttestBCLookup added to list of disabled tests requiring network connection, fi... (diff)
downloadgentoo-2-c50ddfaa263ac64a6ac2445a54f5e580cac9f979.tar.gz
gentoo-2-c50ddfaa263ac64a6ac2445a54f5e580cac9f979.tar.bz2
gentoo-2-c50ddfaa263ac64a6ac2445a54f5e580cac9f979.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gmt/ChangeLog10
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch38
-rw-r--r--sci-geosciences/gmt/gmt-4.5.9.ebuild92
3 files changed, 138 insertions, 2 deletions
diff --git a/sci-geosciences/gmt/ChangeLog b/sci-geosciences/gmt/ChangeLog
index 57376c98f849..af9de39ac8b2 100644
--- a/sci-geosciences/gmt/ChangeLog
+++ b/sci-geosciences/gmt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gmt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.29 2012/12/12 19:33:39 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.30 2013/02/02 06:40:13 patrick Exp $
+
+*gmt-4.5.9 (02 Feb 2013)
+
+ 02 Feb 2013; Patrick Lauer <patrick@gentoo.org>
+ +files/gmt-4.5.9-no-strip.patch, +gmt-4.5.9.ebuild:
+ Bump
12 Dec 2012; Justin Lecher <jlec@gentoo.org> gmt-4.5.8.ebuild,
+files/gmt-4.5.8-bfr-overflow.patch, +files/gmt-4.5.8-impl-dec.patch,
diff --git a/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch b/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch
new file mode 100644
index 000000000000..f57f1d811b05
--- /dev/null
+++ b/sci-geosciences/gmt/files/gmt-4.5.9-no-strip.patch
@@ -0,0 +1,38 @@
+Drop manipulation of several flags:
+
+* stripping of -g from CFLAGS, as it interferes with deliberate
+ generation of debug symbols and breaks on flags like -ggdb.
+* Addition of -s resp. -Wl,-x to LDFLAGS, as stipping of binaries is
+ done as a separate step on Gentoo (and many other distros) in order
+ to faciliate retention or splitting of debug symbols.
+* Setting of optimization flags, as the user should be free to choose
+ them.
+
+2009-07-27 Martin von Gagern
+
+Reference: http://bugs.gentoo.org/279268
+
+Index: GMT4.5.0/configure.ac
+===================================================================
+--- GMT4.5.0.orig/configure.ac
++++ GMT4.5.0/configure.ac
+@@ -527,19 +527,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
+- else
+- LDFLAGS="$LDFLAGS -s"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ AC_MSG_RESULT(no)
+ fi
+ dnl -----------------------------------------------------------------
diff --git a/sci-geosciences/gmt/gmt-4.5.9.ebuild b/sci-geosciences/gmt/gmt-4.5.9.ebuild
new file mode 100644
index 000000000000..4eba3599b40b
--- /dev/null
+++ b/sci-geosciences/gmt/gmt-4.5.9.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.5.9.ebuild,v 1.1 2013/02/02 06:40:13 patrick Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+GSHHS="gshhs-2.2.0"
+
+DESCRIPTION="Powerful map generator"
+HOMEPAGE="http://gmt.soest.hawaii.edu/"
+SRC_URI="
+ mirror://gmt/${P}.tar.bz2
+ mirror://gmt/${GSHHS}.tar.bz2
+ gmttria? ( mirror://gmt/${P}-non-gpl.tar.bz2 )"
+
+LICENSE="GPL-2 gmttria? ( Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +gdal gmttria +metric mex +netcdf octave postscript"
+
+RDEPEND="
+ !sci-biology/probcons
+ gdal? ( sci-libs/gdal )
+ netcdf? ( >=sci-libs/netcdf-4.1 )
+ octave? ( sci-mathematics/octave )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/GMT${PV}"
+
+# mex can use matlab too which i can't test
+REQUIRED_USE="
+ mex? ( octave )
+"
+
+# hand written make files that are not parallel safe
+MAKEOPTS+=" -j1"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.9-no-strip.patch
+ "${FILESDIR}"/${PN}-4.5.6-respect-ldflags.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ mv -f "${WORKDIR}/share/"* "${S}/share/" || die
+
+ tc-export AR RANLIB
+
+ autotools-utils_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)/${P}
+ --includedir=/usr/include/${P}
+ --datadir=/usr/share/${P}
+ --docdir=/usr/share/doc/${PF}
+ --disable-update
+ --disable-matlab
+ --disable-xgrid
+ --disable-debug
+ $(use_enable gdal)
+ $(use_enable netcdf)
+ $(use_enable octave)
+ $(use_enable debug devdebug)
+ $(use_enable !metric US)
+ $(use_enable postscript eps)
+ $(use_enable mex)
+ $(use_enable gmttria triangle)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install install-all
+
+ # remove static libs
+ find "${ED}/usr/$(get_libdir)" -name '*.a' -exec rm -f {} +
+
+ cat <<- _EOF_ > "${T}/99gmt"
+ GMTHOME="${EPREFIX}/usr/share/${P}"
+ GMT_SHAREDIR="${EPREFIX}/usr/share/${P}"
+ _EOF_
+ doenvd "${T}/99gmt"
+}