summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:42:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:42:57 +0000
commit8a86bcd36004a4d58a7dec6d874c9a0483114fc3 (patch)
tree630d57b933ced1db0d5a43050a3f23707e5eaefe /sci-geosciences
parentversion bump, removed some old versions (diff)
downloadgentoo-2-8a86bcd36004a4d58a7dec6d874c9a0483114fc3.tar.gz
gentoo-2-8a86bcd36004a4d58a7dec6d874c9a0483114fc3.tar.bz2
gentoo-2-8a86bcd36004a4d58a7dec6d874c9a0483114fc3.zip
Fix building with GCC 4.5+ wrt #318579 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gebabbel/ChangeLog8
-rw-r--r--sci-geosciences/gebabbel/files/gebabbel-0.3-gcc45.patch15
-rw-r--r--sci-geosciences/gebabbel/gebabbel-0.3.ebuild11
3 files changed, 27 insertions, 7 deletions
diff --git a/sci-geosciences/gebabbel/ChangeLog b/sci-geosciences/gebabbel/ChangeLog
index 46a0b3291adb..052aeac1d02e 100644
--- a/sci-geosciences/gebabbel/ChangeLog
+++ b/sci-geosciences/gebabbel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/gebabbel
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gebabbel/ChangeLog,v 1.4 2009/09/30 16:39:13 ayoy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gebabbel/ChangeLog,v 1.5 2010/05/06 11:42:57 ssuominen Exp $
+
+ 06 May 2010; Samuli Suominen <ssuominen@gentoo.org> gebabbel-0.3.ebuild,
+ +files/gebabbel-0.3-gcc45.patch:
+ Fix building with GCC 4.5+ wrt #318579 by Kacper Kowalik.
30 Sep 2009; Dominik Kapusta <ayoy@gentoo.org> gebabbel-0.3.ebuild:
Removed obsolete QT_BUILT_WITH_USE and the dependency on Qt metapackage,
diff --git a/sci-geosciences/gebabbel/files/gebabbel-0.3-gcc45.patch b/sci-geosciences/gebabbel/files/gebabbel-0.3-gcc45.patch
new file mode 100644
index 000000000000..e8064e366c9c
--- /dev/null
+++ b/sci-geosciences/gebabbel/files/gebabbel-0.3-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318579
+
+--- src/MyMainWindow.cpp
++++ src/MyMainWindow.cpp
+@@ -219,7 +219,7 @@
+
+ // Creating the toolbar
+ MainToolBar = addToolBar( tr( "Main Toolbar" ) );
+- MainToolBar->setIconSize( QSize::QSize( 16, 16 ) );
++ MainToolBar->setIconSize( QSize( 16, 16 ) );
+ MainToolBar->setAllowedAreas( Qt::TopToolBarArea );
+ MainToolBar->setMovable( false );
+
diff --git a/sci-geosciences/gebabbel/gebabbel-0.3.ebuild b/sci-geosciences/gebabbel/gebabbel-0.3.ebuild
index 43bca68f87d9..506b89ce5250 100644
--- a/sci-geosciences/gebabbel/gebabbel-0.3.ebuild
+++ b/sci-geosciences/gebabbel/gebabbel-0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gebabbel/gebabbel-0.3.ebuild,v 1.4 2009/09/30 16:39:13 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gebabbel/gebabbel-0.3.ebuild,v 1.5 2010/05/06 11:42:57 ssuominen Exp $
-EAPI="2"
+EAPI=2
inherit eutils qt4
MY_PN=${PN/g/G}
@@ -20,10 +20,11 @@ DEPEND="x11-libs/qt-core:4
RDEPEND="${DEPEND}
sci-geosciences/gpsbabel"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}/${P}-fix.diff"
+ epatch "${FILESDIR}"/${P}-fix.diff \
+ "${FILESDIR}"/${P}-gcc45.patch
}
src_configure() {