summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-20 13:59:01 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-20 13:59:01 +0000
commit3b97f6936019093b018f724498b829d9d7c623d2 (patch)
tree3401ad5415500238105dfe9e9e41239b6b6042b1 /sci-geosciences/osm-gps-map
parentfix dependencies wrt #470748 (diff)
downloadgentoo-2-3b97f6936019093b018f724498b829d9d7c623d2.tar.gz
gentoo-2-3b97f6936019093b018f724498b829d9d7c623d2.tar.bz2
gentoo-2-3b97f6936019093b018f724498b829d9d7c623d2.zip
Added missing python USE flag conditional in prepare phase, fixes compilation with USE=-python.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sci-geosciences/osm-gps-map')
-rw-r--r--sci-geosciences/osm-gps-map/ChangeLog6
-rw-r--r--sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/sci-geosciences/osm-gps-map/ChangeLog b/sci-geosciences/osm-gps-map/ChangeLog
index c7f947b34481..ad9c6aab9030 100644
--- a/sci-geosciences/osm-gps-map/ChangeLog
+++ b/sci-geosciences/osm-gps-map/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/osm-gps-map
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/ChangeLog,v 1.4 2013/04/21 14:14:32 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/ChangeLog,v 1.5 2013/05/20 13:59:01 tomwij Exp $
+
+ 20 May 2013; Tom Wijsman <TomWij@gentoo.org> osm-gps-map-0.7.3.ebuild:
+ Added missing python USE flag conditional in prepare phase, fixes compilation
+ with USE=-python.
21 Apr 2013; Tom Wijsman <TomWij@gentoo.org> osm-gps-map-0.7.3.ebuild:
Slotted dependencies to avoid breakage, fixes bug #464240.
diff --git a/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
index 50ab856323c7..951b9f0f4804 100644
--- a/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
+++ b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild,v 1.4 2013/04/21 14:14:32 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild,v 1.5 2013/05/20 13:59:01 tomwij Exp $
EAPI=5
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
PYTHON_S="${WORKDIR}/python-osmgpsmap-${PV}"
src_configure() {
- #configure script does not accept quoted EPREFIX...
+ # Configure script does not accept quoted EPREFIX...
gnome2_src_configure \
$(use_enable introspection) \
--docdir=/usr/share/doc/${PF} \
@@ -54,14 +54,16 @@ src_prepare() {
gnome2_src_prepare
- cd "${PYTHON_S}" || die
- epatch "${FILESDIR}/${P}-fix-python-setup.py.patch"
+ if use python ; then
+ cd "${PYTHON_S}" || die
+ epatch "${FILESDIR}/${P}-fix-python-setup.py.patch"
+ fi
}
src_compile() {
gnome2_src_compile
- if use python; then
+ if use python ; then
cd "${PYTHON_S}" || die
CFLAGS="${CFLAGS} -I\"${S}\"/src" LDFLAGS="${LDFLAGS} -L\"${S}\"/src/.libs" distutils-r1_src_compile
fi
@@ -70,7 +72,7 @@ src_compile() {
src_install() {
gnome2_src_install
- if use python; then
+ if use python ; then
cd "${PYTHON_S}" || die
distutils-r1_src_install
fi