summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-06-22 13:07:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-06-22 13:07:09 +0000
commit3b9b7e4c63da25248341f9c7155da34b3f5c1e46 (patch)
tree36d10128ba0f58f74faae44c55cdceff6d439ef1 /sci-geosciences/openstreetmap-icons
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-3b9b7e4c63da25248341f9c7155da34b3f5c1e46.tar.gz
gentoo-2-3b9b7e4c63da25248341f9c7155da34b3f5c1e46.tar.bz2
gentoo-2-3b9b7e4c63da25248341f9c7155da34b3f5c1e46.zip
Rebuild icons and geoinfo db.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/openstreetmap-icons')
-rw-r--r--sci-geosciences/openstreetmap-icons/ChangeLog6
-rw-r--r--sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild24
2 files changed, 25 insertions, 5 deletions
diff --git a/sci-geosciences/openstreetmap-icons/ChangeLog b/sci-geosciences/openstreetmap-icons/ChangeLog
index aaff9bdc0480..2dc9942b9219 100644
--- a/sci-geosciences/openstreetmap-icons/ChangeLog
+++ b/sci-geosciences/openstreetmap-icons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/openstreetmap-icons
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/openstreetmap-icons/ChangeLog,v 1.1 2009/06/20 19:02:23 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/openstreetmap-icons/ChangeLog,v 1.2 2009/06/22 13:07:09 tupone Exp $
+
+ 22 Jun 2009; Alfredo Tupone <tupone@gentoo.org>
+ openstreetmap-icons-20090616.ebuild:
+ Rebuild icons and geoinfo db.
*openstreetmap-icons-20090616 (20 Jun 2009)
diff --git a/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild b/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild
index e93d200cd1e3..a1c0ca202a53 100644
--- a/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild
+++ b/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild,v 1.1 2009/06/20 19:02:23 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/openstreetmap-icons/openstreetmap-icons-20090616.ebuild,v 1.2 2009/06/22 13:07:09 tupone Exp $
+
+EAPI=2
+
+inherit cmake-utils
DESCRIPTION="openstreetmap icons"
HOMEPAGE="http://www.openstreetmap.org/"
@@ -11,12 +15,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=""
+DEPEND="dev-perl/ImageInfo
+ media-gfx/imagemagick[perl]"
RDEPEND=""
+S=${WORKDIR}/${P}/map-icons
+
+src_compile() {
+ cmake-utils_src_compile
+ cp icons.* ${CMAKE_BUILD_DIR}
+ cd ${CMAKE_BUILD_DIR}
+ perl "${S}"/tools/create_geoinfo-db.pl --lang=en --source=icons.xml
+ perl "${S}"/tools/create_geoinfo-db.pl --lang=de --source=icons.xml
+}
+
# tar.bz2 generated extracting files from
# http://svn.openstreetmap.org/applications/share/map-icons
src_install() {
- insinto /usr/share/icons/
- doins -r map-icons
+ insinto /usr/share/icons/map-icons
+ cd ../map-icons_build
+ doins -r icons.* geoinfo.* *.small *.big || die "Install failed"
}