summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2015-01-04 18:36:20 +0000
committerHanno Böck <hanno@gentoo.org>2015-01-04 18:36:20 +0000
commit27a7c628d8aee62ee6985dd29ddfe9199001a0a3 (patch)
treef94311e54f13a4089fe636de4bbb6f9ce1fe19c7 /sci-geosciences/gtk-g-rays2
parentRemove old. (diff)
downloadgentoo-2-27a7c628d8aee62ee6985dd29ddfe9199001a0a3.tar.gz
gentoo-2-27a7c628d8aee62ee6985dd29ddfe9199001a0a3.tar.bz2
gentoo-2-27a7c628d8aee62ee6985dd29ddfe9199001a0a3.zip
gtk-g-rays2 bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BBB51E42)
Diffstat (limited to 'sci-geosciences/gtk-g-rays2')
-rw-r--r--sci-geosciences/gtk-g-rays2/ChangeLog9
-rw-r--r--sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sci-geosciences/gtk-g-rays2/ChangeLog b/sci-geosciences/gtk-g-rays2/ChangeLog
index 09111000711e..40fbc6b39f81 100644
--- a/sci-geosciences/gtk-g-rays2/ChangeLog
+++ b/sci-geosciences/gtk-g-rays2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gtk-g-rays2
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/ChangeLog,v 1.11 2014/07/24 17:59:07 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/ChangeLog,v 1.12 2015/01/04 18:36:20 hanno Exp $
+
+*gtk-g-rays2-2.05 (04 Jan 2015)
+
+ 04 Jan 2015; <hanno@gentoo.org> +gtk-g-rays2-2.05.ebuild:
+ Bump, EAPI 5, add missing dep.
24 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
gtk-g-rays2-2.01.ebuild:
diff --git a/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild
new file mode 100644
index 000000000000..cc1557d2734c
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/gtk-g-rays2-2.05.ebuild,v 1.1 2015/01/04 18:36:20 hanno Exp $
+
+EAPI=5
+
+inherit autotools gnome2
+
+DESCRIPTION="GUI for accessing the Wintec WBT 201 / G-Rays 2 GPS device"
+HOMEPAGE="http://www.daria.co.uk/gps"
+SRC_URI="http://www.zen35309.zen.co.uk/gps/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ virtual/libgudev
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ virtual/freedesktop-icon-theme
+ net-wireless/bluez
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS="README AUTHORS ChangeLog"
+
+src_prepare() {
+ # werror is bad idea
+ sed -i -e 's:-Werror::g' configure.ac || die
+ # we run this ourselves
+ sed -i -e '/gtk-update-icon-cache/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}