summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-08-11 20:18:31 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-08-11 20:18:31 +0000
commit77c3bd099a560158c5277d3bc7ccf5db929ce045 (patch)
treeeffd9a15993ce538611ae6cbfe5a14c1b5d68411 /sci-electronics
parentMinor: Fix CFLAGS not being respected for "halog" (diff)
downloadgentoo-2-77c3bd099a560158c5277d3bc7ccf5db929ce045.tar.gz
gentoo-2-77c3bd099a560158c5277d3bc7ccf5db929ce045.tar.bz2
gentoo-2-77c3bd099a560158c5277d3bc7ccf5db929ce045.zip
Version bumps - bug 516668. Cleanup.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/eagle/ChangeLog11
-rw-r--r--sci-electronics/eagle/eagle-5.12.0.ebuild (renamed from sci-electronics/eagle/eagle-5.10.0-r1.ebuild)81
-rw-r--r--sci-electronics/eagle/eagle-6.2.1_beta.ebuild118
-rw-r--r--sci-electronics/eagle/eagle-6.6.0.ebuild (renamed from sci-electronics/eagle/eagle-6.5.0.ebuild)4
-rw-r--r--sci-electronics/eagle/eagle-7.1.0.ebuild (renamed from sci-electronics/eagle/eagle-6.2.0.ebuild)54
5 files changed, 90 insertions, 178 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 25238d09f012..e9d6964bc572 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.60 2014/06/18 20:43:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.61 2014/08/11 20:18:31 idl0r Exp $
+
+*eagle-7.1.0 (11 Aug 2014)
+*eagle-6.6.0 (11 Aug 2014)
+*eagle-5.12.0 (11 Aug 2014)
+
+ 11 Aug 2014; Christian Ruppert <idl0r@gentoo.org> -eagle-5.10.0-r1.ebuild,
+ +eagle-5.12.0.ebuild, -eagle-6.2.0.ebuild, -eagle-6.2.1_beta.ebuild,
+ -eagle-6.5.0.ebuild, +eagle-6.6.0.ebuild, +eagle-7.1.0.ebuild:
+ Version bumps - bug 516668. Cleanup.
18 Jun 2014; Michał Górny <mgorny@gentoo.org> eagle-6.2.0.ebuild,
eagle-6.2.1_beta.ebuild, eagle-6.5.0.ebuild:
diff --git a/sci-electronics/eagle/eagle-5.10.0-r1.ebuild b/sci-electronics/eagle/eagle-5.12.0.ebuild
index 5b1dc88c29dd..01413ea80228 100644
--- a/sci-electronics/eagle/eagle-5.10.0-r1.ebuild
+++ b/sci-electronics/eagle/eagle-5.12.0.ebuild
@@ -1,37 +1,60 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.10.0-r1.ebuild,v 1.6 2013/08/01 20:52:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.12.0.ebuild,v 1.1 2014/08/11 20:18:31 idl0r Exp $
-EAPI="1"
+EAPI="5"
inherit eutils
DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
HOMEPAGE="http://www.cadsoft.de"
-KEYWORDS="amd64 x86"
-IUSE="linguas_de linguas_zh doc"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc linguas_de linguas_zh"
LICENSE="cadsoft"
-RESTRICT="strip test"
SLOT="0"
-# Cadsoft has used the suffix "_p" in the past which we translate to "r"
-MY_PV=${PV/_p/r}
+SRC_URI="ftp://ftp.cadsoft.de/eagle/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
-SRC_URI="ftp://ftp.cadsoft.de/eagle/program/${PV%\.[0-9]}/${PN}-lin-${MY_PV}.run"
-
-QA_FLAGS_IGNORED="opt/eagle-${PV}/bin/eagle"
+QA_PREBUILT="opt/${P}/bin/eagle"
RDEPEND="sys-libs/glibc
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x86? ( || ( virtual/jpeg:62 media-libs/jpeg:62 )
+ x86? (
+ sys-libs/zlib
+ x11-libs/libXi
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ media-libs/freetype
+ media-libs/fontconfig
+ || ( virtual/jpeg:62 media-libs/jpeg:62 )
media-libs/libpng:1.2
- =dev-libs/openssl-0.9.8* )
- amd64? ( app-emulation/emul-linux-x86-baselibs
- app-emulation/emul-linux-x86-xlibs )"
+ )
+ amd64? (
+ || (
+ (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ virtual/jpeg:62[-abi_x86_32(-)]
+ media-libs/libpng:1.2[-abi_x86_32(-)]
+ )
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+ || (
+ (
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ )
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
# Append ${PV} since that's what upstream installs to
INSTALLDIR="/opt/eagle-${PV}"
@@ -45,14 +68,11 @@ esac
DOCS="README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt"
src_unpack() {
-
# Extract the built-in .tar.bz2 file starting at __DATA__
sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
-
}
src_install() {
-
# Set MY_LANG for this function only since UPDATE_zh and README_zh
# don't exist
[[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
@@ -65,10 +85,11 @@ src_install() {
# Install wrapper (suppressing leading tabs)
# see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
exeinto /usr/bin
- newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle-${PV}
+ dosym eagle-${PV} /usr/bin/eagle
# Finally, append the path of the eagle binary respecting INSTALLDIR and any
# arguments passed to the script (thanks Denilson)
- echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle"
+ echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle-${PV}"
# Install the documentation
cd doc
@@ -80,17 +101,16 @@ src_install() {
rm -rf "${D}${INSTALLDIR}/doc"
cd ..
- echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
- doenvd "${S}/90eagle"
+ echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle-${PV}"
+ doenvd "${S}/90eagle-${PV}"
# Create desktop entry
- doicon bin/${PN}icon50.png
- make_desktop_entry "${ROOT}/usr/bin/eagle" ${PN} ${PN}icon50 "Graphics;Electronics"
-
+ mv bin/${PN}icon50.png bin/${PF}-icon50.png
+ doicon bin/${PF}-icon50.png
+ make_desktop_entry "${ROOT}/usr/bin/eagle-${PV}" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
}
pkg_postinst() {
-
elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
elog "now to set up the correct paths."
elog "You must first run eagle as root to invoke product registration."
@@ -100,5 +120,4 @@ pkg_postinst() {
ewarn "with versions prior to 5.0!"
ewarn
ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 4.xx."
-
}
diff --git a/sci-electronics/eagle/eagle-6.2.1_beta.ebuild b/sci-electronics/eagle/eagle-6.2.1_beta.ebuild
deleted file mode 100644
index 2900f708b838..000000000000
--- a/sci-electronics/eagle/eagle-6.2.1_beta.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-6.2.1_beta.ebuild,v 1.3 2014/06/18 20:43:06 mgorny Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
-HOMEPAGE="http://www.cadsoft.de"
-SRC_URI="ftp://ftp.cadsoft.de/${PN}/betatest/${PN}-lin-${PV/_beta/-beta}.run"
-
-LICENSE="cadsoft"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 -*"
-IUSE="doc linguas_de linguas_zh"
-
-RESTRICT="strip"
-
-QA_PREBUILT="opt/eagle-${PV}/bin/eagle"
-
-RDEPEND="sys-libs/glibc
- x86? (
- sys-libs/zlib
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXi
- media-libs/freetype
- media-libs/fontconfig
- dev-libs/openssl
- virtual/jpeg
- )
- amd64? (
- app-emulation/emul-linux-x86-baselibs
- || (
- (
- >=x11-libs/libX11-1.6.2[abi_x86_32]
- >=x11-libs/libXext-1.3.2[abi_x86_32]
- >=x11-libs/libXrender-0.9.8[abi_x86_32]
- >=x11-libs/libXrandr-1.4.2[abi_x86_32]
- >=x11-libs/libXcursor-1.1.14[abi_x86_32]
- >=x11-libs/libXi-1.7.2[abi_x86_32]
- >=media-libs/freetype-2.5.0.1[abi_x86_32]
- >=media-libs/fontconfig-2.10.92[abi_x86_32]
- )
- app-emulation/emul-linux-x86-xlibs
- )
- )"
-
-S=${WORKDIR}/${P/_beta/}
-
-# Append ${PV} since that's what upstream installs to
-case "${LINGUAS}" in
- *de*)
- MY_LANG="de";;
- *)
- MY_LANG="en";;
-esac
-
-src_unpack() {
- # Extract the built-in .tar.bz2 file starting at __DATA__
- sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
-}
-
-src_install() {
- local installdir="/opt/eagle-${PV}"
-
- # Set MY_LANG for this function only since UPDATE_zh and README_zh
- # don't exist
- [[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
-
- insinto $installdir
- doins -r .
-
- fperms 0755 ${installdir}/bin/eagle
-
- # Install wrapper (suppressing leading tabs)
- # see bug #188368 or http://www.cadsoftusa.com/training/faq/#3
- exeinto /opt/bin
- newexe "${FILESDIR}/eagle_wrapper_script" eagle
- # Finally, append the path of the eagle binary respecting $installdir and any
- # arguments passed to the script (thanks Denilson)
- echo "${installdir}/bin/eagle" '"$@"' >> "${D}/opt/bin/eagle"
-
- # Install the documentation
- cd doc
- dodoc README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt
- doman eagle.1
- # Install extra documentation if requested
- if use doc; then
- dodoc {connect-device-split-symbol-${MY_INST_LANG},elektro-tutorial,manual_${MY_INST_LANG},tutorial_${MY_INST_LANG}}.pdf
- fi
- # Remove docs left in $installdir
- rm -rf "${D}${installdir}/doc"
- cd "${S}"
-
- echo -e "ROOTPATH=${installdir}/bin\nPRELINK_PATH_MASK=${installdir}" > "${S}/90eagle-${PV}"
- doenvd "${S}/90eagle-${PV}"
-
- # Create desktop entry
- newicon bin/${PN}icon50.png ${PF}-icon50.png
- make_desktop_entry "${ROOT}/usr/bin/eagle-${PV}" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
-}
-
-pkg_postinst() {
- elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
- elog "now to set up the correct paths."
- elog "You must first run eagle as root to invoke product registration."
- echo
- ewarn "Due to some necessary changes in the data structure, once you edit"
- ewarn "a file with version 6.x you will no longer be able to edit it"
- ewarn "with versions prior to 6.0!"
- ewarn
- ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 5.xx/4.xx."
-}
diff --git a/sci-electronics/eagle/eagle-6.5.0.ebuild b/sci-electronics/eagle/eagle-6.6.0.ebuild
index 436e287ab11a..e0c5a108d7e6 100644
--- a/sci-electronics/eagle/eagle-6.5.0.ebuild
+++ b/sci-electronics/eagle/eagle-6.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-6.5.0.ebuild,v 1.3 2014/06/18 20:43:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-6.6.0.ebuild,v 1.1 2014/08/11 20:18:31 idl0r Exp $
EAPI="5"
@@ -15,8 +15,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 -*"
IUSE="doc linguas_de linguas_zh"
-RESTRICT="strip"
-
QA_PREBUILT="opt/eagle/bin/eagle"
RDEPEND="sys-libs/glibc
diff --git a/sci-electronics/eagle/eagle-6.2.0.ebuild b/sci-electronics/eagle/eagle-7.1.0.ebuild
index 042b247f1795..04a25eca0119 100644
--- a/sci-electronics/eagle/eagle-6.2.0.ebuild
+++ b/sci-electronics/eagle/eagle-7.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-6.2.0.ebuild,v 1.3 2014/06/18 20:43:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-7.1.0.ebuild,v 1.1 2014/08/11 20:18:31 idl0r Exp $
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -12,41 +12,44 @@ SRC_URI="ftp://ftp.cadsoft.de/${PN}/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
LICENSE="cadsoft"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86 -*"
IUSE="doc linguas_de linguas_zh"
-RESTRICT="strip"
-
-QA_PREBUILT="opt/eagle-${PV}/bin/eagle"
+QA_PREBUILT="opt/eagle/bin/eagle"
RDEPEND="sys-libs/glibc
x86? (
sys-libs/zlib
+ dev-libs/openssl
+ x11-libs/libXi
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
x11-libs/libXrandr
x11-libs/libXcursor
- x11-libs/libXi
media-libs/freetype
media-libs/fontconfig
- dev-libs/openssl
- virtual/jpeg
)
amd64? (
- app-emulation/emul-linux-x86-baselibs
|| (
(
- >=x11-libs/libX11-1.6.2[abi_x86_32]
- >=x11-libs/libXext-1.3.2[abi_x86_32]
- >=x11-libs/libXrender-0.9.8[abi_x86_32]
- >=x11-libs/libXrandr-1.4.2[abi_x86_32]
- >=x11-libs/libXcursor-1.1.14[abi_x86_32]
- >=x11-libs/libXi-1.7.2[abi_x86_32]
- >=media-libs/freetype-2.5.0.1[abi_x86_32]
- >=media-libs/fontconfig-2.10.92[abi_x86_32]
+ >=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
)
- app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+ || (
+ (
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ )
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
)
)"
@@ -64,7 +67,7 @@ src_unpack() {
}
src_install() {
- local installdir="/opt/eagle-${PV}"
+ local installdir="/opt/eagle"
# Set MY_LANG for this function only since UPDATE_zh and README_zh
# don't exist
@@ -87,9 +90,10 @@ src_install() {
cd doc
dodoc README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt
doman eagle.1
+
# Install extra documentation if requested
if use doc; then
- dodoc {connect-device-split-symbol-${MY_INST_LANG},elektro-tutorial,manual_${MY_INST_LANG},tutorial_${MY_INST_LANG}}.pdf
+ dodoc {connect-device-split-symbol-${MY_INST_LANG},elektro-tutorial,manual_${MY_INST_LANG},tutorial_${MY_INST_LANG},layer-setup_designrules}.pdf
fi
# Remove docs left in $installdir
rm -rf "${D}${installdir}/doc"
@@ -100,7 +104,7 @@ src_install() {
# Create desktop entry
newicon bin/${PN}icon50.png ${PF}-icon50.png
- make_desktop_entry "${ROOT}/usr/bin/eagle-${PV}" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
+ make_desktop_entry "${ROOT}/opt/bin/eagle" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
}
pkg_postinst() {
@@ -109,8 +113,8 @@ pkg_postinst() {
elog "You must first run eagle as root to invoke product registration."
echo
ewarn "Due to some necessary changes in the data structure, once you edit"
- ewarn "a file with version 6.x you will no longer be able to edit it"
- ewarn "with versions prior to 6.0!"
+ ewarn "a file with version 7.x you will no longer be able to edit it"
+ ewarn "with versions prior to 7.0!"
ewarn
- ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 5.xx/4.xx."
+ ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 6.x/5.x/4.x."
}