summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-20 23:31:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-20 23:31:27 +0000
commit135160572c5cbc664db909ae4148e1ad2f8c9c91 (patch)
tree67aa7b8a722b9da40cc6af1593177a8bc8b1cae8 /sci-electronics/klayout
parentRespect LDFLAGS (bug #336820). Do not hard-wire AR. Set RDEPEND. (diff)
downloadgentoo-2-135160572c5cbc664db909ae4148e1ad2f8c9c91.tar.gz
gentoo-2-135160572c5cbc664db909ae4148e1ad2f8c9c91.tar.bz2
gentoo-2-135160572c5cbc664db909ae4148e1ad2f8c9c91.zip
New application, viewer and editor for integrated circuit layouts.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog12
-rw-r--r--sci-electronics/klayout/files/klayout-0.20.2-Makefile.conf.linux-gentoo42
-rw-r--r--sci-electronics/klayout/files/klayout-0.20.2-configureonly.patch37
-rw-r--r--sci-electronics/klayout/klayout-0.20.2.ebuild77
-rw-r--r--sci-electronics/klayout/metadata.xml9
5 files changed, 177 insertions, 0 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
new file mode 100644
index 000000000000..7a374077f3f4
--- /dev/null
+++ b/sci-electronics/klayout/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-electronics/klayout
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.1 2010/09/20 23:31:27 dilfridge Exp $
+
+*klayout-0.20.2 (20 Sep 2010)
+
+ 20 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +klayout-0.20.2.ebuild, +files/klayout-0.20.2-Makefile.conf.linux-gentoo,
+ +files/klayout-0.20.2-configureonly.patch, +metadata.xml:
+ New application, viewer and editor for integrated circuit layouts. Thanks
+ to Andreas Krinke and _AxS_ for the initial ebuild. Fixes bug 259291.
+
diff --git a/sci-electronics/klayout/files/klayout-0.20.2-Makefile.conf.linux-gentoo b/sci-electronics/klayout/files/klayout-0.20.2-Makefile.conf.linux-gentoo
new file mode 100644
index 000000000000..b22da1857676
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.20.2-Makefile.conf.linux-gentoo
@@ -0,0 +1,42 @@
+
+# Configuration file for gentoo-linux
+# Compiler options
+
+CCOPT_DEP=-MM -MG -x c++
+
+CCWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
+ -Wsign-promo -Wsynth -Wno-long-long -Wno-strict-aliasing
+
+CCOPT=-c -x c++ $(CXXFLAGS) -o
+CCOPT_SO=-fPIC $(CCOPT)
+
+INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
+
+DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
+
+# Linker options
+
+LOPT=-Wl,-E ${LDFLAGS} -o
+LOPT_SO=-shared -fPIC -o
+
+LIBS=-L$(QTLIB) -lQtGui -lQtCore -lQtXml -lrt -lstdc++ -lcrypt
+
+LINK=$(CXX)
+
+# The details for the install target (needed since 0.19.2)
+
+.PHONY: install
+install:
+ mkdir -p $(INSTALL_BINDIR)
+ cp main/$(EXEC_NAME) $(INSTALL_BINDIR)
+ for bin in $(OTHER_BIN) ; \
+ do \
+ cp main/$$bin $(INSTALL_BINDIR) ; \
+ done
+ for plugin in $(PLUGINS) ; \
+ do \
+ cp $$plugin/*.so $(INSTALL_BINDIR) ; \
+ done
+ chmod 755 $(INSTALL_BINDIR) $(INSTALL_BINDIR)/*
+
+
diff --git a/sci-electronics/klayout/files/klayout-0.20.2-configureonly.patch b/sci-electronics/klayout/files/klayout-0.20.2-configureonly.patch
new file mode 100644
index 000000000000..74c2e78167c4
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.20.2-configureonly.patch
@@ -0,0 +1,37 @@
+--- klayout-0.18.1/build.sh 2009-08-02 15:17:12.000000000 -0400
++++ klayout-0.18.1/build.sh.new 2009-09-18 16:15:47.000000000 -0400
+@@ -237,34 +237,3 @@
+ echo "Building plugins: $PLUGINS"
+ echo ""
+
+-# -- Running build --
+-
+-echo "Running build .."
+-echo "$MAKE_PRG"
+-cd $BUILD
+-$MAKE_PRG $MAKE_OPT all || exit 1
+-echo ""
+-
+-cd $CURR_DIR
+-
+-# -- Installing binaries --
+-
+-echo "Installing binaries .."
+-cd $BUILD
+-$MAKE_PRG install
+-cd $CURR_DIR
+-echo "Build done."
+-
+-if [ $WIN_CYGWIN = 0 ]; then
+- echo ""
+- echo "Final binary is ready in $BIN/$EXEC_NAME."
+- echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
+- echo "$QTLIB"
+-
+- LD_LIBRARY_PATH=$QTLIB:$LD_LIBRARY_PATH
+- $BIN/$EXEC_NAME -v
+- $BIN/$EXEC_NAME -h
+-fi
+-
+-exit 0
+-
diff --git a/sci-electronics/klayout/klayout-0.20.2.ebuild b/sci-electronics/klayout/klayout-0.20.2.ebuild
new file mode 100644
index 000000000000..35fa208ea3b8
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.20.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.20.2.ebuild,v 1.1 2010/09/20 23:31:27 dilfridge Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=yes
+
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://www.klayout.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ruby"
+
+RDEPEND="x11-libs/qt-gui:4[qt3support]"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-configureonly.patch"
+
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${P}-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ local rbflags
+
+ if use ruby ; then
+ rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
+ fi
+
+ ./build.sh \
+ -platform linux-gentoo \
+ -bin bin \
+ -qtbin /usr/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 \
+ ${rbflags} || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all || die "Build failed"
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install || die "make install failed"
+
+ cd ..
+ dobin \
+ bin/klayout \
+ bin/strm2gds \
+ bin/strm2oas \
+ bin/strmclip \
+ bin/strmcmp || die "Installation of binaries failed"
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds || die "Installation of gds testdata failed"
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot || die "Installation of oasis testdata failed"
+
+ if use ruby; then
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby || die "Installation of ruby testdata failed"
+ fi
+}
diff --git a/sci-electronics/klayout/metadata.xml b/sci-electronics/klayout/metadata.xml
new file mode 100644
index 000000000000..b0af9d37956b
--- /dev/null
+++ b/sci-electronics/klayout/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+</pkgmetadata>