summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-12-19 20:13:07 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-12-19 20:13:07 +0000
commitadf2c098e6e053456ef332ef18618dde945bdf9a (patch)
treebde8423246eacfd3ddb5a7f572703700ae330f31 /sci-electronics/eagle
parentRevision bump: add compatibility patch for kernel 3.11. Drop old (diff)
downloadgentoo-2-adf2c098e6e053456ef332ef18618dde945bdf9a.tar.gz
gentoo-2-adf2c098e6e053456ef332ef18618dde945bdf9a.tar.bz2
gentoo-2-adf2c098e6e053456ef332ef18618dde945bdf9a.zip
Bump, bug 448142. Add myself as maintainer.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sci-electronics/eagle')
-rw-r--r--sci-electronics/eagle/ChangeLog8
-rw-r--r--sci-electronics/eagle/eagle-6.5.0.ebuild116
-rw-r--r--sci-electronics/eagle/metadata.xml4
3 files changed, 127 insertions, 1 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 7c3a4211338c..533585565a69 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.57 2013/08/01 20:52:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.58 2013/12/19 20:13:07 idl0r Exp $
+
+*eagle-6.5.0 (19 Dec 2013)
+
+ 19 Dec 2013; Christian Ruppert <idl0r@gentoo.org> +eagle-6.5.0.ebuild,
+ metadata.xml:
+ Bump, bug 448142. Add myself as maintainer.
01 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> eagle-5.10.0-r1.ebuild,
eagle-5.11.0.ebuild:
diff --git a/sci-electronics/eagle/eagle-6.5.0.ebuild b/sci-electronics/eagle/eagle-6.5.0.ebuild
new file mode 100644
index 000000000000..5df39b92eba5
--- /dev/null
+++ b/sci-electronics/eagle/eagle-6.5.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-6.5.0.ebuild,v 1.1 2013/12/19 20:13:07 idl0r Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
+HOMEPAGE="http://www.cadsoft.de"
+SRC_URI="ftp://ftp.cadsoft.de/${PN}/program/${PV%\.[0-9]}/${PN}-lin-${PV}.run"
+
+LICENSE="cadsoft"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE="doc linguas_de linguas_zh"
+
+RESTRICT="strip"
+
+QA_PREBUILT="opt/eagle/bin/eagle"
+
+RDEPEND="sys-libs/glibc
+ x86? (
+ sys-libs/zlib
+ dev-libs/openssl
+ x11-libs/libXi
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ media-libs/freetype
+ media-libs/fontconfig
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ (
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXrender[abi_x86_32]
+ x11-libs/libXrandr[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32]
+ x11-libs/libXi[abi_x86_32]
+ media-libs/freetype[abi_x86_32]
+ media-libs/fontconfig[abi_x86_32]
+ )
+ app-emulation/emul-linux-x86-xlibs
+ )
+ )"
+
+# Append ${PV} since that's what upstream installs to
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="de";;
+ *)
+ MY_LANG="en";;
+esac
+
+src_unpack() {
+ # Extract the built-in .tar.bz2 file starting at __DATA__
+ sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
+}
+
+src_install() {
+ local installdir="/opt/eagle"
+
+ # Set MY_LANG for this function only since UPDATE_zh and README_zh
+ # don't exist
+ [[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
+
+ insinto $installdir
+ doins -r .
+
+ fperms 0755 ${installdir}/bin/eagle
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoftusa.com/training/faq/#3
+ exeinto /opt/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting $installdir and any
+ # arguments passed to the script (thanks Denilson)
+ echo "${installdir}/bin/eagle" '"$@"' >> "${D}/opt/bin/eagle"
+
+ # Install the documentation
+ cd doc
+ dodoc README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt
+ doman eagle.1
+
+ # Install extra documentation if requested
+ if use doc; then
+ dodoc {connect-device-split-symbol-${MY_INST_LANG},elektro-tutorial,manual_${MY_INST_LANG},tutorial_${MY_INST_LANG},layer-setup_designrules}.pdf
+ fi
+ # Remove docs left in $installdir
+ rm -rf "${D}${installdir}/doc"
+ cd "${S}"
+
+ echo -e "ROOTPATH=${installdir}/bin\nPRELINK_PATH_MASK=${installdir}" > "${S}/90eagle-${PV}"
+ doenvd "${S}/90eagle-${PV}"
+
+ # Create desktop entry
+ newicon bin/${PN}icon50.png ${PF}-icon50.png
+ make_desktop_entry "${ROOT}/opt/bin/eagle" "CadSoft EAGLE Layout Editor" ${PF}-icon50 "Graphics;Electronics"
+}
+
+pkg_postinst() {
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+ echo
+ ewarn "Due to some necessary changes in the data structure, once you edit"
+ ewarn "a file with version 6.x you will no longer be able to edit it"
+ ewarn "with versions prior to 6.0!"
+ ewarn
+ ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 5.xx/4.xx."
+}
diff --git a/sci-electronics/eagle/metadata.xml b/sci-electronics/eagle/metadata.xml
index 99ecb803dc05..e99012ea5f3c 100644
--- a/sci-electronics/eagle/metadata.xml
+++ b/sci-electronics/eagle/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-electronics</herd>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
<longdescription>EAGLE (Easily Applicable Graphical Layout Editor)
is a powerful tool for creating printed circuit boards (PCBs).
It requires a 586 (or higher), kernel 2.x (or higher), and