summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-02 06:06:41 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-02 06:06:41 +0000
commitb9a6b0b9f16adef29ce107219a04e64b71bdb008 (patch)
tree196c1600cb61a08947039a88a2fc119d43204b6f /sci-chemistry
parentRe-add x32 support from v3.4-rc1. (diff)
downloadgentoo-2-b9a6b0b9f16adef29ce107219a04e64b71bdb008.tar.gz
gentoo-2-b9a6b0b9f16adef29ce107219a04e64b71bdb008.tar.bz2
gentoo-2-b9a6b0b9f16adef29ce107219a04e64b71bdb008.zip
Drop tk version restriction, move to EAPI=4
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gopenmol/ChangeLog8
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild46
-rw-r--r--sci-chemistry/gopenmol/metadata.xml2
3 files changed, 26 insertions, 30 deletions
diff --git a/sci-chemistry/gopenmol/ChangeLog b/sci-chemistry/gopenmol/ChangeLog
index 71a80b0005fa..bbba41fd68f1 100644
--- a/sci-chemistry/gopenmol/ChangeLog
+++ b/sci-chemistry/gopenmol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gopenmol
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.11 2010/11/08 17:12:40 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.12 2012/04/02 06:06:41 jlec Exp $
+
+ 02 Apr 2012; Justin Lecher <jlec@gentoo.org> gopenmol-3.00-r2.ebuild,
+ metadata.xml:
+ Drop tk version restriction, move to EAPI=4
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org>
-gopenmol-3.00-r1.ebuild, gopenmol-3.00-r2.ebuild:
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
index 8f6c2adaa258..7f5e4913bd89 100644
--- a/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
+++ b/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild,v 1.4 2010/11/08 17:12:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00-r2.ebuild,v 1.5 2012/04/02 06:06:41 jlec Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="2"
inherit eutils multilib prefix python
DESCRIPTION="Tool for the visualization and analysis of molecular structures"
-HOMEPAGE="http://www.csc.fi/gopenmol"
+HOMEPAGE="http://www.csc.fi/gopenmol/"
SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
- =dev-lang/tk-8.4*
+ dev-lang/tk
dev-tcltk/bwidget
- virtual/jpeg
media-libs/freeglut
+ virtual/jpeg
virtual/opengl
x11-libs/libICE
x11-libs/libXau
@@ -29,47 +29,39 @@ RDEPEND="
x11-libs/libXi
x11-libs/libXmu
x11-libs/libXxf86vm"
-
DEPEND="${RDEPEND}"
S="${WORKDIR}/gOpenMol-${PV}/src"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
- epatch "${FILESDIR}"/${PV}-include-config-for-plugins.patch
- epatch "${FILESDIR}"/${PV}-multilib.patch
+ epatch \
+ "${FILESDIR}"/${PV}-include-config-for-plugins.patch \
+ "${FILESDIR}"/${PV}-multilib.patch
sed \
-e "s:GENTOOLIBDIR:$(get_libdir):g" \
- -i config.mk.ac plugins/config.mk.ac
+ -i config.mk.ac plugins/config.mk.ac || die
sed "/GOM_TEMP/s:^.*$:GOM_TEMP=\"${EPREFIX}/tmp/:g" -i ../environment.txt || die
}
src_compile() {
- emake || die "emake failed"
+ default
- # Plugins are not built by default
- cd "${S}"/plugins
- emake || die "emake plugins failed"
-
- # Utilities are not built by default
- cd "${S}"/utility
- emake || die "emake utility failed"
+ # Plugins and Utilities are not built by default
+ cd "${S}"/plugins && emake
+ cd "${S}"/utility && emake
}
src_install() {
- einstall || die "einstall failed"
-
- cd "${S}"/plugins
- einstall || die "einstall plugins failed"
-
- cd "${S}"/utility
- einstall || die "einstall utility failed"
+ einstall
- dosed /usr/bin/rungOpenMol
+ cd "${S}"/plugins && einstall
+ cd "${S}"/utility && einstall
dosym ../$(get_libdir)/gOpenMol-${PV}/bin/${PN} /usr/bin/${PN}
diff --git a/sci-chemistry/gopenmol/metadata.xml b/sci-chemistry/gopenmol/metadata.xml
index 9ac9ffdb3a41..e42d0af60f42 100644
--- a/sci-chemistry/gopenmol/metadata.xml
+++ b/sci-chemistry/gopenmol/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>