summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-27 08:49:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-27 08:49:17 +0000
commit95a4b30cc6da4f14fd5a205466110424bff30279 (patch)
tree7f8eb8c2abb095db56d1ae7a743a25ede80bd3f1 /sci-chemistry
parentVersion bump wrt #311573 by Michael Weber. (diff)
downloadgentoo-2-95a4b30cc6da4f14fd5a205466110424bff30279.tar.gz
gentoo-2-95a4b30cc6da4f14fd5a205466110424bff30279.tar.bz2
gentoo-2-95a4b30cc6da4f14fd5a205466110424bff30279.zip
New Ebuild requested per bug 309737
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/ChangeLog10
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/files/gentoo.patch85
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/metadata.xml18
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild63
4 files changed, 176 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-ezviz/ChangeLog b/sci-chemistry/pymol-plugins-ezviz/ChangeLog
new file mode 100644
index 000000000000..8f4cb05944ba
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-ezviz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/pymol-plugins-ezviz
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-ezviz/ChangeLog,v 1.1 2010/03/27 08:49:17 jlec Exp $
+
+*pymol-plugins-ezviz-1.0.2005 (27 Mar 2010)
+
+ 27 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-plugins-ezviz-1.0.2005.ebuild, +files/gentoo.patch, +metadata.xml:
+ New Ebuild requested per 309737
+
diff --git a/sci-chemistry/pymol-plugins-ezviz/files/gentoo.patch b/sci-chemistry/pymol-plugins-ezviz/files/gentoo.patch
new file mode 100644
index 000000000000..ba28af325c21
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-ezviz/files/gentoo.patch
@@ -0,0 +1,85 @@
+diff --git a/ez-viz.py b/ez-viz.py
+index 1d8e847..8d50e6b 100755
+--- a/ez-viz.py
++++ b/ez-viz.py
+@@ -363,27 +363,27 @@ class PGUI:
+ global splash
+
+ # Images used in Presets tab
+- defaultImage = PhotoImage( file="modules\pmg_tk\startup\default.gif")
+- chains = PhotoImage(file="modules\pmg_tk\startup\chains.GIF")
+- heteroImg = PhotoImage(file="modules\pmg_tk\startup\heteroAtom.GIF")
+- ballStickImg = PhotoImage(file="C:\Program Files\DeLano Scientific\PyMOL\modules\pmg_tk\startup\showBallStick.GIF")
+- surfaceImg = PhotoImage(file="modules\pmg_tk\startup\surface.GIF")
+- polarityImg = PhotoImage(file="modules\pmg_tk\startup\polarity.GIF")
+- puttyImg = PhotoImage(file="modules\pmg_tk\startup\putty.GIF")
+- aromaticsImg = PhotoImage(file="modules\pmg_tk\startup\showAromatics.GIF")
+- dnaImg = PhotoImage(file="modules\pmg_tk\startup\dna.GIF")
++ defaultImage = PhotoImage( file="GENTOOPYMOL/pmg_tk/startup/ez-viz/default.gif")
++ chains = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/chains.gif")
++ heteroImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/heteroAtom.gif")
++ ballStickImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/showBallStick.gif")
++ surfaceImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/surface.gif")
++ polarityImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/polarity.gif")
++ puttyImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/putty.gif")
++ aromaticsImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/showAromatics.gif")
++ dnaImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/dna.gif")
+
+ # Movie tab images
+- ligand = PhotoImage(file="modules\pmg_tk\startup\zoom.GIF")
+- build = PhotoImage(file="modules\pmg_tk\startup\prot.GIF")
+- chainsMovieImg = PhotoImage(file="modules\pmg_tk\startup\chainsMovie.GIF")
+- rotateImg = PhotoImage(file="modules\pmg_tk\startup\Rotate.GIF")
+- playButton = PhotoImage(file="modules\pmg_tk\startup\play.GIF")
+- stopButton = PhotoImage(file="modules\pmg_tk\startup\stop.GIF")
+- rewindButton = PhotoImage(file="modules\pmg_tk\startup\Rewind.GIF")
++ ligand = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/zoom.gif")
++ build = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/prot.gif")
++ chainsMovieImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/chainsMovie.gif")
++ rotateImg = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/Rotate.gif")
++ playButton = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/play.gif")
++ stopButton = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/stop.gif")
++ rewindButton = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/Rewind.gif")
+
+ # Welcome tab image
+- splash = PhotoImage(file="modules\pmg_tk\startup\splash.GIF")
++ splash = PhotoImage(file="GENTOOPYMOL/pmg_tk/startup/ez-viz/splash.gif")
+ #--------------------------------------#
+ # #
+ # PRESETS METHODS #
+@@ -1035,7 +1035,7 @@ class PGUI:
+ if tkMessageBox.askyesno('Ray Trace Image', "Do you want to ray trace you image before saving it? Depending on your image "+
+ "this make take a few minutes if you select yes."):
+ cmd.ray()
+- file = tkFileDialog.asksaveasfilename(defaultextension=".png", initialdir="C:/Program Files/DeLano Scientific/PyMOL/")
++ file = tkFileDialog.asksaveasfilename(defaultextension=".png", initialdir="./")
+ if len(file)>0:
+ cmd.save(file)
+
+@@ -1045,7 +1045,7 @@ class PGUI:
+ import tkFileDialog
+ import tkMessageBox
+
+- file = tkFileDialog.asksaveasfilename(defaultextension=".pse", initialdir='C:/Program Files/Delano Scientific/PyMOL/')
++ file = tkFileDialog.asksaveasfilename(defaultextension=".pse", initialdir='./')
+ print file
+ if len(file)>0:
+ cmd.save(file)
+@@ -1574,7 +1574,7 @@ class PGUI:
+ #------Open Help File---------#
+ def help(self):
+ import webbrowser
+- webbrowser.open('modules\pmg_tk\startup\Help\EZ-VizWebMain.html')
++ webbrowser.open('GENTOOPYMOL/pmg_tk/startup/ez-vizHelp\EZ-VizWebMain.html')
+
+ #---------------------------------------------------------------#
+ # #
+@@ -2188,7 +2188,7 @@ class PGUI:
+ import tkFileDialog
+
+ if result == 'Open':
+- file=tkFileDialog.askopenfilename(initialdir='C:/Documents and Settings/Administrator/My Documents/')
++ file=tkFileDialog.askopenfilename(initialdir='./')
+ if file:
+ cmd.load(file)
+ self.pdbCode = file
diff --git a/sci-chemistry/pymol-plugins-ezviz/metadata.xml b/sci-chemistry/pymol-plugins-ezviz/metadata.xml
new file mode 100644
index 000000000000..bfccced9410e
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-ezviz/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+ EZ-Viz was developed as an assistance tool for the difficult to
+ understand user interface of PyMOL. The standard interface is
+ very complex takes a long time to learn, especially for students
+ unfamiliar with the chemistry and busy researchers with little
+ time to learn the commands necessary to use the PyMOL software
+ to its full extent. EZ-Viz allows for users to navigate through
+ PyMOL using a series of clickable buttons and tabs to complete
+ all functions of the PyMol software without ever having to type
+ a single command.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild
new file mode 100644
index 000000000000..eecaef8837f7
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild,v 1.1 2010/03/27 08:49:17 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+DESCRIPTION="assistance tool for the difficult to understand user interface of PyMOL"
+HOMEPAGE="http://www.rit.edu/cos/ezviz/index.html"
+SRC_URI="
+ mirror://gentoo/${P}.zip
+ mirror://gentoo/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="as-is"
+IUSE="doc"
+
+RDEPEND="sci-chemistry/pymol"
+DEPEND="
+ app-arch/unzip
+ ${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/EZ_Viz Folder"
+
+src_prepare() {
+ edos2unix ez-viz.py
+ python_copy_sources
+ preperation() {
+ epatch "${FILESDIR}"/gentoo.patch
+ sed \
+ -e "s:GENTOOPYMOL:${EPREFIX}/$(python_get_sitedir):g" \
+ -i ez-viz.py || die
+ }
+ python_execute_function -s preperation
+}
+
+src_install() {
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins *.py || die
+ insinto $(python_get_sitedir)/pmg_tk/startup/ez-viz/
+ doins *.gif || die
+ for gif in *.GIF; do
+ newins ${gif} ${gif/.GIF/.gif} || die
+ done
+ }
+ python_execute_function -s installation
+ dodoc readme.txt || die
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup
+}