summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 11:19:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 11:19:03 +0000
commit83115f8c746a5b14446be533215801e3097d8350 (patch)
treeafe196182c1dac6a2164d341eee8f2df73338600 /sci-chemistry
parentSimplify src_test(). (diff)
downloadgentoo-2-83115f8c746a5b14446be533215801e3097d8350.tar.gz
gentoo-2-83115f8c746a5b14446be533215801e3097d8350.tar.bz2
gentoo-2-83115f8c746a5b14446be533215801e3097d8350.zip
Moved to EAPI=3 for PREFIX support, keyworded for *-linux, tested by me
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molmol/ChangeLog10
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2-r1.ebuild69
2 files changed, 77 insertions, 2 deletions
diff --git a/sci-chemistry/molmol/ChangeLog b/sci-chemistry/molmol/ChangeLog
index a56e34296533..97ef0cc90dde 100644
--- a/sci-chemistry/molmol/ChangeLog
+++ b/sci-chemistry/molmol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/molmol
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.17 2009/09/18 15:01:49 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.18 2010/03/07 11:19:03 jlec Exp $
+
+*molmol-2k_p2-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +molmol-2k_p2-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, keyworded for *-linux, tested by me
18 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> molmol-2k_p2.ebuild:
Migrate to EAPI 2 in order to remove built_with_use usage.
diff --git a/sci-chemistry/molmol/molmol-2k_p2-r1.ebuild b/sci-chemistry/molmol/molmol-2k_p2-r1.ebuild
new file mode 100644
index 000000000000..2dc8184afede
--- /dev/null
+++ b/sci-chemistry/molmol/molmol-2k_p2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r1.ebuild,v 1.1 2010/03/07 11:19:03 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs multilib
+
+MY_PV="${PV/_p/.}.0"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Publication-quality molecular visualization package"
+HOMEPAGE="http://hugin.ethz.ch/wuthrich/software/molmol/index.html"
+SRC_URI="ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-src.tar.gz
+ ftp://ftp.mol.biol.ethz.ch/software/MOLMOL/unix-gzip/${MY_P}-doc.tar.gz"
+LICENSE="molmol"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="x11-libs/openmotif
+ x11-libs/libXpm
+ media-libs/mesa[motif]
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/libpng
+ sys-libs/zlib"
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+# Yeah, the gz's aren't in a subdir.
+S=${WORKDIR}
+
+MMDIR="/usr/$(get_libdir)/molmol"
+
+src_prepare() {
+ # Patch from http://pjf.net/science/molmol.html, where src.rpm is provided
+ epatch ${FILESDIR}/pjf_RH9_molmol2k2.diff
+
+ ln -s makedef.lnx ${S}/makedef
+
+ # 1) The Korn shell is only taken by default because the Bourne shell
+ # on DEC systems cannot handle the script.
+ # We don't want this needless dependency.
+ # 2) Fix up MOLMOLHOME, which determines the directory the binary's in.
+ sed -i \
+ -e "s:/bin/ksh:${EPREFIX}/bin/sh:" \
+ -e "s:^MOLMOLHOME.*:MOLMOLHOME=${EPREFIX}/${MMDIR}:" \
+ ${S}/molmol
+ # 1) Set CFLAGS.
+ # 2) Set compiler.
+ sed -i \
+ -e "s:^MCFLAGS.*:MCFLAGS = ${CFLAGS}:" \
+ -e "s:^CC.*:CC = $(tc-getCC):" \
+ ${S}/makedef
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin molmol || die
+
+ exeinto ${MMDIR}
+ newexe src/main/molmol molmol.lnx || die
+ insinto ${MMDIR}
+ doins -r auxil help macros man setup tips || die
+
+ dodoc HISTORY README || die
+}