summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-17 11:34:50 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-17 11:34:50 +0000
commit9d4495ed2acb0e54fcf2adde276ba0fc2cf95183 (patch)
treef71e879a71f62ceeede968d487dacc26ab699e02 /sci-chemistry/xdsi
parent[www-client/arora] resurrected 0.10.1 - most recent version that supports Qt 4.5 (diff)
downloadgentoo-2-9d4495ed2acb0e54fcf2adde276ba0fc2cf95183.tar.gz
gentoo-2-9d4495ed2acb0e54fcf2adde276ba0fc2cf95183.tar.bz2
gentoo-2-9d4495ed2acb0e54fcf2adde276ba0fc2cf95183.zip
New ebuild for xdsi
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/xdsi')
-rw-r--r--sci-chemistry/xdsi/ChangeLog10
-rw-r--r--sci-chemistry/xdsi/files/0.91-gentoo.patch24
-rw-r--r--sci-chemistry/xdsi/metadata.xml17
-rw-r--r--sci-chemistry/xdsi/xdsi-0.91.ebuild49
4 files changed, 100 insertions, 0 deletions
diff --git a/sci-chemistry/xdsi/ChangeLog b/sci-chemistry/xdsi/ChangeLog
new file mode 100644
index 000000000000..75c3d38bd013
--- /dev/null
+++ b/sci-chemistry/xdsi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/xdsi
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsi/ChangeLog,v 1.1 2010/02/17 11:34:49 jlec Exp $
+
+*xdsi-0.91 (17 Feb 2010)
+
+ 17 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/0.91-gentoo.patch, +xdsi-0.91.ebuild, +metadata.xml:
+ Initial addition
+
diff --git a/sci-chemistry/xdsi/files/0.91-gentoo.patch b/sci-chemistry/xdsi/files/0.91-gentoo.patch
new file mode 100644
index 000000000000..a21752bf5f68
--- /dev/null
+++ b/sci-chemistry/xdsi/files/0.91-gentoo.patch
@@ -0,0 +1,24 @@
+diff --git a/xdsi b/xdsi
+index 2fcc543..2ce8262 100755
+--- a/xdsi
++++ b/xdsi
+@@ -20,8 +20,8 @@
+ ####################################################################
+ # These are the only two things you may change#
+
+-set Templates "/mydir/templates"
+-set initial "/mydir/SLS-2009"
++set Templates "GENTOOTEMPLATE"
++set initial "./"
+
+
+ ####################################################################
+@@ -122,7 +122,7 @@ return 1
+ }
+
+
+-CheckExecutables "kpdf gnuplot xds_par xdsstat xdsviewer convert pointless ipmosflm VIEW"
++CheckExecutables "xpdf gnuplot xds_par xdsviewer convert pointless ipmosflm"
+
+ wm resizable . 0 0
+
diff --git a/sci-chemistry/xdsi/metadata.xml b/sci-chemistry/xdsi/metadata.xml
new file mode 100644
index 000000000000..42fa47ea8165
--- /dev/null
+++ b/sci-chemistry/xdsi/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+XDSi offers you the possibility to process all your datasets in a given directory with minimum effort.
+* You just have to provide it with a resultdirectory and the directory where your frames are stored.
+* All datasets consisting of more than 100 frames within the given directory and all its subdirectories will be processed.
+* For each dataset a space group assignment is done using POINTLESS of the CCP4 software package
+* Plots of the most informative statistics of INTEGRATE.LP, CORRECT.LP and XDSSTAT.LP are generated for each dataset
+* A plot comparing Rmeas, I/sig and Completeness of all the processed datasets is generated
+* You can also generate plots for datasets that have been processed using XDS without XDSi
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/xdsi/xdsi-0.91.ebuild b/sci-chemistry/xdsi/xdsi-0.91.ebuild
new file mode 100644
index 000000000000..fdd6d406900c
--- /dev/null
+++ b/sci-chemistry/xdsi/xdsi-0.91.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsi/xdsi-0.91.ebuild,v 1.1 2010/02/17 11:34:49 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A crude interface for running the XDS"
+HOMEPAGE="http://strucbio.biologie.uni-konstanz.de/xdswiki/index.php/Xdsi"
+SRC_URI="ftp://turn14.biologie.uni-konstanz.de/pub/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/mosflm
+ sci-chemistry/xds-bin[smp]
+ sci-chemistry/pointless
+ sci-visualization/xds-viewer
+ sci-visualization/gnuplot
+ media-gfx/imagemagick
+ app-text/xpdf
+ dev-lang/tk"
+# Need to clarified for licensing
+# sci-chemistry/xdsstat-bin
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed "s:GENTOOTEMPLATE:${EPREFIX}/usr/share/${PN}/templates:g" -i ${PN} \
+ || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ insinto /usr/share/${PN}/templates
+ doins templates/{*.INP,bohr*,fortran,pauli,info.png,*.pck,tablesf_xdsi} || die
+ dodoc templates/*.pdf || die
+}
+
+pkg_postinst() {
+ elog "Documentation can be found here:"
+ elog "ftp://turn14.biologie.uni-konstanz.de/pub/xdsi/xdsi_doc_print.pdf"
+}