summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-08-14 15:17:01 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-08-14 15:17:01 +0000
commit2e7fb1dc7d73e3238951895bd786bdd28d25b643 (patch)
tree2afe5003f6d2e051fc306c6f47c58dc60bfd64df /sci-chemistry/votca-csg
parentrenamed boost useflag and removed old (diff)
downloadgentoo-2-2e7fb1dc7d73e3238951895bd786bdd28d25b643.tar.gz
gentoo-2-2e7fb1dc7d73e3238951895bd786bdd28d25b643.tar.bz2
gentoo-2-2e7fb1dc7d73e3238951895bd786bdd28d25b643.zip
renamed boost useflag and removed old
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog6
-rw-r--r--sci-chemistry/votca-csg/metadata.xml4
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.1.1.ebuild82
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.1.2.ebuild82
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.2.ebuild13
5 files changed, 15 insertions, 172 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
index 8a6cf7579f6a..f88ca3a2739c 100644
--- a/sci-chemistry/votca-csg/ChangeLog
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/votca-csg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.6 2011/07/17 12:46:17 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.7 2011/08/14 15:17:01 ottxor Exp $
+
+ 14 Aug 2011; Christoph Junghans <ottxor@gentoo.org> -votca-csg-1.1.1.ebuild,
+ -votca-csg-1.1.2.ebuild, votca-csg-1.2.ebuild, metadata.xml:
+ renamed boost useflag to system-boost and removed old
17 Jul 2011; Christoph Junghans <ottxor@gentoo.org> votca-csg-1.2.ebuild:
Added IUSE=examples
diff --git a/sci-chemistry/votca-csg/metadata.xml b/sci-chemistry/votca-csg/metadata.xml
index 7daef59af41e..2b261601af3e 100644
--- a/sci-chemistry/votca-csg/metadata.xml
+++ b/sci-chemistry/votca-csg/metadata.xml
@@ -7,7 +7,7 @@
<name>Christoph Junghans</name>
</maintainer>
<use>
- <flag name='boost'>Compile against external boost headers (dev-libs/boost)</flag>
- <flag name='gromacs'>Add support for file formats from <pkg>sci-chemistry/gromacs</pkg></flag>
+ <flag name='gromacs'>Add support for gromacs file formats through <pkg>sci-chemistry/gromacs</pkg></flag>
+ <flag name='system-boost'>Use system boost (<pkg>dev-libs/boost</pkg>) instead of bundled one</flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/votca-csg/votca-csg-1.1.1.ebuild b/sci-chemistry/votca-csg/votca-csg-1.1.1.ebuild
deleted file mode 100644
index 669182395b73..000000000000
--- a/sci-chemistry/votca-csg/votca-csg-1.1.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.1.1.ebuild,v 1.2 2011/03/09 22:12:21 ottxor Exp $
-
-EAPI="3"
-
-inherit autotools-utils bash-completion
-
-MANUAL_PV=1.1
-if [ "${PV}" != "9999" ]; then
- SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
- doc? ( http://votca.googlecode.com/files/votca-manual-${MANUAL_PV}.pdf )"
- RESTRICT="primaryuri"
-else
- SRC_URI=""
- inherit mercurial
- EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
- S="${WORKDIR}/${EHG_REPO_URI##*/}"
- PDEPEND="doc? ( =app-doc/votca-manual-${PV} )"
-fi
-
-DESCRIPTION="Votca coarse-graining engine"
-HOMEPAGE="http://www.votca.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +gromacs static-libs"
-
-RDEPEND="=sci-libs/votca-tools-${PV}
- gromacs? ( >=sci-chemistry/gromacs-4.0.7-r5 )
- dev-lang/perl
- app-shells/bash"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[-nodot] )
- >=app-text/txt2tags-2.5
- dev-util/pkgconfig"
-
-src_prepare() {
- #from bootstrap.sh
- if [ -z "${PV##*9999}" ]; then
- emake -C share/scripts/inverse -f Makefile.am.in Makefile.am || die
- fi
-
- eautoreconf || die "eautoreconf failed"
-}
-
-src_configure() {
- local libgmx
-
- #in >gromacs-4.5 libgmx was renamed to libgromacs
- has_version =sci-chemistry/gromacs-9999 && libgmx="libgromacs" || libgmx="libgmx"
- #prefer gromacs double-precision if it is there
- has_version sci-chemistry/gromacs[double-precision] && libgmx="${libgmx}_d"
-
- myeconfargs=( ${myconf} --disable-rc-files $(use_with gromacs libgmx $libgmx) )
- autotools-utils_src_configure || die
-}
-
-src_install() {
- DOCS=(README NOTICE ${AUTOTOOLS_BUILD_DIR}/CHANGELOG)
- dobashcompletion scripts/csg-completion.bash ${PN} || die
- autotools-utils_src_install || die
- if use doc; then
- if [ -n "${PV##*9999}" ]; then
- dodoc "${DISTDIR}/votca-manual-${MANUAL_PV}.pdf" || die
- fi
- cd share/doc || die
- doxygen || die
- dohtml -r html/* || die
- fi
-}
-
-pkg_postinst() {
- elog
- elog "Please read and cite:"
- elog "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
- elog "http://dx.doi.org/10.1021/ct900369w"
- elog
- bash-completion_pkg_postinst
-}
diff --git a/sci-chemistry/votca-csg/votca-csg-1.1.2.ebuild b/sci-chemistry/votca-csg/votca-csg-1.1.2.ebuild
deleted file mode 100644
index c6e7ffc5114c..000000000000
--- a/sci-chemistry/votca-csg/votca-csg-1.1.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.1.2.ebuild,v 1.1 2011/04/04 20:05:31 ottxor Exp $
-
-EAPI="3"
-
-inherit autotools-utils bash-completion
-
-MANUAL_PV=1.1
-if [ "${PV}" != "9999" ]; then
- SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
- doc? ( http://votca.googlecode.com/files/votca-manual-${MANUAL_PV}.pdf )"
- RESTRICT="primaryuri"
-else
- SRC_URI=""
- inherit mercurial
- EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
- S="${WORKDIR}/${EHG_REPO_URI##*/}"
- PDEPEND="doc? ( =app-doc/votca-manual-${PV} )"
-fi
-
-DESCRIPTION="Votca coarse-graining engine"
-HOMEPAGE="http://www.votca.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +gromacs static-libs"
-
-RDEPEND="=sci-libs/votca-tools-${PV}
- gromacs? ( >=sci-chemistry/gromacs-4.0.7-r5 )
- dev-lang/perl
- app-shells/bash"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[-nodot] )
- >=app-text/txt2tags-2.5
- dev-util/pkgconfig"
-
-src_prepare() {
- #from bootstrap.sh
- if [ -z "${PV##*9999}" ]; then
- emake -C share/scripts/inverse -f Makefile.am.in Makefile.am || die
- fi
-
- eautoreconf || die "eautoreconf failed"
-}
-
-src_configure() {
- local libgmx
-
- #in >gromacs-4.5 libgmx was renamed to libgromacs
- has_version =sci-chemistry/gromacs-9999 && libgmx="libgromacs" || libgmx="libgmx"
- #prefer gromacs double-precision if it is there
- has_version sci-chemistry/gromacs[double-precision] && libgmx="${libgmx}_d"
-
- myeconfargs=( ${myconf} --disable-rc-files $(use_with gromacs libgmx $libgmx) )
- autotools-utils_src_configure || die
-}
-
-src_install() {
- DOCS=(README NOTICE ${AUTOTOOLS_BUILD_DIR}/CHANGELOG)
- dobashcompletion scripts/csg-completion.bash ${PN} || die
- autotools-utils_src_install || die
- if use doc; then
- if [ -n "${PV##*9999}" ]; then
- dodoc "${DISTDIR}/votca-manual-${MANUAL_PV}.pdf" || die
- fi
- cd share/doc || die
- doxygen || die
- dohtml -r html/* || die
- fi
-}
-
-pkg_postinst() {
- elog
- elog "Please read and cite:"
- elog "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
- elog "http://dx.doi.org/10.1021/ct900369w"
- elog
- bash-completion_pkg_postinst
-}
diff --git a/sci-chemistry/votca-csg/votca-csg-1.2.ebuild b/sci-chemistry/votca-csg/votca-csg-1.2.ebuild
index e998195aae1d..4b05ee2b3f01 100644
--- a/sci-chemistry/votca-csg/votca-csg-1.2.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.ebuild,v 1.2 2011/07/17 12:46:17 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.ebuild,v 1.3 2011/08/14 15:17:01 ottxor Exp $
EAPI=4
@@ -8,6 +8,7 @@ inherit bash-completion cmake-utils
MANUAL_PV=1.2
TUTORIAL_PV=1.2
+IUSE="doc examples +gromacs +system-boost"
if [ "${PV}" != "9999" ]; then
SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
doc? ( http://votca.googlecode.com/files/votca-manual-${MANUAL_PV}.pdf )
@@ -15,12 +16,15 @@ if [ "${PV}" != "9999" ]; then
RESTRICT="primaryuri"
else
SRC_URI=""
+ #make this a common use when csg-apps get released
+ IUSE="${IUSE} extras"
inherit mercurial
EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
EHG_REVISION="default"
S="${WORKDIR}/${EHG_REPO_URI##*/}"
PDEPEND="doc? ( =app-doc/votca-csg-manual-${PV} )
- examples? ( =sci-chemistry/votca-csg-tutorials-${PV} )"
+ examples? ( =sci-chemistry/votca-csg-tutorials-${PV} )
+ extras? ( =sci-chemistry/votca-csg-apps-${PV} )"
fi
DESCRIPTION="Votca coarse-graining engine"
@@ -29,9 +33,8 @@ HOMEPAGE="http://www.votca.org"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="-boost doc examples +gromacs"
-RDEPEND="=sci-libs/votca-tools-${PV}[boost=]
+RDEPEND="=sci-libs/votca-tools-${PV}[system-boost=]
gromacs? ( sci-chemistry/gromacs )
dev-lang/perl
app-shells/bash"
@@ -48,7 +51,7 @@ src_configure() {
extra="-DWITH_GMX_DEVEL=ON"
mycmakeargs=(
- $(cmake-utils_use boost EXTERNAL_BOOST)
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
$(cmake-utils_use_with gromacs GMX)
${extra}
-DWITH_RC_FILES=OFF