summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-01-11 04:11:09 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-01-11 04:11:09 +0000
commit6e016acf96b9d9783c4051a98188bd075ad96c0e (patch)
treea0a2f94d69df5f822a85540c62a097576f32b4ee /sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild
parentversion bump (diff)
downloadgentoo-2-6e016acf96b9d9783c4051a98188bd075ad96c0e.tar.gz
gentoo-2-6e016acf96b9d9783c4051a98188bd075ad96c0e.tar.bz2
gentoo-2-6e016acf96b9d9783c4051a98188bd075ad96c0e.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild b/sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild
new file mode 100644
index 000000000000..65368d21e72c
--- /dev/null
+++ b/sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.2.ebuild,v 1.1 2012/01/11 04:11:09 ottxor Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc examples extras +gromacs +system-boost"
+PDEPEND="extras? ( =sci-chemistry/votca-csgapps-${PV} )"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
+ doc? ( http://votca.googlecode.com/files/${PN}-manual-${PV}.pdf )
+ examples? ( http://votca.googlecode.com/files/${PN}-tutorials-${PV}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+ PDEPEND="${PDEPEND} doc? ( =app-doc/${PN}-manual-${PV} )
+ examples? ( =sci-chemistry/${PN}-tutorials-${PV} )"
+fi
+
+DESCRIPTION="Votca coarse-graining engine"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/votca-tools-${PV}[system-boost=]
+ gromacs? ( sci-chemistry/gromacs )
+ dev-lang/perl
+ app-shells/bash"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+ >=app-text/txt2tags-2.5
+ dev-util/pkgconfig"
+
+src_configure() {
+ local extra="-DWITH_GMX_DEVEL=OFF"
+
+ use gromacs && has_version =sci-chemistry/gromacs-9999 && \
+ extra="-DWITH_GMX_DEVEL=ON"
+
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ $(cmake-utils_use_with gromacs GMX)
+ ${extra}
+ -DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ DOCS=(README NOTICE ${CMAKE_BUILD_DIR}/CHANGELOG)
+ newbashcomp scripts/csg-completion.bash ${PN}
+ cmake-utils_src_install
+ if use doc; then
+ if [ -n "${PV##*9999}" ]; then
+ dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ fi
+ cd "${CMAKE_BUILD_DIR}" || die
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/*
+ fi
+ if use examples && [ -n "${PV##*9999}" ]; then
+ insinto "/usr/share/doc/${PF}/tutorials"
+ docompress -x "/usr/share/doc/${PF}/tutorials"
+ doins -r "${WORKDIR}/${PN}-tutorials-${PV}"/*
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "http://dx.doi.org/10.1021/ct900369w"
+ einfo
+}