summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-06 10:07:11 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-06 10:07:11 +0000
commitef8c7047ec7035ac20c33b15ab7cfad1cb59799a (patch)
treefa246972097c4142107a8616d4d163a4b4411ccf /sci-chemistry/vmd
parentrevbump after bugfix 541830 (diff)
downloadgentoo-2-ef8c7047ec7035ac20c33b15ab7cfad1cb59799a.tar.gz
gentoo-2-ef8c7047ec7035ac20c33b15ab7cfad1cb59799a.tar.bz2
gentoo-2-ef8c7047ec7035ac20c33b15ab7cfad1cb59799a.zip
Version BUmp; install optional plugins, #517886
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog9
-rw-r--r--sci-chemistry/vmd/files/vmd-1.9.2-format-security.patch16
-rw-r--r--sci-chemistry/vmd/metadata.xml3
-rw-r--r--sci-chemistry/vmd/vmd-1.9.1.ebuild217
-rw-r--r--sci-chemistry/vmd/vmd-1.9.2.ebuild (renamed from sci-chemistry/vmd/vmd-1.9.1-r2.ebuild)117
5 files changed, 97 insertions, 265 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 65e0c55ad45d..91c14a83b476 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.60 2015/02/10 02:23:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.61 2015/03/06 10:07:11 jlec Exp $
+
+*vmd-1.9.2 (06 Mar 2015)
+
+ 06 Mar 2015; Justin Lecher <jlec@gentoo.org>
+ +files/vmd-1.9.2-format-security.patch, +vmd-1.9.2.ebuild,
+ -vmd-1.9.1-r2.ebuild, -vmd-1.9.1.ebuild, metadata.xml:
+ Version BUmp; install optional plugins, #517886
10 Feb 2015; Patrick Lauer <patrick@gentoo.org> -vmd-1.9.1-r1.ebuild:
Remove version with unsatisfiable dependencies
diff --git a/sci-chemistry/vmd/files/vmd-1.9.2-format-security.patch b/sci-chemistry/vmd/files/vmd-1.9.2-format-security.patch
new file mode 100644
index 000000000000..3f9ea5c8c2ef
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.9.2-format-security.patch
@@ -0,0 +1,16 @@
+ plugins/molfile_plugin/src/maeffplugin.cxx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/molfile_plugin/src/maeffplugin.cxx b/plugins/molfile_plugin/src/maeffplugin.cxx
+index cfe1223..41d92bb 100644
+--- a/plugins/molfile_plugin/src/maeffplugin.cxx
++++ b/plugins/molfile_plugin/src/maeffplugin.cxx
+@@ -1979,7 +1979,7 @@ namespace {
+ }
+ }
+ catch (std::exception &e) {
+- fprintf(stderr, e.what());
++ fprintf(stderr, "%s", e.what());
+ return MOLFILE_ERROR;
+ }
+ return MOLFILE_SUCCESS;
diff --git a/sci-chemistry/vmd/metadata.xml b/sci-chemistry/vmd/metadata.xml
index b9b5a0649de6..4b17d8d6b913 100644
--- a/sci-chemistry/vmd/metadata.xml
+++ b/sci-chemistry/vmd/metadata.xml
@@ -7,9 +7,10 @@
</maintainer>
<herd>sci-chemistry</herd>
<use>
+ <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
+ <flag name="gromacs">Add support for TNG file format</flag>
<flag name="msms">Add support for MSMS SAS calcualtion tool</flag>
<flag name="povray">Add support for povray raytracer for HQ images</flag>
<flag name="tachyon">Add support for tachyon raytracer for HQ images</flag>
- <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/vmd/vmd-1.9.1.ebuild b/sci-chemistry/vmd/vmd-1.9.1.ebuild
deleted file mode 100644
index 5e6d70abcd24..000000000000
--- a/sci-chemistry/vmd/vmd-1.9.1.ebuild
+++ /dev/null
@@ -1,217 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.1.ebuild,v 1.7 2013/03/01 08:23:03 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-
-inherit eutils multilib python toolchain-funcs
-
-DESCRIPTION="Visual Molecular Dynamics"
-HOMEPAGE="http://www.ks.uiuc.edu/Research/vmd/"
-SRC_URI="
- mirror://gentoo/${P}-gentoo-patches.tar.xz
- ${P}.src.tar.gz"
-
-SLOT="0"
-LICENSE="vmd"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cuda msms povray tachyon xinerama"
-
-RESTRICT="fetch"
-
-# currently, tk-8.5* with USE=truetype breaks some
-# tk apps such as Sequence Viewer or Timeline.
-CDEPEND="
- =dev-lang/tk-8.5*[-truetype]
- dev-lang/perl
- dev-python/numpy
- sci-libs/netcdf
- virtual/opengl
- >=x11-libs/fltk-1.1.10-r2:1
- x11-libs/libXft
- x11-libs/libXi
- cuda? ( >=dev-util/nvidia-cuda-toolkit-3.1 )
- xinerama? ( x11-libs/libXinerama )"
-DEPEND="${CDEPEND}
- dev-lang/swig"
-RDEPEND="${CDEPEND}
- sci-biology/stride
- sci-chemistry/surf
- x11-terms/xterm
- msms? ( sci-chemistry/msms-bin )
- povray? ( media-gfx/povray )
- tachyon? ( media-gfx/tachyon )"
-
-VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
-# Binary only plugin!!
-QA_TEXTRELS="usr/lib*/vmd/plugins/LINUX/tcl/intersurf1.1/bin/intersurf.so"
-QA_PRESTRIPPED="usr/lib*/vmd/plugins/LINUX/tcl/intersurf1.1/bin/intersurf.so"
-QA_FLAGS_IGNORED_amd64="
- usr/lib64/vmd/plugins/LINUX/tcl/intersurf1.1/bin/intersurf.so
- usr/lib64/vmd/plugins/LINUX/tcl/volutil1.3/volutil"
-QA_FLAGS_IGNORED_x86="
- usr/lib/vmd/plugins/LINUX/tcl/intersurf1.1/bin/intersurf.so
- usr/lib/vmd/plugins/LINUX/tcl/volutil1.3/volutil"
-
-pkg_nofetch() {
- elog "Please download ${P}.src.tar.gz from"
- elog "${VMD_DOWNLOAD}"
- elog "after agreeing to the license and get"
- elog "http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo-patches.tar.xz"
- elog "Place both in ${DISTDIR}"
-}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- cd "${WORKDIR}"/plugins
-
- epatch "${WORKDIR}"/${P}-gentoo-plugins.patch
-
- [[ ${SILENT} == yes ]] || sed '/^.SILENT/d' -i $(find -name Makefile)
-
- sed \
- -e "s:CC = gcc:CC = $(tc-getCC):" \
- -e "s:CXX = g++:CXX = $(tc-getCXX):" \
- -e "s:COPTO =.*\":COPTO = -fPIC -o\":" \
- -e "s:LOPTO = .*\":LOPTO = ${LDFLAGS} -fPIC -o\":" \
- -e "s:CCFLAGS =.*\":CCFLAGS = ${CFLAGS}\":" \
- -e "s:CXXFLAGS =.*\":CXXFLAGS = ${CXXFLAGS}\":" \
- -e "s:SHLD = gcc:SHLD = $(tc-getCC) -shared:" \
- -e "s:SHXXLD = g++:SHXXLD = $(tc-getCXX) -shared:" \
- -e "s:-ltcl8.5:-ltcl:" \
- -i Make-arch || die "Failed to set up plugins Makefile"
-
- sed \
- -e "s:\$(CXXFLAGS)::g" \
- -i hesstrans/Makefile || die
-
- # prepare vmd itself
- cd "${S}"
-
- epatch "${WORKDIR}"/${P}-gentoo-base.patch
-
- # PREFIX
- sed \
- -e "s:/usr/include/:${EPREFIX}/usr/include:g" \
- -i configure || die
-
- sed \
- -e "s:gentoo-bindir:${ED}/usr/bin:g" \
- -e "s:gentoo-libdir:${ED}/usr/$(get_libdir):g" \
- -e "s:gentoo-opengl-include:${EPREFIX}/usr/include/GL:g" \
- -e "s:gentoo-opengl-libs:${EPREFIX}/usr/$(get_libdir):g" \
- -e "s:gentoo-gcc:$(tc-getCC):g" \
- -e "s:gentoo-g++:$(tc-getCXX):g" \
- -e "s:gentoo-nvcc:${EPREFIX}/opt/cuda/bin/nvcc:g" \
- -e "s:gentoo-cflags:${CFLAGS}:g" \
- -e "s:gentoo-cxxflags:${CXXFLAGS}:g" \
- -e "s:gentoo-nvflags: -O3 -v:g" \
- -e "s:gentoo-ldflags:${LDFLAGS}:g" \
- -e "s:gentoo-plugindir:${WORKDIR}/plugins:g" \
- -e "s:gentoo-fltk-include:$(fltk-config --includedir):g" \
- -e "s:gentoo-fltk-libs:$(dirname $(fltk-config --libs)) -Wl,-rpath,$(dirname $(fltk-config --libs)):g" \
- -e "s:gentoo-netcdf-include:${EPREFIX}/usr/include:g" \
- -e "s:gentoo-netcdf-libs:${EPREFIX}/usr/$(get_libdir):g" \
- -i configure || die
-
-# local NUMPY_INCLUDE="numpy/core/include"
-# sed -e "s:gentoo-python-include:${EPREFIX}$(python_get_includedir):" \
-# -e "s:gentoo-python-lib:${EPREFIX}$(python_get_libdir):" \
-# -e "s:gentoo-python-link:$(PYTHON):" \
-# -e "s:gentoo-numpy-include:${EPREFIX}$(python_get_sitedir)/${NUMPY_INCLUDE}:" \
-# -i configure || die "failed setting up python"
-
- if use cuda; then
- local gcc44_bindir="$(ls -d ${EPREFIX}/usr/*pc-linux-gnu/gcc-bin/4.4*)"
-
- sed \
- -e "s:gentoo-cuda-lib:${EPREFIX}/opt/cuda/$(get_libdir):g" \
- -e "/^\$arch_nvccflags/s:=:= \"--compiler-bindir=${gcc44_bindir} \" . \n:1" \
- -i configure || die
- fi
-
- sed \
- -e "s:LINUXPPC:LINUX:g" \
- -e "s:LINUXALPHA:LINUX:g" \
- -e "s:LINUXAMD64:LINUX:g" \
- -e "s:gentoo-stride:${EPREFIX}/usr/bin/stride:g" \
- -e "s:gentoo-surf:${EPREFIX}/usr/bin/surf:g" \
- -e "s:gentoo-tachyon:${EPREFIX}/usr/bin/tachyon:g" \
- -i "${S}"/bin/vmd.sh || die "failed setting up vmd wrapper script"
-}
-
-src_configure() {
- local myconf="OPENGL FLTK TK TCL PTHREADS PYTHON IMD NETCDF NUMPY NOSILENT XINPUT"
- rm -f configure.options && echo $myconf >> configure.options
-
- use cuda && myconf+=" CUDA"
-# use mpi && myconf+=" MPI"
-# use tachion && myconf+=" LIBTACHYON"
- use xinerama && myconf+=" XINERAMA"
-
- export \
- PYTHON_INCLUDE_DIR="${EPREFIX}$(python_get_includedir)" \
- PYTHON_LIBRARY_DIR="${EPREFIX}$(python_get_libdir)" \
- PYTHON_LIBRARY="$(python_get_library -l)" \
- NUMPY_INCLUDE_DIR="${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- NUMPY_LIBRARY_DIR="${EPREFIX}$(python_get_sitedir)/numpy/core/include"
-
- ./configure LINUX \
- ${myconf} || die
-}
-
-src_compile() {
- # build plugins
- cd "${WORKDIR}"/plugins
-
- emake \
- TCLINC="-I${EPREFIX}/usr/include" \
- TCLLIB="-L${EPREFIX}/usr/$(get_libdir)" \
- NETCDFLIB="$(pkg-config --libs-only-L netcdf)" \
- NETCDFINC="$(pkg-config --cflags-only-I netcdf)" \
- NETCDFLDFLAGS="$(pkg-config --libs netcdf)" \
- LINUX
-
- # build vmd
- cd "${S}"/src
- emake
-}
-
-src_install() {
- # install plugins
- cd "${WORKDIR}"/plugins
- emake \
- PLUGINDIR="${ED}/usr/$(get_libdir)/${PN}/plugins" \
- distrib
-
- # install vmd
- cd "${S}"/src
- emake install
-
- # install docs
- cd "${S}"
- dodoc Announcement README doc/ig.pdf doc/ug.pdf
-
- # remove some of the things we don't want and need in
- # /usr/lib
- cd "${ED}"/usr/$(get_libdir)/vmd
- rm -fr doc README Announcement LICENSE || \
- die "failed to clean up /usr/lib/vmd directory"
-
- # adjust path in vmd wrapper
- sed \
- -e "s:${ED}::" -i "${ED}"/usr/bin/${PN} \
- -e "/^defaultvmddir/s:^.*$:defaultvmddir=\"${EPREFIX}/usr/$(get_libdir)/${PN}\":g" \
- || die "failed to set up vmd wrapper script"
-
- # install icon and generate desktop entry
- insinto /usr/share/pixmaps
- doins "${WORKDIR}"/vmd.png
- domenu "${WORKDIR}"/vmd.desktop
-}
diff --git a/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild b/sci-chemistry/vmd/vmd-1.9.2.ebuild
index 58d94f044413..4805b8fe5522 100644
--- a/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild
+++ b/sci-chemistry/vmd/vmd-1.9.2.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.1-r2.ebuild,v 1.5 2013/10/02 11:39:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.2.ebuild,v 1.1 2015/03/06 10:07:11 jlec Exp $
EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python2_7 )
-inherit cuda eutils multilib prefix python toolchain-funcs
+inherit cuda eutils flag-o-matic multilib prefix python-single-r1 toolchain-funcs
DESCRIPTION="Visual Molecular Dynamics"
HOMEPAGE="http://www.ks.uiuc.edu/Research/vmd/"
SRC_URI="
- http://dev.gentoo.org/~jlec/distifles/${P}-gentoo-patches-2.tar.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo-patches.tar.xz
${P}.src.tar.gz"
SLOT="0"
LICENSE="vmd"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cuda msms povray tachyon xinerama"
+IUSE="cuda gromacs msms povray sqlite tachyon xinerama"
RESTRICT="fetch"
@@ -26,15 +26,20 @@ RESTRICT="fetch"
CDEPEND="
|| ( =dev-lang/tk-8.5*:0=[-truetype] >=dev-lang/tk-8.6.1 )
dev-lang/perl
- dev-python/numpy
+ dev-libs/expat
+ dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/netcdf
virtual/opengl
>=x11-libs/fltk-1.1.10-r2:1
x11-libs/libXft
x11-libs/libXi
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ gromacs? ( >=sci-chemistry/gromacs-5.0.4-r1[tng] )
+ sqlite? ( dev-db/sqlite:3= )
+ tachyon? ( >=media-gfx/tachyon-0.99_beta6 )
xinerama? ( x11-libs/libXinerama )"
DEPEND="${CDEPEND}
+ virtual/pkgconfig
dev-lang/swig"
RDEPEND="${CDEPEND}
sci-biology/stride
@@ -42,7 +47,7 @@ RDEPEND="${CDEPEND}
x11-terms/xterm
msms? ( sci-chemistry/msms-bin )
povray? ( media-gfx/povray )
- tachyon? ( media-gfx/tachyon )"
+ "
VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
# Binary only plugin!!
@@ -54,33 +59,28 @@ pkg_nofetch() {
elog "Please download ${P}.src.tar.gz from"
elog "${VMD_DOWNLOAD}"
elog "after agreeing to the license and get"
- elog "http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo-patches-2.tar.xz"
+ elog "http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo-patches.tar.xz"
elog "Place both in ${DISTDIR}"
}
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_prepare() {
use cuda && cuda_sanitize
- epatch "${FILESDIR}"/${P}-cuda-device_ptr.patch
+ epatch "${FILESDIR}"/${PN}-1.9.1-cuda-device_ptr.patch
- cd "${WORKDIR}"/plugins
+ cd "${WORKDIR}"/plugins || die
epatch \
"${WORKDIR}"/${P}-gentoo-plugins.patch \
- "${FILESDIR}"/${P}-tcl8.6.patch
+ "${FILESDIR}"/${P}-format-security.patch
[[ ${SILENT} == yes ]] || sed '/^.SILENT/d' -i $(find -name Makefile)
sed \
-e "s:CC = gcc:CC = $(tc-getCC):" \
-e "s:CXX = g++:CXX = $(tc-getCXX):" \
- -e "s:COPTO =.*\":COPTO = -fPIC -o\":" \
- -e "s:LOPTO = .*\":LOPTO = ${LDFLAGS} -fPIC -o\":" \
+ -e "s:COPTO =.*\":COPTO = -fPIC -o \":" \
+ -e "s:LOPTO = .*\":LOPTO = ${LDFLAGS} -fPIC -o \":" \
-e "s:CCFLAGS =.*\":CCFLAGS = ${CFLAGS}\":" \
-e "s:CXXFLAGS =.*\":CXXFLAGS = ${CXXFLAGS}\":" \
-e "s:SHLD = gcc:SHLD = $(tc-getCC) -shared:" \
@@ -100,7 +100,7 @@ src_prepare() {
-i hesstrans/Makefile || die
# prepare vmd itself
- cd "${S}"
+ cd "${S}" || die
epatch "${WORKDIR}"/${P}-gentoo-base.patch
@@ -128,18 +128,17 @@ src_prepare() {
-e "s:gentoo-netcdf-libs:${EPREFIX}/usr/$(get_libdir):g" \
-i configure || die
-# local NUMPY_INCLUDE="numpy/core/include"
-# sed -e "s:gentoo-python-include:${EPREFIX}$(python_get_includedir):" \
-# -e "s:gentoo-python-lib:${EPREFIX}$(python_get_libdir):" \
-# -e "s:gentoo-python-link:$(PYTHON):" \
-# -e "s:gentoo-numpy-include:${EPREFIX}$(python_get_sitedir)/${NUMPY_INCLUDE}:" \
-# -i configure || die "failed setting up python"
-
if use cuda; then
sed \
-e "s:gentoo-cuda-lib:${EPREFIX}/opt/cuda/$(get_libdir):g" \
-e "/NVCCFLAGS/s:=:= ${NVCCFLAGS}:g" \
-i configure src/Makefile || die
+ sed \
+ -e '/compute_/d' \
+ -i configure || die
+ sed \
+ -e 's:-gencode .*code=sm_..::' \
+ -i src/Makefile || die
fi
sed \
@@ -150,63 +149,89 @@ src_prepare() {
-e "s:gentoo-surf:${EPREFIX}/usr/bin/surf:g" \
-e "s:gentoo-tachyon:${EPREFIX}/usr/bin/tachyon:g" \
-i "${S}"/bin/vmd.sh || die "failed setting up vmd wrapper script"
+
+ EMAKEOPTS=(
+ TCLINC="-I${EPREFIX}/usr/include"
+ TCLLIB="-L${EPREFIX}/usr/$(get_libdir)"
+ TCLLDFLAGS="-shared"
+ NETCDFLIB="$($(tc-getPKG_CONFIG) --libs-only-L netcdf) ${EPREFIX}/usr/$(get_libdir)/libnetcdf.so"
+ NETCDFINC="$($(tc-getPKG_CONFIG) --cflags-only-I netcdf) ${EPREFIX}/usr/include"
+ NETCDFLDFLAGS="$($(tc-getPKG_CONFIG) --libs netcdf)"
+ NETCDFDYNAMIC=1
+ EXPATINC="-I${EPREFIX}/usr/include"
+ EXPATLIB="$($(tc-getPKG_CONFIG) --libs expat)"
+ EXPATLDFLAGS="-shared"
+ EXPATDYNAMIC=1
+ )
+ if use gromacs; then
+ EMAKEOPTS+=(
+ TNGLIB="$($(tc-getPKG_CONFIG) --libs libgromacs)"
+ TNGINC="-I${EPREFIX}/usr/include"
+ TNGLDFLAGS="-shared"
+ TNGDYNAMIC=1
+ )
+ fi
+ if use sqlite; then
+ EMAKEOPTS+=(
+ SQLITELIB="$($(tc-getPKG_CONFIG) --libs sqlite3)"
+ SQLITEINC="-I${EPREFIX}/usr/include"
+ SQLITELDFLAGS="-shared"
+ SQLITEDYNAMIC=1
+ )
+ fi
}
src_configure() {
- local myconf="OPENGL FLTK TK TCL PTHREADS PYTHON IMD NETCDF NUMPY NOSILENT XINPUT"
+ local myconf="OPENGL OPENGLPBUFFER COLVARS FLTK TK TCL PTHREADS PYTHON IMD NETCDF NUMPY NOSILENT XINPUT"
rm -f configure.options && echo $myconf >> configure.options
use cuda && myconf+=" CUDA"
# use mpi && myconf+=" MPI"
-# use tachion && myconf+=" LIBTACHYON"
+ use tachyon && myconf+=" LIBTACHYON" && append-cflags -I"${EPREFIX}/usr/include/tachyon"
use xinerama && myconf+=" XINERAMA"
export \
- PYTHON_INCLUDE_DIR="${EPREFIX}$(python_get_includedir)" \
- PYTHON_LIBRARY_DIR="${EPREFIX}$(python_get_libdir)" \
- PYTHON_LIBRARY="$(python_get_library -l)" \
- NUMPY_INCLUDE_DIR="${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- NUMPY_LIBRARY_DIR="${EPREFIX}$(python_get_sitedir)/numpy/core/include"
+ PYTHON_INCLUDE_DIR="$(python_get_includedir)" \
+ PYTHON_LIBRARY_DIR="$(python_get_library_path)" \
+ PYTHON_LIBRARY="$(python_get_LIBS)" \
+ NUMPY_INCLUDE_DIR="$(python_get_sitedir)/numpy/core/include" \
+ NUMPY_LIBRARY_DIR="$(python_get_sitedir)/numpy/core/include"
- ./configure LINUX \
+ perl ./configure LINUX \
${myconf} || die
}
src_compile() {
# build plugins
- cd "${WORKDIR}"/plugins
+ cd "${WORKDIR}"/plugins || die
emake \
- TCLINC="-I${EPREFIX}/usr/include" \
- TCLLIB="-L${EPREFIX}/usr/$(get_libdir)" \
- NETCDFLIB="$(pkg-config --libs-only-L netcdf) ${EPREFIX}/usr/$(get_libdir)/libnetcdf.so" \
- NETCDFINC="$(pkg-config --cflags-only-I netcdf) ${EPREFIX}/usr/include" \
- NETCDFLDFLAGS="$(pkg-config --libs netcdf)" \
+ ${EMAKEOPTS[@]} \
LINUX
# build vmd
- cd "${S}"/src
+ cd "${S}"/src || die
emake
}
src_install() {
# install plugins
- cd "${WORKDIR}"/plugins
+ cd "${WORKDIR}"/plugins || die
emake \
PLUGINDIR="${ED}/usr/$(get_libdir)/${PN}/plugins" \
distrib
# install vmd
- cd "${S}"/src
+ cd "${S}"/src || die
emake install
# install docs
- cd "${S}"
+ cd "${S}" || die
dodoc Announcement README doc/ig.pdf doc/ug.pdf
# remove some of the things we don't want and need in
# /usr/lib
- cd "${ED}"/usr/$(get_libdir)/vmd
+ cd "${ED}"/usr/$(get_libdir)/vmd || die
rm -fr doc README Announcement LICENSE || \
die "failed to clean up /usr/lib/vmd directory"