summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-19 19:52:41 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-19 19:52:41 +0000
commit33100e7d892144326bbed01f5426db96f64753c4 (patch)
tree5feeac1e6e38c8455fad79201522a9b8adb3aa1e /sci-chemistry/rasmol
parentwhitespace (diff)
downloadgentoo-2-33100e7d892144326bbed01f5426db96f64753c4.tar.gz
gentoo-2-33100e7d892144326bbed01f5426db96f64753c4.tar.bz2
gentoo-2-33100e7d892144326bbed01f5426db96f64753c4.zip
Reverted removal of rasmol-2.7.2.1.1-r1.ebuild
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-chemistry/rasmol')
-rw-r--r--sci-chemistry/rasmol/ChangeLog5
-rw-r--r--sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild68
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-chemistry/rasmol/ChangeLog b/sci-chemistry/rasmol/ChangeLog
index 0f183880d637..5ed191889745 100644
--- a/sci-chemistry/rasmol/ChangeLog
+++ b/sci-chemistry/rasmol/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/rasmol
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/ChangeLog,v 1.18 2011/01/18 16:00:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/ChangeLog,v 1.19 2011/01/19 19:52:41 jlec Exp $
+
+ 19 Jan 2011; Justin Lecher <jlec@gentoo.org> +rasmol-2.7.2.1.1-r1.ebuild:
+ Reverted removal of rasmol-2.7.2.1.1-r1.ebuild
18 Jan 2011; Markos Chandras <hwoarang@gentoo.org> rasmol-2.7.5-r1.ebuild:
Stable on amd64 wrt bug #351984
diff --git a/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild b/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild
new file mode 100644
index 000000000000..251e47e8e0e1
--- /dev/null
+++ b/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild,v 1.9 2011/01/19 19:52:41 jlec Exp $
+
+inherit toolchain-funcs
+
+MY_P="RasMol_${PV}"
+
+DESCRIPTION="Free program that displays molecular structure."
+HOMEPAGE="http://www.openrasmol.org/"
+SRC_URI="http://www.bernstein-plus-sons.com/software/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXi
+ || ( x11-apps/xdpyinfo x11-apps/xwininfo )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ app-text/rman
+ x11-misc/imake"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Hack required for build
+ cd src
+ ln -s ../doc
+}
+
+src_compile() {
+ cd src
+ xmkmf || die "xmkmf failed"
+ make DEPTHDEF=-DEIGHTBIT CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "8-bit make failed"
+ mv rasmol rasmol.8
+ make clean
+ make DEPTHDEF=-DSIXTEENBIT CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "16-bit make failed"
+ mv rasmol rasmol.16
+ make clean
+ make DEPTHDEF=-DTHIRTYTWOBIT CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "32-bit make failed"
+ mv rasmol rasmol.32
+ make clean
+}
+
+src_install () {
+ newbin "${FILESDIR}"/rasmol.sh.debian rasmol
+ insinto /usr/lib/${PN}
+ doins doc/rasmol.hlp
+ exeinto /usr/lib/${PN}
+ doexe src/rasmol.{8,16,32}
+ dodoc INSTALL PROJECTS README TODO doc/*.{ps,pdf}.gz doc/rasmol.txt.gz
+ doman doc/rasmol.1
+ insinto /usr/lib/${PN}/databases
+ doins data/*
+}