summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-04 10:13:09 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-04 10:13:09 +0000
commitee2672efe27fc17b2c204b423a45cccdc48b4c8d (patch)
tree29f71d1f78716d864f539b26e7a9c9f47661983a /sci-chemistry/pymol/files
parentMove to virtual/ffmpeg from media-video/ffmpeg. (diff)
downloadgentoo-2-ee2672efe27fc17b2c204b423a45cccdc48b4c8d.tar.gz
gentoo-2-ee2672efe27fc17b2c204b423a45cccdc48b4c8d.tar.bz2
gentoo-2-ee2672efe27fc17b2c204b423a45cccdc48b4c8d.zip
Version Bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol/files')
-rw-r--r--sci-chemistry/pymol/files/1.4-shaders.patch62
-rw-r--r--sci-chemistry/pymol/files/1.4-vmd.patch36
2 files changed, 98 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/files/1.4-shaders.patch b/sci-chemistry/pymol/files/1.4-shaders.patch
new file mode 100644
index 000000000000..853ebff9da81
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.4-shaders.patch
@@ -0,0 +1,62 @@
+ layer0/ShaderMgr.c | 16 ++++++++--------
+ layer1/Setting.c | 2 +-
+ 2 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/layer0/ShaderMgr.c b/layer0/ShaderMgr.c
+index 929167f..ecb4130 100644
+--- a/layer0/ShaderMgr.c
++++ b/layer0/ShaderMgr.c
+@@ -386,7 +386,7 @@ int CShaderMgr_ShadersPresent(CShaderMgr * I)
+ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+ FILE* f;
+ long size;
+- char* buffer = NULL, *p, *pymol_path, *shader_path, *fullFile;
++ char* buffer = NULL, *p, *pymol_data, *shader_path, *fullFile;
+
+ PRINTFB(G, FB_ShaderMgr, FB_Debugging)
+ "CShaderMgr_ReadShaderFromDisk: fileName='%s'\n", fileName
+@@ -398,16 +398,16 @@ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+ return NULL;
+ }
+
+- pymol_path = getenv("PYMOL_PATH");
+- if (!pymol_path){
++ pymol_data = getenv("PYMOL_DATA");
++ if (!pymol_data){
+ PRINTFB(G, FB_ShaderMgr, FB_Warnings)
+- " PyMOLShader_NewFromFile-Warning: PYMOL_PATH not set, cannot read shader config files (%s) from disk\n", fileName ENDFB(G);
++ " PyMOLShader_NewFromFile-Warning: PYMOL_DATA not set, cannot read shader config files (%s) from disk\n", fileName ENDFB(G);
+ return NULL;
+ }
+ /* make this a setting */
+- shader_path = "/data/shaders/";
+- fullFile = malloc( sizeof(char) * (strlen(pymol_path)+strlen(shader_path)+strlen(fileName)+1));
+- fullFile = strcpy(fullFile, pymol_path);
++ shader_path = "/shaders/";
++ fullFile = malloc( sizeof(char) * (strlen(pymol_data)+strlen(shader_path)+strlen(fileName)+1));
++ fullFile = strcpy(fullFile, pymol_data);
+ fullFile = strcat(fullFile, shader_path);
+ fullFile = strcat(fullFile, fileName);
+
+@@ -416,7 +416,7 @@ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+
+ if (!f) {
+ PRINTFB(G, FB_ShaderMgr, FB_Errors)
+- " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_PATH='%s'\n", fullFile, pymol_path ENDFB(G);
++ " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_DATA='%s'\n", fullFile, pymol_data ENDFB(G);
+ return NULL;
+ } else {
+ PRINTFB(G, FB_ShaderMgr, FB_Blather)
+diff --git a/layer1/Setting.c b/layer1/Setting.c
+index 3aa0b8d..f9b5789 100644
+--- a/layer1/Setting.c
++++ b/layer1/Setting.c
+@@ -3956,7 +3956,7 @@ void SettingInitGlobal(PyMOLGlobals * G, int alloc, int reset_gui, int use_defau
+ set_b(I, cSetting_line_use_shader, 1);
+ set_b(I, cSetting_sphere_use_shader, 1);
+ set_b(I, cSetting_use_shaders, 0); /* disable by default until optimized shaders present; doesn't effect vol */
+- set_s(I, cSetting_shader_path, "data/shaders");
++ set_s(I, cSetting_shader_path, "shaders");
+ set_i(I, cSetting_volume_bit_depth, 8);
+ set_color(I, cSetting_volume_color, "-1");
+ set_f(I, cSetting_volume_layers, 256);
diff --git a/sci-chemistry/pymol/files/1.4-vmd.patch b/sci-chemistry/pymol/files/1.4-vmd.patch
new file mode 100644
index 000000000000..2fd909ffd540
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.4-vmd.patch
@@ -0,0 +1,36 @@
+ setup.py | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index b0f4dad..4ec5145 100644
+--- a/setup.py
++++ b/setup.py
+@@ -132,8 +132,8 @@ else: # linux or other unix
+ "/usr/include/freetype2",
+ # "/users/warren/ext/include",
+ # VMD plugin support
+-# "contrib/uiuc/plugins/include",
+-# "contrib/uiuc/plugins/molfile_plugin/src",
++ "contrib/uiuc/plugins/include",
++ "contrib/uiuc/plugins/molfile_plugin/src",
+ "modules/cealign/src",
+ "modules/cealign/src/tnt", ]
+ libs=["GL","GLU","glut","png","z","freetype", "GLEW",
+@@ -153,7 +153,7 @@ else: # linux or other unix
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support
+-# ("_PYMOL_VMD_PLUGINS",None)
++ ("_PYMOL_VMD_PLUGINS",None),
+ ("NO_MMLIBS",None),
+ ]
+ ext_comp_args=["-ffast-math","-funroll-loops","-O3"]
+@@ -307,7 +307,7 @@ setup ( # Distribution meta-data
+ "layer5/main.c"
+ # VMD plugin support
+ # switch the 0 to 1 to activate the additional source code
+- ] + 0 * [
++ ] + 1 * [
+ # (incomplete support -- only TRJ, TRR, XTC, DCD so far...)
+ 'contrib/uiuc/plugins/molfile_plugin/src/PlugIOManagerInit.c',
+ 'contrib/uiuc/plugins/molfile_plugin/src/avsplugin.cpp',