summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-28 19:25:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-28 19:25:28 +0000
commit24c4d9fd08b2e1e0cb4aacdaeacb67961c2a0fe4 (patch)
tree94f9ba896d04922a8ca1aed322003b295aeefb45 /sci-chemistry/openbabel-python
parentUse SLOT dependencies for x11-libs/gtk+. (diff)
downloadgentoo-2-24c4d9fd08b2e1e0cb4aacdaeacb67961c2a0fe4.tar.gz
gentoo-2-24c4d9fd08b2e1e0cb4aacdaeacb67961c2a0fe4.tar.bz2
gentoo-2-24c4d9fd08b2e1e0cb4aacdaeacb67961c2a0fe4.zip
Sane check for swig version, https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=428740
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog8
-rw-r--r--sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch25
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild7
3 files changed, 36 insertions, 4 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index e881865288d5..72f189fb370d 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.1 2011/03/26 15:34:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.2 2011/03/28 19:25:28 jlec Exp $
+
+ 28 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.0.ebuild,
+ +files/openbabel-python-2.3.0-swig.patch:
+ Sane check for swig version,
+ https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=
+ 428740
*openbabel-python-2.3.0 (26 Mar 2011)
diff --git a/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch
new file mode 100644
index 000000000000..6beacf74880c
--- /dev/null
+++ b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.0-swig.patch
@@ -0,0 +1,25 @@
+ scripts/CMakeLists.txt | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
+index bf2527b..16feeb4 100644
+--- a/scripts/CMakeLists.txt
++++ b/scripts/CMakeLists.txt
+@@ -8,16 +8,12 @@ if (RUN_SWIG)
+ # SWIG_EXECUTABLE - the path to the swig executable
+ # SWIG_VERSION - the version number of the swig executable
+
+- find_package(SWIG)
++ find_package(SWIG 2.0.0)
+ if (NOT SWIG_FOUND)
+ message(STATUS "SWIG NOT found")
+ return()
+ endif (NOT SWIG_FOUND)
+ message(STATUS "SWIG version is ${SWIG_VERSION}")
+- if (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+- message(STATUS "SWIG version 2.0.0 exactly is required")
+- return()
+- endif (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+ endif (RUN_SWIG)
+
+ ###################
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
index 0a7aa1ff24e8..897f7b668175 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.1 2011/03/26 15:34:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.2 2011/03/28 19:25:28 jlec Exp $
EAPI="3"
@@ -26,7 +26,7 @@ RDEPEND="
~sci-chemistry/openbabel-${PV}
sys-libs/zlib"
DEPEND="${RDEPEND}
- =dev-lang/swig-2.0.1
+ dev-lang/swig
dev-util/cmake"
S="${WORKDIR}"/openbabel-${PV}
@@ -36,7 +36,8 @@ DISTUTILS_SETUP_FILES="${S}/scripts/python/setup.py"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-wrap_OBInternalCoord.patch \
- "${FILESDIR}"/${P}-py3_iterator.patch
+ "${FILESDIR}"/${P}-py3_iterator.patch \
+ "${FILESDIR}"/${P}-swig.patch
}
src_configure() {