summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-13 16:33:06 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-13 16:33:06 +0000
commitc636516f5d454a06638d9ccd084e718d2b6dbc3b (patch)
tree8b43831f0038edc28d2c12fe12f28f365d7c5fb2 /sci-chemistry/gabedit
parentStable for HPPA (bug #407941). (diff)
downloadgentoo-2-c636516f5d454a06638d9ccd084e718d2b6dbc3b.tar.gz
gentoo-2-c636516f5d454a06638d9ccd084e718d2b6dbc3b.tar.bz2
gentoo-2-c636516f5d454a06638d9ccd084e718d2b6dbc3b.zip
Version Bump thanks Maximilian Bräutigam, Fix for underlinking detected by gold
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gabedit')
-rw-r--r--sci-chemistry/gabedit/ChangeLog12
-rw-r--r--sci-chemistry/gabedit/files/gabedit-2.4.2-gold.patch16
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.9.ebuild63
-rw-r--r--sci-chemistry/gabedit/gabedit-2.4.2.ebuild (renamed from sci-chemistry/gabedit/gabedit-2.3.8.ebuild)11
4 files changed, 33 insertions, 69 deletions
diff --git a/sci-chemistry/gabedit/ChangeLog b/sci-chemistry/gabedit/ChangeLog
index 6d3c735944c8..751a7ae57711 100644
--- a/sci-chemistry/gabedit/ChangeLog
+++ b/sci-chemistry/gabedit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/gabedit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.13 2011/10/05 19:47:00 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.14 2012/03/13 16:33:06 jlec Exp $
+
+*gabedit-2.4.2 (13 Mar 2012)
+
+ 13 Mar 2012; Justin Lecher <jlec@gentoo.org> -gabedit-2.3.8.ebuild,
+ -gabedit-2.3.9.ebuild, +gabedit-2.4.2.ebuild,
+ +files/gabedit-2.4.2-gold.patch:
+ Version Bump thanks Maximilian Bräutigam, Fix for underlinking detected by
+ gold
*gabedit-2.4.0 (05 Oct 2011)
diff --git a/sci-chemistry/gabedit/files/gabedit-2.4.2-gold.patch b/sci-chemistry/gabedit/files/gabedit-2.4.2-gold.patch
new file mode 100644
index 000000000000..68823d0d7663
--- /dev/null
+++ b/sci-chemistry/gabedit/files/gabedit-2.4.2-gold.patch
@@ -0,0 +1,16 @@
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae08e60..eee2b46 100644
+--- a/Makefile
++++ b/Makefile
+@@ -62,7 +62,7 @@ all: gabedit
+ gabedit: $(SUBDIRS)
+ $(MKDIR) tmp
+ cp $(OBJECTS) tmp
+- $(CC) $(LDFLAGS) tmp/*.o -o gabedit $(GLTOPS) $(X11LIB) $(GTKLIB) $(OGLLIB) $(JPEGLIB) $(LIBPTHREAD) $(WIN32LIB) $(OMPLIB) -g
++ $(CC) $(LDFLAGS) tmp/*.o -o gabedit $(GLTOPS) $(X11LIB) $(GTKLIB) $(OGLLIB) $(JPEGLIB) $(LIBPTHREAD) $(WIN32LIB) $(OMPLIB) -g -lm
+ @$(RMTMP) > ptmp
+ rmdir tmp
+ @$(RM) ptmp
diff --git a/sci-chemistry/gabedit/gabedit-2.3.9.ebuild b/sci-chemistry/gabedit/gabedit-2.3.9.ebuild
deleted file mode 100644
index b2fdb43a511f..000000000000
--- a/sci-chemistry/gabedit/gabedit-2.3.9.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.9.ebuild,v 1.1 2011/07/24 09:09:47 jlec Exp $
-
-EAPI=4
-
-inherit toolchain-funcs versionator
-
-MY_PN=${PN/g/G}
-MY_PV=$(delete_all_version_separators)
-MY_P="${MY_PN}Src${MY_PV}"
-
-DESCRIPTION="GUI for computational chemistry packages"
-HOMEPAGE="http://gabedit.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/GabeditDevloppment/${MY_PN}${MY_PV}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~amd64 ~x86"
-IUSE="openmp"
-
-RDEPEND="
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- x11-libs/gtkglext
- x11-libs/gl2ps
- x11-libs/pango
- virtual/opengl
- virtual/glu"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- tc-export CC
- sed -i "/rmdir tmp/d" "${S}"/Makefile
- sed \
- -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
- -i "${S}/Config.h" || die
- sed -e 's:-g::g' -i Makefile || die
- cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
-
- if use openmp && tc-has-openmp; then
- cat <<- EOF >> "${S}/CONFIG"
- OMPLIB=-fopenmp
- OMPCFLAGS=-DENABLE_OMP -fopenmp
- EOF
- fi
- echo "COMMONCFLAGS = ${CFLAGS} -DENABLE_DEPRECATED \$(OMPCFLAGS) \$(DRAWGEOMGL)" >> CONFIG
-}
-
-src_compile() {
- emake clean
- emake external_gl2ps=1
-}
-
-src_install() {
- dobin ${PN}
- dodoc ChangeLog
-}
diff --git a/sci-chemistry/gabedit/gabedit-2.3.8.ebuild b/sci-chemistry/gabedit/gabedit-2.4.2.ebuild
index cb3cedd76029..6e6f877d1776 100644
--- a/sci-chemistry/gabedit/gabedit-2.3.8.ebuild
+++ b/sci-chemistry/gabedit/gabedit-2.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.8.ebuild,v 1.2 2011/06/21 06:04:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.4.2.ebuild,v 1.1 2012/03/13 16:33:06 jlec Exp $
EAPI=4
-inherit toolchain-funcs versionator
+inherit eutils toolchain-funcs versionator
MY_PN=${PN/g/G}
MY_PV=$(delete_all_version_separators)
@@ -12,7 +12,7 @@ MY_P="${MY_PN}Src${MY_PV}"
DESCRIPTION="GUI for computational chemistry packages"
HOMEPAGE="http://gabedit.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/GabeditDevloppment/${MY_PN}${MY_PV}/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
SLOT="0"
LICENSE="as-is"
@@ -36,6 +36,9 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
tc-export CC
+
+ epatch "${FILESDIR}"/${P}-gold.patch
+
sed -i "/rmdir tmp/d" "${S}"/Makefile
sed \
-e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \