summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 08:04:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 08:04:15 +0000
commite95fc0292f0fbebe21c5f25755100a1a106abaf4 (patch)
treea4f818f370b89199bbaf0bf9bb9caf5b8742bc52 /sci-chemistry/easychem
parentVersion bump. Add ree18 support. (diff)
downloadgentoo-2-e95fc0292f0fbebe21c5f25755100a1a106abaf4.tar.gz
gentoo-2-e95fc0292f0fbebe21c5f25755100a1a106abaf4.tar.bz2
gentoo-2-e95fc0292f0fbebe21c5f25755100a1a106abaf4.zip
Respecting LDFLAGS now, 333847; Prefix ready and keyworded for ~-linux
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/easychem')
-rw-r--r--sci-chemistry/easychem/ChangeLog8
-rw-r--r--sci-chemistry/easychem/easychem-0.6-r1.ebuild40
-rw-r--r--sci-chemistry/easychem/files/0.6-gentoo.patch65
3 files changed, 112 insertions, 1 deletions
diff --git a/sci-chemistry/easychem/ChangeLog b/sci-chemistry/easychem/ChangeLog
index c841c39b39f7..e3be73c55d50 100644
--- a/sci-chemistry/easychem/ChangeLog
+++ b/sci-chemistry/easychem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/easychem
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/easychem/ChangeLog,v 1.16 2010/06/17 10:30:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/easychem/ChangeLog,v 1.17 2010/10/03 08:04:15 jlec Exp $
+
+*easychem-0.6-r1 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/0.6-gentoo.patch,
+ +easychem-0.6-r1.ebuild:
+ Respecting LDFLAGS now, 333847; Prefix ready and keyworded for ~-linux
17 Jun 2010; Justin Lecher <jlec@gentoo.org> easychem-0.6.ebuild:
Some QA
diff --git a/sci-chemistry/easychem/easychem-0.6-r1.ebuild b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
new file mode 100644
index 000000000000..79434e9b09c7
--- /dev/null
+++ b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/easychem/easychem-0.6-r1.ebuild,v 1.1 2010/10/03 08:04:15 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Chemical structure drawing program - focused on presentation."
+HOMEPAGE="http://easychem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/easychem/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtk+-2.4.1
+ app-text/ghostscript-gpl
+ media-gfx/pstoedit"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ ln -s Makefile.linux Makefile
+ DGS_PATH="${EPREFIX}"/usr/bin DPSTOEDIT_PATH="${EPREFIX}"/usr/bin \
+ C_FLAGS="${CFLAGS}" emake -e || die
+}
+
+src_install () {
+ dobin easychem || die
+ dodoc TODO || die
+}
diff --git a/sci-chemistry/easychem/files/0.6-gentoo.patch b/sci-chemistry/easychem/files/0.6-gentoo.patch
new file mode 100644
index 000000000000..9455d299c14d
--- /dev/null
+++ b/sci-chemistry/easychem/files/0.6-gentoo.patch
@@ -0,0 +1,65 @@
+diff --git a/Makefile.linux b/Makefile.linux
+index 6638394..5da56b0 100644
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -1,5 +1,5 @@
+ # The C compiler
+-CC=gcc
++CC ?= gcc
+
+ # The following line must be uncommented if you want to specify a place
+ # where the 'gs' (or 'pstoedit') program is.
+@@ -25,11 +25,10 @@ GTK_LIBS=`pkg-config --libs gtk+-2.0`
+ # The list of important files
+ OBJECTS=auxi.o bonds.o easychem.o export.o dialogs.o detect.o library.o drawing.o
+
+-all: easychem po/
++all: easychem po
+
+-easychem: postscript/ graph/ $(OBJECTS)
+- $(CC) -o easychem $(OBJECTS) $(GTK_LIBS) $(C_FLAGS)
+- strip easychem
++easychem: postscript graph $(OBJECTS)
++ $(CC) $(C_FLAGS) $(LDFLAGS) -o easychem $(OBJECTS) $(GTK_LIBS)
+
+ clean: FORCE
+ -cd graph; make clean
+@@ -37,7 +36,7 @@ clean: FORCE
+ -cd po; make clean
+ -rm $(OBJECTS) easychem
+
+-export.o: export.c common.h bonds.h postscript/
++export.o: export.c common.h bonds.h postscript
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c export.c
+ bonds.o: bonds.c common.h bonds.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c bonds.c
+@@ -49,20 +48,22 @@ library.o: library.c common.h library.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c library.c
+ drawing.o: drawing.c common.h drawing.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c drawing.c
+-dialogs.o: dialogs.c common.h dialogs.h graph/
++dialogs.o: dialogs.c common.h dialogs.h graph
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c dialogs.c
+ detect.o: detect.c common.h detect.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c detect.c
+
+ # The rules for subdirectories
+-graph/: FORCE
+- cd graph; make all
++graph:
++ +make -C $@
+
+-postscript/: FORCE
+- cd postscript; make all
++postscript:
++ +make -C $@
+
+-po/: FORCE
+- cd po; make all
++po:
++ +make -C $@
+
+ # This is used to force an update
+ FORCE:
++
++.PHONY: graph postscript po