summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-07-04 08:29:51 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-07-04 08:29:51 +0000
commitf8e6e636961d6a3fe6b48a5ffa3e37abf741bbac (patch)
tree767c785c321191f9874f83aafa80c2d16504fec2 /sci-calculators
parentStable on amd64 wrt bug #316453 (diff)
downloadgentoo-2-f8e6e636961d6a3fe6b48a5ffa3e37abf741bbac.tar.gz
gentoo-2-f8e6e636961d6a3fe6b48a5ffa3e37abf741bbac.tar.bz2
gentoo-2-f8e6e636961d6a3fe6b48a5ffa3e37abf741bbac.zip
Fix build with >=gtk+-2.18 wrt bug 326793. Thanks to Diego for reporting.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tiemu/ChangeLog8
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch232
-rw-r--r--sci-calculators/tiemu/tiemu-3.03.ebuild8
3 files changed, 244 insertions, 4 deletions
diff --git a/sci-calculators/tiemu/ChangeLog b/sci-calculators/tiemu/ChangeLog
index 4c738864b906..d9c55714b3b4 100644
--- a/sci-calculators/tiemu/ChangeLog
+++ b/sci-calculators/tiemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-calculators/tiemu
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.3 2009/11/09 11:12:26 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.4 2010/07/04 08:29:50 xarthisius Exp $
+
+ 04 Jul 2010; Kacper Kowalik <xarthisius@gentoo.org> tiemu-3.03.ebuild,
+ +files/tiemu-3.03-remove_depreciated_gtk_calls.patch:
+ Fix build with >=gtk+-2.18 wrt bug 326793. Thanks to Diego for reporting.
09 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> tiemu-3.03.ebuild:
Remove USE kde wrt #257590, thanks to Jakob Dettner for reporting.
diff --git a/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch b/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch
new file mode 100644
index 000000000000..10a0e1a11341
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.03-remove_depreciated_gtk_calls.patch
@@ -0,0 +1,232 @@
+--- src/gui/debugger/dbg_bkpts.c
++++ src/gui/debugger/dbg_bkpts.c
+@@ -29,10 +29,15 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_regs.c
++++ src/gui/debugger/dbg_regs.c
+@@ -28,14 +28,19 @@
+ # include <config.h>
+ #endif
+
+-#include <gtk/gtk.h>
+-#include <glade/glade.h>
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <gtk/gtk.h>
++#include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_pclog.c
++++ src/gui/debugger/dbg_pclog.c
+@@ -31,6 +31,11 @@
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_wnds.c
++++ src/gui/debugger/dbg_wnds.c
+@@ -38,6 +38,11 @@
+ #include <windows.h>
+ #endif
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "ti68k_int.h"
+ #include "struct.h"
+--- src/gui/debugger/dbg_mem.c
++++ src/gui/debugger/dbg_mem.c
+@@ -33,6 +33,11 @@
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+--- src/gui/debugger/dbg_iop.c
++++ src/gui/debugger/dbg_iop.c
+@@ -28,13 +28,18 @@
+ # include <config.h>
+ #endif
+
+-#include <gtk/gtk.h>
+-#include <glade/glade.h>
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <gtk/gtk.h>
++#include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_stack.c
++++ src/gui/debugger/dbg_stack.c
+@@ -28,11 +28,16 @@
+ # include <config.h>
+ #endif
+
++#include <stdlib.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <stdlib.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_all.c
++++ src/gui/debugger/dbg_all.c
+@@ -38,6 +38,13 @@
+ #include <windows.h>
+ #endif
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_SENSITIVE
++#define GTK_WIDGET_SENSITIVE(wid) (gtk_widget_get_sensitive(wid))
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "ti68k_int.h"
+ #include "struct.h"
+ #include "dbg_all.h"
+--- src/gui/debugger/dbg_code.c
++++ src/gui/debugger/dbg_code.c
+@@ -28,11 +28,16 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_SENSITIVE
++#define GTK_WIDGET_SENSITIVE(wid) (gtk_widget_get_sensitive(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_heap.c
++++ src/gui/debugger/dbg_heap.c
+@@ -31,6 +31,11 @@
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/debugger/dbg_dock.c
++++ src/gui/debugger/dbg_dock.c
+@@ -37,11 +37,16 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk/gdkkeysyms.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_VISIBLE
++#define GTK_WIDGET_VISIBLE(wid) (gtk_widget_get_visible(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "support.h"
+--- src/gui/calc/calc.c
++++ src/gui/calc/calc.c
+@@ -39,6 +39,11 @@
+ #include <glade/glade.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_STATE
++#define GTK_WIDGET_STATE(wid) (gtk_widget_get_state(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "skinops.h"
+--- src/gui/calc/screen.c
++++ src/gui/calc/screen.c
+@@ -29,11 +29,16 @@
+ # include <config.h>
+ #endif /* */
+
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+-#include <string.h>
+
++#if GTK_CHECK_VERSION(2,18,0)
++#undef GTK_WIDGET_STATE
++#define GTK_WIDGET_STATE(wid) (gtk_widget_get_state(wid))
++#endif
++
+ #include "intl.h"
+ #include "paths.h"
+ #include "skinops.h"
diff --git a/sci-calculators/tiemu/tiemu-3.03.ebuild b/sci-calculators/tiemu/tiemu-3.03.ebuild
index 29b26ce21a87..312a7170d9d0 100644
--- a/sci-calculators/tiemu/tiemu-3.03.ebuild
+++ b/sci-calculators/tiemu/tiemu-3.03.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.03.ebuild,v 1.2 2009/11/09 11:12:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.03.ebuild,v 1.3 2010/07/04 08:29:50 xarthisius Exp $
EAPI=2
inherit eutils
@@ -30,6 +30,10 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
xinerama? ( x11-proto/xineramaproto )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch
+}
+
src_configure() {
econf \
--disable-rpath \