summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-30 17:06:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-30 17:06:15 +0000
commit5e8d51af078eaf2b4157929820e4aab0fd7490f9 (patch)
tree6ed6ba4fe955204a51b1195c5d981a8106108c35 /sci-calculators/pgcalc2
parentVersion bump (diff)
downloadgentoo-2-5e8d51af078eaf2b4157929820e4aab0fd7490f9.tar.gz
gentoo-2-5e8d51af078eaf2b4157929820e4aab0fd7490f9.tar.bz2
gentoo-2-5e8d51af078eaf2b4157929820e4aab0fd7490f9.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-calculators/pgcalc2')
-rw-r--r--sci-calculators/pgcalc2/ChangeLog8
-rw-r--r--sci-calculators/pgcalc2/metadata.xml12
-rw-r--r--sci-calculators/pgcalc2/pgcalc2-2.2.10.ebuild35
3 files changed, 48 insertions, 7 deletions
diff --git a/sci-calculators/pgcalc2/ChangeLog b/sci-calculators/pgcalc2/ChangeLog
index 73be122fc92c..fe3253d9cc8d 100644
--- a/sci-calculators/pgcalc2/ChangeLog
+++ b/sci-calculators/pgcalc2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/pgcalc2
# Copyright 2004-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pgcalc2/ChangeLog,v 1.5 2008/01/08 15:18:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pgcalc2/ChangeLog,v 1.6 2008/08/30 17:06:15 bicatali Exp $
+
+*pgcalc2-2.2.10 (30 Aug 2008)
+
+ 30 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +pgcalc2-2.2.10.ebuild:
+ Version bump
08 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> pgcalc2-2.2.6.ebuild:
Added kdelibs and friend dependency with need-kde function (bug #204797)
diff --git a/sci-calculators/pgcalc2/metadata.xml b/sci-calculators/pgcalc2/metadata.xml
index f393ee709b86..9f8700e61019 100644
--- a/sci-calculators/pgcalc2/metadata.xml
+++ b/sci-calculators/pgcalc2/metadata.xml
@@ -3,11 +3,11 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-PG Calculator is a scientific skinnable calculator for KDE. It works
-in algebraic and RPN mode, recognizes real and complex numbers, and
-allows simple vectors manipulations. It has up to 80 built-in functions,
-allows user-defined variables, supports numbers inputing in binary, octal,
-hexadecimal, and exponential formats. Graphical user interface can be
-easy changed with skins.
+ PG Calculator is a scientific skinnable calculator for KDE. It works
+ in algebraic and RPN mode, recognizes real and complex numbers, and
+ allows simple vectors manipulations. It has up to 80 built-in functions,
+ allows user-defined variables, supports numbers inputing in binary, octal,
+ hexadecimal, and exponential formats. Graphical user interface can be
+ easy changed with skins.
</longdescription>
</pkgmetadata>
diff --git a/sci-calculators/pgcalc2/pgcalc2-2.2.10.ebuild b/sci-calculators/pgcalc2/pgcalc2-2.2.10.ebuild
new file mode 100644
index 000000000000..3f2ead6b346e
--- /dev/null
+++ b/sci-calculators/pgcalc2/pgcalc2-2.2.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/pgcalc2/pgcalc2-2.2.10.ebuild,v 1.1 2008/08/30 17:06:15 bicatali Exp $
+
+inherit versionator kde
+
+MY_PV=$(get_major_version).$(get_version_component_range 2)-$(get_version_component_range 3)
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Powerful scientific calculator for KDE"
+SRC_URI="mirror://sourceforge/${PN/2/}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pgcalc.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+need-kde 3
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
+ if use doc; then
+ dohtml -r "${S}"/htmldoc/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use another skin, start ${PN} with:"
+ einfo "\t ${MY_PN} --skinname=<skin>"
+ einfo "<skin> is one of $(ls /usr/share/apps/pgcalc2/skins)"
+}