summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-23 11:48:13 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-23 11:48:13 +0000
commitfbc8ed8a913ee4f169d2d1402078881c0490a46a (patch)
treef6076a8c122c6e49b6738386bb3c6aa0c15690b6 /sci-biology
parentVersion bump. (diff)
downloadgentoo-2-fbc8ed8a913ee4f169d2d1402078881c0490a46a.tar.gz
gentoo-2-fbc8ed8a913ee4f169d2d1402078881c0490a46a.tar.bz2
gentoo-2-fbc8ed8a913ee4f169d2d1402078881c0490a46a.zip
sci-biology/mira: Version BUmp, thanks Martin Mokrejš for the work
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mira/ChangeLog7
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-biology/mira/ChangeLog b/sci-biology/mira/ChangeLog
index 59b0cb700be8..30fd80586652 100644
--- a/sci-biology/mira/ChangeLog
+++ b/sci-biology/mira/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mira
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.28 2015/01/23 11:25:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.29 2015/01/23 11:48:13 jlec Exp $
+
+*mira-4.0.2 (23 Jan 2015)
+
+ 23 Jan 2015; Justin Lecher <jlec@gentoo.org> +mira-4.0.2.ebuild:
+ Version BUmp, thanks Martin Mokrejš for the work
23 Jan 2015; Justin Lecher <jlec@gentoo.org> mira-3.9.18.ebuild:
Add workaroung for m4 dir location, #536172
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
new file mode 100644
index 000000000000..8ae345aeeef5
--- /dev/null
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-4.0.2.ebuild,v 1.1 2015/01/23 11:48:13 jlec Exp $
+
+EAPI=5
+
+MIRA_3RDPARTY_PV="06-07-2012"
+MY_PV="${PV/_}" # convert from mira-4.0_rc2 (Gentoo ebuild filename derived) to mira-4.0rc2 (upstream fromat)
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="
+ http://sourceforge.net/projects/mira-assembler/files/MIRA/stable/"${PN}"-"${MY_PV}".tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+# http://sourceforge.net/projects/mira-assembler/files/MIRA/development/${P}.tar.bz2
+# mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+S="${WORKDIR}"/"${PN}"-"${MY_PV}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+CDEPEND="
+ dev-libs/boost
+ dev-util/google-perftools"
+DEPEND="${CDEPEND}
+ app-editors/vim-core
+ dev-libs/expat"
+RDEPEND="${CDEPEND}"
+
+#DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED
+# THANKS doc/3rdparty/scaffolding_MIRA_BAMBUS.pdf )
+DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED THANKS )
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.4.0.2-boost-1.50.patch
+
+ sed \
+ -e "s:-O[23]::g" \
+ -e "s:-funroll-loops::g" \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-thread=boost_thread-mt
+}
+
+#src_compile() {
+# base_src_compile
+# # TODO: resolve docbook incompatibility for building docs
+# if use doc; then emake -C doc clean docs || die; fi
+#}
+
+src_install() {
+ default
+ dodoc ${DOCS[@]}
+
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,qual2ball,*.pl}
+ dodoc "${WORKDIR}"/3rdparty/{README.txt,midi_screen.fasta}
+}
+
+pkg_postinst() {
+ einfo "Documentation is no longer built, you can find it at:"
+ einfo "http://mira-assembler.sourceforge.net/docs/DefinitiveGuideToMIRA.html"
+}