summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-28 10:58:46 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-28 10:58:46 +0000
commitea8ac8a807db07f9f5a6ccc62fa334ddf6a8bb4a (patch)
tree87b6174db3682df2bfd56357823b51dbd2201d89 /sci-biology
parentInitial import. (diff)
downloadgentoo-2-ea8ac8a807db07f9f5a6ccc62fa334ddf6a8bb4a.tar.gz
gentoo-2-ea8ac8a807db07f9f5a6ccc62fa334ddf6a8bb4a.tar.bz2
gentoo-2-ea8ac8a807db07f9f5a6ccc62fa334ddf6a8bb4a.zip
Gold fix, #369001
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/snpfile/ChangeLog8
-rw-r--r--sci-biology/snpfile/files/snpfile-2.0.1-gold.patch23
-rw-r--r--sci-biology/snpfile/snpfile-2.0.1-r1.ebuild18
3 files changed, 37 insertions, 12 deletions
diff --git a/sci-biology/snpfile/ChangeLog b/sci-biology/snpfile/ChangeLog
index efa38a7ded45..6ea82f568758 100644
--- a/sci-biology/snpfile/ChangeLog
+++ b/sci-biology/snpfile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/snpfile
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/snpfile/ChangeLog,v 1.6 2010/10/02 07:52:04 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/snpfile/ChangeLog,v 1.7 2011/05/28 10:58:46 jlec Exp $
+
+ 28 May 2011; Justin Lecher <jlec@gentoo.org> snpfile-2.0.1-r1.ebuild,
+ +files/snpfile-2.0.1-gold.patch:
+ Gold fix, #369001
02 Oct 2010; Kacper Kowalik <xarthisius@gentoo.org>
files/snpfile-2.0.1-gentoo.diff:
diff --git a/sci-biology/snpfile/files/snpfile-2.0.1-gold.patch b/sci-biology/snpfile/files/snpfile-2.0.1-gold.patch
new file mode 100644
index 000000000000..2211aa36c0ca
--- /dev/null
+++ b/sci-biology/snpfile/files/snpfile-2.0.1-gold.patch
@@ -0,0 +1,23 @@
+ Makefile.am | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 06fd733..5805c48 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -32,7 +32,7 @@ noinst_PROGRAMS += make_test_snpfile test_test_snpfile
+ noinst_PROGRAMS += row_metadata_experiment metadata_cache_prototype matrix_benchmark \
+ matrix_benchmark_write matrix_benchmark_read
+
+-LDADD = $(top_builddir)/libsnpfile.la
++LDADD = $(top_builddir)/libsnpfile.la $(BOOST_PROGRAM_OPTIONS_LIB) $(BOOST_SIGNALS_LIB) -lstdc++
+
+ matrix_test_SOURCES = test_util.hh test_util.cc input_archive.hh output_archive.hh matrix_test.cc
+
+@@ -88,5 +88,5 @@ libsnpfile_la_SOURCES = common.hh matrix.hh matrix.cc file_matrix.hh file_matrix
+ metadata.hh metadata.cc metadata_access.hh archive_common.hh archives.hh \
+ input_archive.hh output_archive.hh snpfile.hh snpfile.cc serialization_trait.hh \
+ type_trait.hh
+-libsnpfile_la_LIBADD = $(BOOST_PROGRAM_OPTIONS_LIB) $(BOOST_SIGNALS_LIB)
++libsnpfile_la_LIBADD = $(BOOST_PROGRAM_OPTIONS_LIB) $(BOOST_SIGNALS_LIB) -lstdc++
+
diff --git a/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild b/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild
index 010abe9aecae..341e937a757b 100644
--- a/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild
+++ b/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild,v 1.1 2010/06/20 16:58:42 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/snpfile/snpfile-2.0.1-r1.ebuild,v 1.2 2011/05/28 10:58:46 jlec Exp $
+
+EAPI=4
-EAPI=2
inherit autotools eutils
DESCRIPTION="A library and API for manipulating large SNP datasets"
@@ -18,16 +19,13 @@ RDEPEND="dev-libs/boost"
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-gentoo.diff
+ epatch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-gold.patch
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS README NEWS || die
-}