summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-03 06:54:27 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-03 06:54:27 +0000
commite448c4eed328a6894976079a628000dc160cd802 (patch)
treee690efc4dc08a825c156783937dba5f6b67eccab /sci-biology
parentInclude /dev/ati/card in the SANDBOX_PREDICT line (user from Freenode proofed... (diff)
downloadgentoo-2-e448c4eed328a6894976079a628000dc160cd802.tar.gz
gentoo-2-e448c4eed328a6894976079a628000dc160cd802.tar.bz2
gentoo-2-e448c4eed328a6894976079a628000dc160cd802.zip
sci-biology/biopython: Version Bump, thanks Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> preparing the ebuild
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.64.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index b15feab77d1a..8b94d92d48fe 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.75 2014/05/07 11:00:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.76 2014/06/03 06:54:27 jlec Exp $
+
+*biopython-1.64 (03 Jun 2014)
+
+ 03 Jun 2014; Justin Lecher <jlec@gentoo.org> +biopython-1.64.ebuild:
+ Version Bump, thanks Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> preparing
+ the ebuild
*biopython-1.63-r1 (07 May 2014)
diff --git a/sci-biology/biopython/biopython-1.64.ebuild b/sci-biology/biopython/biopython-1.64.ebuild
new file mode 100644
index 000000000000..c1cad3f6d822
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.64.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.64.ebuild,v 1.1 2014/06/03 06:54:27 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="mysql postgres"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}