summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-21 18:04:05 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-21 18:04:05 +0000
commitdfb961dba83c5804bd75daa56339ffe340530232 (patch)
tree069fe4e199928d14f3061847fa694c28f59923f3 /sci-biology
parentRemove old. (diff)
downloadgentoo-2-dfb961dba83c5804bd75daa56339ffe340530232.tar.gz
gentoo-2-dfb961dba83c5804bd75daa56339ffe340530232.tar.bz2
gentoo-2-dfb961dba83c5804bd75daa56339ffe340530232.zip
sci-biology/mafft: Version BUmp, drop unnecessary die
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mafft/ChangeLog8
-rw-r--r--sci-biology/mafft/mafft-7.037.ebuild11
-rw-r--r--sci-biology/mafft/mafft-7.040.ebuild44
3 files changed, 56 insertions, 7 deletions
diff --git a/sci-biology/mafft/ChangeLog b/sci-biology/mafft/ChangeLog
index b67bedfac437..380d0724306a 100644
--- a/sci-biology/mafft/ChangeLog
+++ b/sci-biology/mafft/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/mafft
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/ChangeLog,v 1.11 2013/04/29 10:19:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/ChangeLog,v 1.12 2013/05/21 18:04:05 jlec Exp $
+
+*mafft-7.040 (21 May 2013)
+
+ 21 May 2013; Justin Lecher <jlec@gentoo.org> mafft-7.037.ebuild,
+ +mafft-7.040.ebuild:
+ Version BUmp, drop unnecessary die
29 Apr 2013; Justin Lecher <jlec@gentoo.org> mafft-7.037.ebuild:
Fix USE=threads make flag magic
diff --git a/sci-biology/mafft/mafft-7.037.ebuild b/sci-biology/mafft/mafft-7.037.ebuild
index 679f51d7351e..b8547f6c6f66 100644
--- a/sci-biology/mafft/mafft-7.037.ebuild
+++ b/sci-biology/mafft/mafft-7.037.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/mafft-7.037.ebuild,v 1.2 2013/04/29 10:19:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/mafft-7.037.ebuild,v 1.3 2013/05/21 18:04:05 jlec Exp $
EAPI=5
@@ -22,7 +22,7 @@ S="${WORKDIR}"/${P}${EXTENSIONS}
src_prepare() {
epatch "${FILESDIR}"/${P}-respect.patch
use threads && append-flags -Denablemultithread
- sed "s:GENTOOLIBDIR:$(get_libdir):g" -i core/Makefile
+ sed "s:GENTOOLIBDIR:$(get_libdir):g" -i core/Makefile || die
sed -i -e "s/(PREFIX)\/man/(PREFIX)\/share\/man/" "${S}"/core/Makefile || die "sed failed"
}
@@ -32,14 +32,13 @@ src_compile() {
$(usex threads ENABLE_MULTITHREAD="-Denablemultithread" ENABLE_MULTITHREAD="") \
PREFIX="${EPREFIX}"/usr \
CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- || die "make failed"
+ CFLAGS="${CFLAGS}"
popd
}
src_install() {
pushd core
- emake PREFIX="${ED}usr" install || die "install failed"
+ emake PREFIX="${ED}usr" install
popd
- dodoc readme || die
+ dodoc readme
}
diff --git a/sci-biology/mafft/mafft-7.040.ebuild b/sci-biology/mafft/mafft-7.040.ebuild
new file mode 100644
index 000000000000..6a554361c671
--- /dev/null
+++ b/sci-biology/mafft/mafft-7.040.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/mafft-7.040.ebuild,v 1.1 2013/05/21 18:04:05 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+EXTENSIONS="-without-extensions"
+
+DESCRIPTION="Multiple sequence alignments using a variety of algorithms"
+HOMEPAGE="http://mafft.cbrc.jp/alignment/software/index.html"
+SRC_URI="http://mafft.cbrc.jp/alignment/software/${P}${EXTENSIONS}-src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos ~x86-macos"
+IUSE="threads"
+
+S="${WORKDIR}"/${P}${EXTENSIONS}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.037-respect.patch
+ use threads && append-flags -Denablemultithread
+ sed "s:GENTOOLIBDIR:$(get_libdir):g" -i core/Makefile || die
+ sed -i -e "s/(PREFIX)\/man/(PREFIX)\/share\/man/" "${S}"/core/Makefile || die "sed failed"
+}
+
+src_compile() {
+ pushd core
+ emake \
+ $(usex threads ENABLE_MULTITHREAD="-Denablemultithread" ENABLE_MULTITHREAD="") \
+ PREFIX="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ popd
+}
+
+src_install() {
+ pushd core
+ emake PREFIX="${ED}usr" install
+ popd
+ dodoc readme
+}