summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-03-07 21:41:22 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-03-07 21:41:22 +0000
commitde1486718c20057772840999e1cba871d84c483d (patch)
tree3a78f30b68b4968835fb94f96fc8a2e0e44c2b55 /sci-biology
parentKeyworded ~sparc wrt #124229 (diff)
downloadgentoo-2-de1486718c20057772840999e1cba871d84c483d.tar.gz
gentoo-2-de1486718c20057772840999e1cba871d84c483d.tar.bz2
gentoo-2-de1486718c20057772840999e1cba871d84c483d.zip
Bump.
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/t-coffee/ChangeLog10
-rw-r--r--sci-biology/t-coffee/files/digest-t-coffee-3.843
-rw-r--r--sci-biology/t-coffee/t-coffee-3.84.ebuild57
3 files changed, 68 insertions, 2 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index ca1dfe82adb0..bb9060a083ae 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/t-coffee
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.12 2005/12/08 19:52:39 ribosome Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.13 2006/03/07 21:41:22 spyderous Exp $
+
+*t-coffee-3.84 (07 Mar 2006)
+
+ 07 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +t-coffee-3.84.ebuild:
+ Bump.
08 Dec 2005; Olivier Fisette <ribosome@gentoo.org> -t-coffee-3.18.ebuild:
Pruning old version.
diff --git a/sci-biology/t-coffee/files/digest-t-coffee-3.84 b/sci-biology/t-coffee/files/digest-t-coffee-3.84
new file mode 100644
index 000000000000..bc927afd27fc
--- /dev/null
+++ b/sci-biology/t-coffee/files/digest-t-coffee-3.84
@@ -0,0 +1,3 @@
+MD5 f8f74db4132573b0ec8790e64c4cda4c T-COFFEE_distribution_Version_3.84.tar.gz 1625217
+RMD160 cda295fd0c2c432c8f802739a3748fcb01f40389 T-COFFEE_distribution_Version_3.84.tar.gz 1625217
+SHA256 1c062fe67b1817570fdce8f57999ce637863cc91b4feb91053ef805cc3f48eab T-COFFEE_distribution_Version_3.84.tar.gz 1625217
diff --git a/sci-biology/t-coffee/t-coffee-3.84.ebuild b/sci-biology/t-coffee/t-coffee-3.84.ebuild
new file mode 100644
index 000000000000..100840872c61
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-3.84.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-3.84.ebuild,v 1.1 2006/03/07 21:41:22 spyderous Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="t-coffee"
+HOMEPAGE="http://igs-server.cnrs-mrs.fr/~cnotred/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://igs-server.cnrs-mrs.fr/~cnotred/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+RESTRICT="nomirror"
+
+DEPEND="sci-biology/clustalw"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC) ${CFLAGS}/" -i makefile || die \
+ "Failed to patch makefile."
+}
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ make all || die_compile
+}
+
+src_install() {
+ cd "${TCDIR}"/bin
+ dobin t_coffee || die "Failed to install program."
+ insinto /usr/share/${PN}/lib/html
+ doins ${TCDIR}/html/* || die "Failed to install HTML documentation,"
+
+ dodoc ${TCDIR}/doc/README4T-COFFEE || die \
+ "Failed to install basic documentation."
+ insinto /usr/share/doc/${PF}
+ doins ${TCDIR}/doc/t_coffee{_doc.{doc,pdf},.pdf} || die \
+ "Failed to install manuals and articles."
+ doins ${TCDIR}/doc/*.txt || die "Failed to install documentation."
+
+ insinto /usr/share/${PN}/example
+ doins ${TCDIR}/example/* || die "Failed to install example files."
+}