summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-06 11:20:02 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-06 11:20:02 +0000
commit98dfa208b434f63766440ecf71fc956d947153e0 (patch)
tree81650aca6132b8e3a09d92ef4d3ec56bcf1c90cd /sci-biology
parentppc stable; bug #193933. (diff)
downloadgentoo-2-98dfa208b434f63766440ecf71fc956d947153e0.tar.gz
gentoo-2-98dfa208b434f63766440ecf71fc956d947153e0.tar.bz2
gentoo-2-98dfa208b434f63766440ecf71fc956d947153e0.zip
New version (fixes bug #191874).
(Portage version: 2.1.3.11)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/probcons/ChangeLog7
-rw-r--r--sci-biology/probcons/files/digest-probcons-1.123
-rw-r--r--sci-biology/probcons/files/probcons-1.12-cxxflags.patch21
-rw-r--r--sci-biology/probcons/probcons-1.12.ebuild44
4 files changed, 74 insertions, 1 deletions
diff --git a/sci-biology/probcons/ChangeLog b/sci-biology/probcons/ChangeLog
index a328565fca0e..84b675cf5980 100644
--- a/sci-biology/probcons/ChangeLog
+++ b/sci-biology/probcons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/probcons
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.5 2007/02/22 01:28:37 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.6 2007/10/06 11:20:01 markusle Exp $
+
+*probcons-1.12 (06 Oct 2007)
+
+ 06 Oct 2007; Markus Dittrich <markusle@gentoo.org> +files/probcons-1.12-cxxflags.patch, +probcons-1.12.ebuild:
+ New version (fixes bug #191874).
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-biology/probcons/files/digest-probcons-1.12 b/sci-biology/probcons/files/digest-probcons-1.12
new file mode 100644
index 000000000000..655d2ce3110e
--- /dev/null
+++ b/sci-biology/probcons/files/digest-probcons-1.12
@@ -0,0 +1,3 @@
+MD5 a658e24b07aaa9e8194317345133ac9d probcons_v1_12.tar.gz 43200
+RMD160 4d7d9a89c2c95f22056719c8349216ca1ba635c9 probcons_v1_12.tar.gz 43200
+SHA256 ecf3f9ab9ad47e14787c76d1c64aeea5533d4038c4be0236c00cdd79104cf383 probcons_v1_12.tar.gz 43200
diff --git a/sci-biology/probcons/files/probcons-1.12-cxxflags.patch b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
new file mode 100644
index 000000000000..a2431c4a0936
--- /dev/null
+++ b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
@@ -0,0 +1,21 @@
+diff -Naur probcons/Makefile probcons-new/Makefile
+--- probcons/Makefile 2007-04-03 13:39:23.000000000 -0400
++++ probcons-new/Makefile 2007-10-06 07:07:10.000000000 -0400
+@@ -15,6 +15,8 @@
+ # c) RELEASE mode
+ ################################################################################
+
++OPT_CXXFLAGS = -O3 -W -Wall -pedantic -funroll-loops
++
+ OTHERFLAGS = -DNumInsertStates=2 -DVERSION="1.12"
+
+ # debug mode
+@@ -25,7 +27,7 @@
+
+ # release mode
+ #CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -mmmx -msse -msse2 -mfpmath=sse -march=pentium4 -mcpu=pentium4 -funroll-loops -fomit-frame-pointer
+-CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -funroll-loops
++CXXFLAGS = $(OPT_CXXFLAGS) -DNDEBUG $(OTHERFLAGS)
+
+ ################################################################################
+ # 3) Dependencies
diff --git a/sci-biology/probcons/probcons-1.12.ebuild b/sci-biology/probcons/probcons-1.12.ebuild
new file mode 100644
index 000000000000..d930525be39f
--- /dev/null
+++ b/sci-biology/probcons/probcons-1.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12.ebuild,v 1.1 2007/10/06 11:20:01 markusle Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_v${PV/./_}"
+DESCRIPTION="Probabilistic Consistency-based Multiple Alignment of Amino Acid Sequences"
+HOMEPAGE="http://probcons.stanford.edu/"
+SRC_URI="http://probcons.stanford.edu/${MY_P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+# Gnuplot is explicitly runtime-only, it's run using system()
+RDEPEND="sci-visualization/gnuplot"
+DEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-cxxflags.patch
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ DESTTREE="/usr" dobin probcons project makegnuplot
+ # Overlap with imagemagick
+ DESTTREE="/usr" newbin compare compare-probcons
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "The 'compare' binary is installed as 'compare-probcons'"
+ ewarn "to avoid overlap with other packages."
+ einfo "You may also want to download the user manual"
+ einfo "from http://probcons.stanford.edu/manual.pdf"
+}