summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-12 13:42:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-12 13:42:20 +0000
commit7de75d2d1a2d7d1fbed303cb91722085f24e9b8c (patch)
tree8e777f0e0f5c9eec4b8f289b182c54794ad345a4 /sci-biology
parentRemove old. (diff)
downloadgentoo-2-7de75d2d1a2d7d1fbed303cb91722085f24e9b8c.tar.gz
gentoo-2-7de75d2d1a2d7d1fbed303cb91722085f24e9b8c.tar.bz2
gentoo-2-7de75d2d1a2d7d1fbed303cb91722085f24e9b8c.zip
sci-biology/mafft: version Bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mafft/ChangeLog7
-rw-r--r--sci-biology/mafft/mafft-7.046.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sci-biology/mafft/ChangeLog b/sci-biology/mafft/ChangeLog
index f392d0624a36..424e38021ece 100644
--- a/sci-biology/mafft/ChangeLog
+++ b/sci-biology/mafft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mafft
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/ChangeLog,v 1.16 2013/06/06 08:09:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/ChangeLog,v 1.17 2013/06/12 13:42:20 jlec Exp $
+
+*mafft-7.046 (12 Jun 2013)
+
+ 12 Jun 2013; Justin Lecher <jlec@gentoo.org> +mafft-7.046.ebuild:
+ version Bump
06 Jun 2013; Justin Lecher <jlec@gentoo.org> Manifest:
Update to new upstream tarball
diff --git a/sci-biology/mafft/mafft-7.046.ebuild b/sci-biology/mafft/mafft-7.046.ebuild
new file mode 100644
index 000000000000..121e8324c8c5
--- /dev/null
+++ b/sci-biology/mafft/mafft-7.046.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mafft/mafft-7.046.ebuild,v 1.1 2013/06/12 13:42:20 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+EXTENSIONS="-without-extensions"
+
+DESCRIPTION="Multiple sequence alignments using a variety of algorithms"
+HOMEPAGE="http://mafft.cbrc.jp/alignment/software/index.html"
+SRC_URI="http://mafft.cbrc.jp/alignment/software/${P}${EXTENSIONS}-src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos ~x86-macos"
+IUSE="threads"
+
+S="${WORKDIR}"/${P}${EXTENSIONS}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.037-respect.patch
+ use threads && append-cppflags -Denablemultithread
+ sed "s:GENTOOLIBDIR:$(get_libdir):g" -i core/Makefile || die
+ sed -i -e "s/(PREFIX)\/man/(PREFIX)\/share\/man/" "${S}"/core/Makefile || die "sed failed"
+}
+
+src_compile() {
+ pushd core > /dev/null || die
+ emake \
+ $(usex threads ENABLE_MULTITHREAD="-Denablemultithread" ENABLE_MULTITHREAD="") \
+ PREFIX="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ popd > /dev/null || die
+}
+
+src_test() {
+ export MAFFT_BINARIES="${S}"/core
+ cd test || die
+ bash ../core/mafft sample > test.fftns2 || die
+ bash ../core/mafft --maxiterate 100 sample > test.fftnsi || die
+ bash ../core/mafft --globalpair sample > test.gins1 || die
+ bash ../core/mafft --globalpair --maxiterate 100 sample > test.ginsi || die
+ bash ../core/mafft --localpair sample > test.lins1 || die
+ bash ../core/mafft --localpair --maxiterate 100 sample > test.linsi || die
+
+ diff test.fftns2 sample.fftns2 || die
+ diff test.fftnsi sample.fftnsi || die
+ diff test.gins1 sample.gins1 || die
+ diff test.ginsi sample.ginsi || die
+ diff test.lins1 sample.lins1 || die
+}
+
+src_install() {
+ pushd core
+ emake PREFIX="${ED}usr" install
+ popd
+ dodoc readme
+}