summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-11-24 18:21:23 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-11-24 18:21:23 +0000
commit3b0f4b1eeae33f8f6acf1b7d22f0bb267ad6f7ea (patch)
treee6bdcb97e46be07fcd82d9912710b3e6040fbed7 /sci-biology
parentimlib gtk use flag was renamed to deprecated (diff)
downloadgentoo-2-3b0f4b1eeae33f8f6acf1b7d22f0bb267ad6f7ea.tar.gz
gentoo-2-3b0f4b1eeae33f8f6acf1b7d22f0bb267ad6f7ea.tar.bz2
gentoo-2-3b0f4b1eeae33f8f6acf1b7d22f0bb267ad6f7ea.zip
Version bump, take maintainership
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/t-coffee/ChangeLog8
-rw-r--r--sci-biology/t-coffee/metadata.xml4
-rw-r--r--sci-biology/t-coffee/t-coffee-8.14.ebuild60
3 files changed, 71 insertions, 1 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index b5b266530c59..4b7872f69ac7 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.36 2009/03/24 21:32:36 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.37 2009/11/24 18:21:23 weaver Exp $
+
+*t-coffee-8.14 (24 Nov 2009)
+
+ 24 Nov 2009; Andrey Kislyuk <weaver@gentoo.org> metadata.xml,
+ +t-coffee-8.14.ebuild:
+ Version bump, assume maintainership
24 Mar 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-biology/t-coffee/metadata.xml b/sci-biology/t-coffee/metadata.xml
index 228a09e08036..3ea57edd4222 100644
--- a/sci-biology/t-coffee/metadata.xml
+++ b/sci-biology/t-coffee/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
<herd>sci-biology</herd>
<longdescription>
T-Coffee is a multiple sequence alignment package. Given a set of
diff --git a/sci-biology/t-coffee/t-coffee-8.14.ebuild b/sci-biology/t-coffee/t-coffee-8.14.ebuild
new file mode 100644
index 000000000000..773631d503d6
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-8.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-8.14.ebuild,v 1.1 2009/11/24 18:21:23 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sci-biology/clustalw"
+RDEPEND="${DEPEND}"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" emake || die_compile
+}
+
+src_install() {
+ dobin t_coffee || die "Failed to install program."
+
+ insinto /usr/share/${PN}/lib/html
+ doins "${TCDIR}"/html/* \
+ || die "Failed to install Web interface files."
+
+ cd "${TCDIR}"/doc
+ dodoc aln_compare.doc.txt seq_reformat.doc.txt \
+ t_coffee_technical.txt t_coffee_tutorial.txt \
+ || die "Failed to install text documentation."
+
+ dohtml t_coffee_technical.htm t_coffee_tutorial.htm \
+ || die "Failed to install HTML documentation."
+
+ insinto /usr/share/doc/${PF}
+ doins t_coffee_technical.doc t_coffee_tutorial.doc \
+ || die "Failed to install DOC documentation."
+
+ insinto /usr/share/${PN}/example
+ doins "${TCDIR}"/example/* \
+ || die "Failed to install example files."
+}