summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-01-30 18:25:40 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-01-30 18:25:40 +0000
commit78e0651e2d6dd7b0a5757b7e90043c9180fe067f (patch)
tree7c1a31dc6a7f184345dbde34a2aa5fdc6a3c88ec /sci-biology/trnascan-se
parentStable on sparc. (diff)
downloadgentoo-2-78e0651e2d6dd7b0a5757b7e90043c9180fe067f.tar.gz
gentoo-2-78e0651e2d6dd7b0a5757b7e90043c9180fe067f.tar.bz2
gentoo-2-78e0651e2d6dd7b0a5757b7e90043c9180fe067f.zip
Initial import
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-biology/trnascan-se')
-rw-r--r--sci-biology/trnascan-se/ChangeLog10
-rw-r--r--sci-biology/trnascan-se/Manifest3
-rw-r--r--sci-biology/trnascan-se/files/digest-trnascan-se-1.231
-rw-r--r--sci-biology/trnascan-se/metadata.xml16
-rw-r--r--sci-biology/trnascan-se/trnascan-se-1.23.ebuild37
5 files changed, 67 insertions, 0 deletions
diff --git a/sci-biology/trnascan-se/ChangeLog b/sci-biology/trnascan-se/ChangeLog
new file mode 100644
index 000000000000..085d091c000f
--- /dev/null
+++ b/sci-biology/trnascan-se/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/trnascan-se
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/trnascan-se/ChangeLog,v 1.1 2005/01/30 18:25:40 ribosome Exp $
+
+*trnascan-se-1.23 (30 Jan 2005)
+
+ 30 Jan 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +trnascan-se-1.23.ebuild:
+ Initial import.
+
diff --git a/sci-biology/trnascan-se/Manifest b/sci-biology/trnascan-se/Manifest
new file mode 100644
index 000000000000..3271641ac450
--- /dev/null
+++ b/sci-biology/trnascan-se/Manifest
@@ -0,0 +1,3 @@
+MD5 52a2d8486100b689ebdaca388a8a4521 trnascan-se-1.23.ebuild 891
+MD5 8b2911939b7a9ffbd6a01f82973f0c7a metadata.xml 587
+MD5 9ecd6913936da62c55e691e4123d3f4f files/digest-trnascan-se-1.23 69
diff --git a/sci-biology/trnascan-se/files/digest-trnascan-se-1.23 b/sci-biology/trnascan-se/files/digest-trnascan-se-1.23
new file mode 100644
index 000000000000..8079b6849520
--- /dev/null
+++ b/sci-biology/trnascan-se/files/digest-trnascan-se-1.23
@@ -0,0 +1 @@
+MD5 f993cea7fce0e68641360b1799640316 trnascan-se-1.23.tar.bz2 482202
diff --git a/sci-biology/trnascan-se/metadata.xml b/sci-biology/trnascan-se/metadata.xml
new file mode 100644
index 000000000000..b5716d9ff73d
--- /dev/null
+++ b/sci-biology/trnascan-se/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ribosome@gentoo.org</email>
+ <name>Olivier Fisette</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription>
+ tRNAscan-SE detects ~99% of eukaryotic nuclear or prokaryotic tRNA
+ genes, with a false positive rate of less than one per 15 gigabases,
+ and with a search speed of about 30 kb/second. It was implemented for
+ large-scale human genome sequence analysis, but is applicable to
+ other DNAs as well.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/trnascan-se/trnascan-se-1.23.ebuild b/sci-biology/trnascan-se/trnascan-se-1.23.ebuild
new file mode 100644
index 000000000000..6383d30c6f5f
--- /dev/null
+++ b/sci-biology/trnascan-se/trnascan-se-1.23.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/trnascan-se/trnascan-se-1.23.ebuild,v 1.1 2005/01/30 18:25:40 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="tRNA detection in large-scale genome sequences"
+HOMEPAGE="http://selab.wustl.edu/cgi-bin/selab.pl?mode=software%22#trnascan"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_compile() {
+ sed -i -e "s%BINDIR = \$(HOME)/bin%BINDIR = ${D}/usr/bin%" \
+ -e "s%LIBDIR = \$(HOME)/lib/tRNAscan-SE%LIBDIR = ${D}/usr/share/${PN}%" \
+ -e "s%MANDIR = \$(HOME)/man%MANDIR = ${D}/usr/share/man%" \
+ -e "s%CC = gcc%CC = $(tc-getCC)%" \
+ -e "s%CFLAGS = -O%CFLAGS = ${CFLAGS}%" \
+ Makefile || die
+ emake || die
+}
+
+src_install() {
+ make install || die
+ dodoc MANUAL README Release.history
+ insinto /usr/share/doc/${PF}
+ doins Manual.ps
+}
+
+src_test() {
+ make testrun || die
+}