summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-09-06 06:42:18 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-09-06 06:42:18 +0000
commit90fbec142f4024f141e1f2cc5d255a263c15f025 (patch)
tree1a8ca0a95d10814400d4d3753f71b7ffeceb2d5c /sci-biology/treeviewx
parentManifest fix, upstream changed tarball (diff)
downloadgentoo-2-90fbec142f4024f141e1f2cc5d255a263c15f025.tar.gz
gentoo-2-90fbec142f4024f141e1f2cc5d255a263c15f025.tar.bz2
gentoo-2-90fbec142f4024f141e1f2cc5d255a263c15f025.zip
Migrate to wxGTK-2.8 with patch from Debian. Use EAPI 2. Simplify
wxwidgets handling. (Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/treeviewx')
-rw-r--r--sci-biology/treeviewx/ChangeLog9
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch14
-rw-r--r--sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild32
3 files changed, 54 insertions, 1 deletions
diff --git a/sci-biology/treeviewx/ChangeLog b/sci-biology/treeviewx/ChangeLog
index 3583a0a1c111..d0f65b433afc 100644
--- a/sci-biology/treeviewx/ChangeLog
+++ b/sci-biology/treeviewx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/treeviewx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.21 2010/02/18 02:55:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.22 2010/09/06 06:42:18 dirtyepic Exp $
+
+*treeviewx-0.5.1-r2 (06 Sep 2010)
+
+ 06 Sep 2010; Ryan Hill <dirtyepic@gentoo.org> +treeviewx-0.5.1-r2.ebuild,
+ +files/treeviewx-0.5.1-wx28.patch:
+ Migrate to wxGTK-2.8 with patch from Debian. Use EAPI 2. Simplify
+ wxwidgets handling.
18 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> treeviewx-0.5.1.ebuild,
treeviewx-0.5.1-r1.ebuild:
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch
new file mode 100644
index 000000000000..e3ba6b2fff50
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch
@@ -0,0 +1,14 @@
+Fix build w/ wxGTK-2.8
+http://bugs.debian.org/567238
+
+--- a/tview.cpp
++++ b/tview.cpp
+@@ -994,7 +994,7 @@ END_EVENT_TABLE()
+ MyCanvas::MyCanvas(wxView *v, wxMDIChildFrame *frame, const wxPoint& pos, const wxSize& size, long style):
+ wxScrolledWindow(frame, -1, pos, size, style)
+ {
+- SetBackgroundColour(wxColour("WHITE"));
++ SetBackgroundColour(wxColour(wxT("WHITE")));
+ view = v;
+ magnification = 1;
+ }
diff --git a/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild b/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..1a65ecedcadd
--- /dev/null
+++ b/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild,v 1.1 2010/09/06 06:42:18 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+inherit eutils wxwidgets
+
+DESCRIPTION="A phylogenetic tree viewer"
+HOMEPAGE="http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/"
+SRC_URI="http://darwin.zoology.gla.ac.uk/~rpage/${PN}/download/0.5/tv-${PV}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/tv-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-wxt.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-wx28.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+}