summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-01-21 17:19:43 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-01-21 17:19:43 +0000
commit4795299e249ca9f09d8a991e419f7891208dd09f (patch)
tree4728ba16d03a4c1083ea835984db8062c181ba95 /sci-biology/rebase
parentVersion Bump. (diff)
downloadgentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.tar.gz
gentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.tar.bz2
gentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.zip
Fixed issues with duplicated CODON files, case-insensitive filesystems (ppc-macos) and restriction enzymes equivalences (see bugs #118832 and #115446)
(Portage version: 2.0.53)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog8
-rw-r--r--sci-biology/rebase/Manifest2
-rw-r--r--sci-biology/rebase/files/digest-rebase-601-r11
-rw-r--r--sci-biology/rebase/rebase-601-r1.ebuild43
4 files changed, 53 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index bcc87a245910..f7c2a8b74e07 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/rebase
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.51 2006/01/18 21:28:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.52 2006/01/21 17:19:43 ribosome Exp $
+
+*rebase-601-r1 (21 Jan 2006)
+
+ 21 Jan 2006; Olivier Fisette <ribosome@gentoo.org> +rebase-601-r1.ebuild:
+ Install an enzymes prototypes file, replacing the one distributed with
+ EMBOSS. This will solve the inconsistencies reported in bug #118832.
18 Jan 2006; Markus Rothe <corsair@gentoo.org> rebase-512.ebuild:
Stable on ppc64; bug #118832
diff --git a/sci-biology/rebase/Manifest b/sci-biology/rebase/Manifest
index 9db7760c6724..e5af18ff6bb0 100644
--- a/sci-biology/rebase/Manifest
+++ b/sci-biology/rebase/Manifest
@@ -3,8 +3,10 @@ MD5 8b72021e3a53e0c9ab7acaf2d016637e files/digest-rebase-509 63
MD5 de0923d154ca7a32f45ee6bb9d3a40c4 files/digest-rebase-511 63
MD5 0327e485fe0040317dd1016583b0d76d files/digest-rebase-512 63
MD5 9b37c587b84cf914d6f9a9b616c493db files/digest-rebase-601 63
+MD5 9b37c587b84cf914d6f9a9b616c493db files/digest-rebase-601-r1 63
MD5 550f8d428f3e75690b43d32df6aa60cd metadata.xml 900
MD5 b4f7769279c4301bacb9c4b78f136d08 rebase-509.ebuild 1097
MD5 fe94217aa8122be5dc5855d73772d8b0 rebase-511.ebuild 1237
MD5 292928f0068bac8ab37a29c223af581e rebase-512.ebuild 1238
+MD5 ef9d51f417289656336e9f1f26edf920 rebase-601-r1.ebuild 1360
MD5 ac62c4563f22a49719f3623d9e163ce1 rebase-601.ebuild 1244
diff --git a/sci-biology/rebase/files/digest-rebase-601-r1 b/sci-biology/rebase/files/digest-rebase-601-r1
new file mode 100644
index 000000000000..514623f4bd95
--- /dev/null
+++ b/sci-biology/rebase/files/digest-rebase-601-r1
@@ -0,0 +1 @@
+MD5 473a812ec6119fb8b02ac3e0bfec6884 rebase-601.tar.bz2 181829
diff --git a/sci-biology/rebase/rebase-601-r1.ebuild b/sci-biology/rebase/rebase-601-r1.ebuild
new file mode 100644
index 000000000000..8cb1c680615e
--- /dev/null
+++ b/sci-biology/rebase/rebase-601-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-601-r1.ebuild,v 1.1 2006/01/21 17:19:43 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos ~ppc64"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0-r1 )"
+
+src_compile() {
+ if use emboss; then
+ echo
+ einfo "Indexing ${PN} for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA=. rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/{embossre.enz,embossre.ref,embossre.sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins embossre.equ || die "Failed to install enzyme prototypes file."
+ fi
+}