summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 13:27:50 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 13:27:50 +0000
commitcd685ebc89de32a6c2b8e5931bc344f69f46e696 (patch)
tree907f62497a2b52c1f28f398f1aaa1da018de1801 /sci-biology/probcons
parentVersion BUmp, keyworded for prefix, repecting multilib and LDFLAGS (diff)
downloadgentoo-2-cd685ebc89de32a6c2b8e5931bc344f69f46e696.tar.gz
gentoo-2-cd685ebc89de32a6c2b8e5931bc344f69f46e696.tar.bz2
gentoo-2-cd685ebc89de32a6c2b8e5931bc344f69f46e696.zip
QA and keyworded for linux prefix
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/probcons')
-rw-r--r--sci-biology/probcons/ChangeLog10
-rw-r--r--sci-biology/probcons/files/probcons-1.12-cxxflags.patch36
-rw-r--r--sci-biology/probcons/probcons-1.12-r1.ebuild50
3 files changed, 89 insertions, 7 deletions
diff --git a/sci-biology/probcons/ChangeLog b/sci-biology/probcons/ChangeLog
index 9aeb9f3e504c..212d6096034a 100644
--- a/sci-biology/probcons/ChangeLog
+++ b/sci-biology/probcons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/probcons
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.9 2009/08/16 18:18:18 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.10 2010/06/15 13:27:50 jlec Exp $
+
+*probcons-1.12-r1 (15 Jun 2010)
+
+ 15 Jun 2010; Justin Lecher <jlec@gentoo.org> +probcons-1.12-r1.ebuild,
+ files/probcons-1.12-cxxflags.patch:
+ QA and keyworded for linux prefix
16 Aug 2009; Donnie Berkholz <dberkholz@gentoo.org>; probcons-1.12.ebuild:
Keyword ~amd64.
diff --git a/sci-biology/probcons/files/probcons-1.12-cxxflags.patch b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
index a2431c4a0936..e07ebe1a613f 100644
--- a/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
+++ b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
@@ -1,7 +1,8 @@
-diff -Naur probcons/Makefile probcons-new/Makefile
---- probcons/Makefile 2007-04-03 13:39:23.000000000 -0400
-+++ probcons-new/Makefile 2007-10-06 07:07:10.000000000 -0400
-@@ -15,6 +15,8 @@
+diff --git a/Makefile b/Makefile
+index 75fc47a..4a19140 100644
+--- a/Makefile
++++ b/Makefile
+@@ -15,6 +15,8 @@ CXX = g++
# c) RELEASE mode
################################################################################
@@ -10,7 +11,7 @@ diff -Naur probcons/Makefile probcons-new/Makefile
OTHERFLAGS = -DNumInsertStates=2 -DVERSION="1.12"
# debug mode
-@@ -25,7 +27,7 @@
+@@ -25,7 +27,7 @@ OTHERFLAGS = -DNumInsertStates=2 -DVERSION="1.12"
# release mode
#CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -mmmx -msse -msse2 -mfpmath=sse -march=pentium4 -mcpu=pentium4 -funroll-loops -fomit-frame-pointer
@@ -19,3 +20,28 @@ diff -Naur probcons/Makefile probcons-new/Makefile
################################################################################
# 3) Dependencies
+@@ -37,19 +39,19 @@ TARGETS = probcons compare project makegnuplot
+ all : $(TARGETS)
+
+ probcons : MultiSequence.h ProbabilisticModel.h ScoreType.h Sequence.h FileBuffer.h SparseMatrix.h EvolutionaryTree.h Defaults.h SafeVector.h Main.cc
+- $(CXX) $(CXXFLAGS) -lm -o probcons Main.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o probcons Main.cc -lm
+
+ compare : MultiSequence.h Sequence.h FileBuffer.h SafeVector.h CompareToRef.cc
+- $(CXX) $(CXXFLAGS) -o compare CompareToRef.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o compare CompareToRef.cc
+
+ fixref : MultiSequence.h ProbabilisticModel.h ScoreType.h Sequence.h FileBuffer.h SparseMatrix.h EvolutionaryTree.h Defaults.h SafeVector.h FixRef.cc
+- $(CXX) $(CXXFLAGS) -o fixref FixRef.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o fixref FixRef.cc
+
+ project : MultiSequence.h Sequence.h SafeVector.h ProjectPairwise.cc
+- $(CXX) $(CXXFLAGS) -o project ProjectPairwise.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o project ProjectPairwise.cc
+
+ makegnuplot : MakeGnuPlot.cc
+- $(CXX) $(CXXFLAGS) -o makegnuplot MakeGnuPlot.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o makegnuplot MakeGnuPlot.cc
+
+ .PHONY : clean
+ clean:
diff --git a/sci-biology/probcons/probcons-1.12-r1.ebuild b/sci-biology/probcons/probcons-1.12-r1.ebuild
new file mode 100644
index 000000000000..4dbeda112c8e
--- /dev/null
+++ b/sci-biology/probcons/probcons-1.12-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12-r1.ebuild,v 1.1 2010/06/15 13:27:50 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_v${PV/./_}"
+
+DESCRIPTION="Probabilistic Consistency-based Multiple Alignment of Amino Acid Sequences"
+HOMEPAGE="http://probcons.stanford.edu/"
+SRC_URI="http://probcons.stanford.edu/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Gnuplot is explicitly runtime-only, it's run using system()
+RDEPEND="sci-visualization/gnuplot"
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cxxflags.patch
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ dobin probcons project makegnuplot || die "failed to install"
+ # Overlap with imagemagick
+ newbin compare compare-probcons || die "failed to install compare"
+ dodoc README || die
+}
+
+pkg_postinst() {
+ ewarn "The 'compare' binary is installed as 'compare-probcons'"
+ ewarn "to avoid overlap with other packages."
+ einfo "You may also want to download the user manual"
+ einfo "from http://probcons.stanford.edu/manual.pdf"
+}