summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-08-20 16:56:10 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-08-20 16:56:10 +0000
commit50fb05b65e184e9b3ead9fb1587587959b1cacc2 (patch)
tree7064304505a28b01acc909b66b174ba149d45ad0 /sci-biology/allpaths
parentWith thanks to Ondrej Filip, the build system can now handle parallel make. T... (diff)
downloadgentoo-2-50fb05b65e184e9b3ead9fb1587587959b1cacc2.tar.gz
gentoo-2-50fb05b65e184e9b3ead9fb1587587959b1cacc2.tar.bz2
gentoo-2-50fb05b65e184e9b3ead9fb1587587959b1cacc2.zip
Fix compile issue on x86, bug 279711
(Portage version: 2.2_rc30/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-biology/allpaths')
-rw-r--r--sci-biology/allpaths/ChangeLog6
-rw-r--r--sci-biology/allpaths/allpaths-2.0.ebuild9
-rw-r--r--sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch30
3 files changed, 43 insertions, 2 deletions
diff --git a/sci-biology/allpaths/ChangeLog b/sci-biology/allpaths/ChangeLog
index 470981c22678..56d1cae87f32 100644
--- a/sci-biology/allpaths/ChangeLog
+++ b/sci-biology/allpaths/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/allpaths
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/ChangeLog,v 1.2 2009/07/08 03:50:03 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/ChangeLog,v 1.3 2009/08/20 16:56:10 weaver Exp $
+
+ 20 Aug 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/allpaths-2.0-gcc-x86-no-autocast.patch, allpaths-2.0.ebuild:
+ Fix compile issue on x86, bug 279711
07 Jul 2009; Andrey Kislyuk <weaver@gentoo.org> allpaths-2.0.ebuild:
Typo and collision fixes
diff --git a/sci-biology/allpaths/allpaths-2.0.ebuild b/sci-biology/allpaths/allpaths-2.0.ebuild
index 3d8192db7c3f..5814ee571f3a 100644
--- a/sci-biology/allpaths/allpaths-2.0.ebuild
+++ b/sci-biology/allpaths/allpaths-2.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/allpaths-2.0.ebuild,v 1.2 2009/07/08 03:50:03 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/allpaths-2.0.ebuild,v 1.3 2009/08/20 16:56:10 weaver Exp $
EAPI="2"
+inherit base
+
DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
SRC_URI="ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-2-0/allpaths-2.0.tar.gz
@@ -18,9 +20,14 @@ KEYWORDS="~amd64 ~x86"
DEPEND=">=sys-devel/gcc-4.3.2"
RDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-x86-no-autocast.patch
+)
+
S="${WORKDIR}"
src_prepare() {
+ base_src_prepare
rm -rf libxerces* xerces_include || die
}
diff --git a/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch b/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch
new file mode 100644
index 000000000000..d4fe428efa26
--- /dev/null
+++ b/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch
@@ -0,0 +1,30 @@
+diff -durr work.orig/SortKmersImpl.h work/SortKmersImpl.h
+--- work.orig/SortKmersImpl.h 2009-08-20 11:25:39.336695499 +0000
++++ work/SortKmersImpl.h 2009-08-20 11:25:51.431932630 +0000
+@@ -98,7 +98,7 @@
+ { if ( reads[l].size( ) < KSPAN ) continue;
+ unsigned int N = reads[l].size( ) - KSPAN + 1;
+ if ( S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<1>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
+@@ -180,7 +180,7 @@
+ }
+ if ( q == N ) break;
+ if ( S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }
+@@ -207,7 +207,7 @@
+ top += Min( N - top, (unsigned int) 10000 );
+
+ if ( S + 20000 >= R.size( ) || S + 2*N >= R.size( ) ) {
+- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
++ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
+ if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
+ R.resize(nn);
+ }