summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-27 18:54:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-27 18:54:55 +0000
commit8f576acda4de017ae16a5f05f581c1bc2a3c4a96 (patch)
treec0b17098cebabef942c02586256dd1ee552992a8 /sci-astronomy
parentStable for HPPA (bug #211360). (diff)
downloadgentoo-2-8f576acda4de017ae16a5f05f581c1bc2a3c4a96.tar.gz
gentoo-2-8f576acda4de017ae16a5f05f581c1bc2a3c4a96.tar.bz2
gentoo-2-8f576acda4de017ae16a5f05f581c1bc2a3c4a96.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog8
-rw-r--r--sci-astronomy/celestia/celestia-1.5.0.ebuild130
-rw-r--r--sci-astronomy/celestia/files/celestia-1.5.0-desktop.patch55
3 files changed, 192 insertions, 1 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index f31906f39226..3a020a205e18 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.38 2008/02/26 17:33:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.39 2008/02/27 18:54:54 bicatali Exp $
+
+*celestia-1.5.0 (27 Feb 2008)
+
+ 27 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/celestia-1.5.0-desktop.patch, +celestia-1.5.0.ebuild:
+ Version bump
26 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
files/celestia-1.4.1-kde-datadir.patch, celestia-1.4.1-r2.ebuild:
diff --git a/sci-astronomy/celestia/celestia-1.5.0.ebuild b/sci-astronomy/celestia/celestia-1.5.0.ebuild
new file mode 100644
index 000000000000..53d461ee5616
--- /dev/null
+++ b/sci-astronomy/celestia/celestia-1.5.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.0.ebuild,v 1.1 2008/02/27 18:54:54 bicatali Exp $
+
+inherit eutils flag-o-matic gnome2 kde-functions autotools
+
+DESCRIPTION="OpenGL 3D space simulator"
+HOMEPAGE="http://www.shatters.net/celestia/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts cairo gnome gtk kde lua nls pch theora threads"
+
+RDEPEND="virtual/glu
+ media-libs/jpeg
+ media-libs/libpng
+ gtk? ( !gnome? ( !kde? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ ) ) )
+ gnome? ( !kde? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ >=gnome-base/libgnomeui-2.0
+ ) )
+ kde? ( !gnome? ( >=kde-base/kdelibs-3.0.5 ) )
+ !gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
+ arts? ( kde-base/arts )
+ lua? ( >=dev-lang/lua-5.0 )
+ cairo? ( x11-libs/cairo )
+ theora? ( media-libs/libtheora )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # Check for one for the following use flags to be set.
+
+ if ! use gnome && use kde; then
+ einfo "USE=\"kde\" detected."
+ CELESTIA_GUI="kde"
+ elif ! use kde && use gnome; then
+ einfo "USE=\"gnome\" detected."
+ USE_DESTDIR="1"
+ CELESTIA_GUI="gnome"
+ elif ! use kde && ! use gnome && use gtk; then
+ einfo "USE=\"gtk\" detected."
+ CELESTIA_GUI="gtk"
+ elif use kde && use gnome; then
+ einfo "Both gnome and kde support requested. Defaulting to kde"
+ CELESTIA_GUI="kde"
+ else
+ ewarn "If you want to use the full gui, set USE=\"{kde/gnome/gtk}\""
+ ewarn "Defaulting to glut support (no GUI)."
+ CELESTIA_GUI="glut"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ # make better desktop files
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ # add a ~/.celestia for extra directories
+ epatch "${FILESDIR}"/${PN}-1.4.1-cfg.patch
+
+ # fix for as-needed (bug #130091)
+ epatch "${FILESDIR}"/${PN}-1.4.1-as-needed.patch
+
+ # remove flags to let the user decide
+ for cf in -O2 -ffast-math \
+ -fexpensive-optimizations \
+ -fomit-frame-pointer; do
+ sed -i \
+ -e "s/${cf}//g" \
+ configure.in || die "sed failed"
+ done
+
+ # remove an unused gconf macro killing autoconf when no gnome
+ # (not needed without eautoreconf)
+ if ! use gnome; then
+ sed -i \
+ -e '/AM_GCONF_SOURCE_2/d' \
+ configure.in || die "sed failed"
+ fi
+
+ eautoreconf
+}
+
+src_compile() {
+
+ if [[ ${CELESTIA_GUI} == kde ]]; then
+ set-kdedir 3
+ set-qtdir 3
+ export kde_widgetdir="${KDEDIR}/lib/kde3/plugins/designer"
+ fi
+
+ filter-flags "-funroll-loops -frerun-loop-opt"
+
+ econf \
+ --with-${CELESTIA_GUI} \
+ $(use_with arts) \
+ $(use_with lua) \
+ $(use_enable cairo) \
+ $(use_enable threads threading) \
+ $(use_enable nls) \
+ $(use_enable pch) \
+ $(use_enable theora) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ if [[ ${CELESTIA_GUI} == gnome ]]; then
+ gnome2_src_install
+ else
+ emake DESTDIR="${D}" install || die "emake install failed"
+ for size in 16 22 32 48 ; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
+ done
+ fi
+ [[ ${CELESTIA_GUI} == glut ]] && domenu celestia.desktop
+ dodoc AUTHORS README TODO TRANSLATORS *.txt || die
+}
diff --git a/sci-astronomy/celestia/files/celestia-1.5.0-desktop.patch b/sci-astronomy/celestia/files/celestia-1.5.0-desktop.patch
new file mode 100644
index 000000000000..c4be8afeba8a
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.5.0-desktop.patch
@@ -0,0 +1,55 @@
+--- src/celestia/kde/data/celestia.desktop.orig 2008-02-27 15:19:41.000000000 +0000
++++ src/celestia/kde/data/celestia.desktop 2008-02-27 15:43:20.000000000 +0000
+@@ -1,8 +1,12 @@
+ [Desktop Entry]
++Encoding=UTF-8
++Version=1.0
+ Name=Celestia
+-Comment=Celestia
++Comment=3D space simulator to explore the universe
+ Exec=celestia %f
+ Terminal=false
+ Icon=celestia.png
+ MimeType=application/x-celestia-script
+ Type=Application
++Categories=Science;Astronomy;Qt
++GenericName=Space Simulator
+--- src/celestia/gtk/data/celestia.desktop.orig 2008-02-27 15:19:58.000000000 +0000
++++ src/celestia/gtk/data/celestia.desktop 2008-02-27 15:44:26.000000000 +0000
+@@ -1,12 +1,12 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+-Version=1.4.0
+-Type=Application
+-Exec=celestia
+-Icon=celestia
+-X-GNOME-DocPath=
+-Terminal=false
++Version=1.0
+ Name=Celestia
+-Comment=Space Simulator
+-StartupNotify=true
+-Categories=Astronomy;Science;Application;
++Comment=3D space simulator to explore the universe
++Exec=celestia %f
++Terminal=false
++Icon=celestia.png
++MimeType=application/x-celestia-script
++Type=Application
++Categories=Science;Astronomy;GTK
++GenericName=Space Simulator
+--- celestia.desktop 1970-01-01 01:00:00.000000000 +0100
++++ celestia.desktop 2008-02-27 15:22:31.000000000 +0000
+@@ -0,0 +1,12 @@
++[Desktop Entry]
++Encoding=UTF-8
++Version=1.0
++Name=Celestia
++GenericName=Space Simulator
++Comment=Explore the Universe in this detailed space simulation
++Type=Application
++Categories=Science;Astronomy
++Exec=celestia %f
++Terminal=false
++Icon=celestia.png
++MimeType=application/x-celestia-script