summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-03-04 00:23:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-03-04 00:23:49 +0000
commit6dbffb293a1520965ce88ddaca59715c947c966b (patch)
tree81a4024027e92d2f3052864b87f7a15c1664ac32 /sci-astronomy
parentFixed pidfile location for non-linux systems (diff)
downloadgentoo-2-6dbffb293a1520965ce88ddaca59715c947c966b.tar.gz
gentoo-2-6dbffb293a1520965ce88ddaca59715c947c966b.tar.bz2
gentoo-2-6dbffb293a1520965ce88ddaca59715c947c966b.zip
Fixed autoreconf bug #503222, add cpl6 compatibility patch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/esorex/ChangeLog10
-rw-r--r--sci-astronomy/esorex/esorex-3.10-r2.ebuild41
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-cpl60_compat.patch13
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-fix-autotools.patch4
4 files changed, 64 insertions, 4 deletions
diff --git a/sci-astronomy/esorex/ChangeLog b/sci-astronomy/esorex/ChangeLog
index c8fa37d4af19..87dc20a08dcf 100644
--- a/sci-astronomy/esorex/ChangeLog
+++ b/sci-astronomy/esorex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/esorex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/ChangeLog,v 1.10 2013/07/25 17:26:47 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/ChangeLog,v 1.11 2014/03/04 00:23:49 bicatali Exp $
+
+*esorex-3.10-r2 (04 Mar 2014)
+
+ 04 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> +esorex-3.10-r2.ebuild,
+ +files/esorex-3.10-cpl60_compat.patch, files/esorex-3.10-fix-autotools.patch:
+ Fixed autoreconf bug #503222, add cpl6 compatibility patch
*esorex-3.10-r1 (25 Jul 2013)
diff --git a/sci-astronomy/esorex/esorex-3.10-r2.ebuild b/sci-astronomy/esorex/esorex-3.10-r2.ebuild
new file mode 100644
index 000000000000..e9515aeb54d2
--- /dev/null
+++ b/sci-astronomy/esorex/esorex-3.10-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/esorex-3.10-r2.ebuild,v 1.1 2014/03/04 00:23:49 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AT_NO_RECURSIVE=1
+
+inherit autotools-utils
+
+DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/esorex.html"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=sci-astronomy/cpl-6.3:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.9.6-use-shared-libs.patch
+ "${FILESDIR}"/${PN}-3.10-remove-private-ltdl.patch
+ "${FILESDIR}"/${PN}-3.10-fix-autotools.patch
+ "${FILESDIR}"/${PN}-3.10-generate-manpage.patch
+ "${FILESDIR}"/${PN}-3.10-remove-empty-configdir.patch
+ "${FILESDIR}"/${PN}-3.10-set-default-plugin-path.patch
+ "${FILESDIR}"/${PN}-3.10-cpl60_compat.patch
+)
+
+export CPLDIR="${EPREFIX}/usr"
+
+src_install() {
+ autotools-utils_src_install
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}
diff --git a/sci-astronomy/esorex/files/esorex-3.10-cpl60_compat.patch b/sci-astronomy/esorex/files/esorex-3.10-cpl60_compat.patch
new file mode 100644
index 000000000000..1203f7812fa0
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.10-cpl60_compat.patch
@@ -0,0 +1,13 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Subject: Remove function that is only in cpl >= 6.3 to establish compability
+ with older (stable) versions and allow backporting.
+--- a/src/er_main.c
++++ b/src/er_main.c
+@@ -641,7 +641,6 @@
+
+ cpl_msg_set_domain (PACKAGE);
+ cpl_msg_set_time_off ();
+-cpl_msg_set_threadid_off ();
+ cpl_msg_set_domain_on ();
+ cpl_msg_set_component_off ();
+
diff --git a/sci-astronomy/esorex/files/esorex-3.10-fix-autotools.patch b/sci-astronomy/esorex/files/esorex-3.10-fix-autotools.patch
index 44919f54aa9b..68fbcb971f45 100644
--- a/sci-astronomy/esorex/files/esorex-3.10-fix-autotools.patch
+++ b/sci-astronomy/esorex/files/esorex-3.10-fix-autotools.patch
@@ -1,7 +1,7 @@
Author: Ole Streicher <debian@liska.ath.cx>
Subject: Fix autotools files to allow the current version.
---- a/configure.ac
-+++ b/configure.ac
+--- esorex-3.10/configure.ac.orig
++++ esorex-2.10/configure.ac
@@ -5,6 +5,7 @@
AC_CONFIG_SRCDIR([Makefile.am])