summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-03-07 02:49:15 +0000
committerDaniel Goller <morfic@gentoo.org>2006-03-07 02:49:15 +0000
commit0d57cd97f1df4d1e536d73d71bac28dbf44bfd00 (patch)
treefc864b9eff2315284d53e32f3a11b4a9edd88c20 /sci-astronomy
parentAdd gstreamer gconf dependency. (diff)
downloadgentoo-2-0d57cd97f1df4d1e536d73d71bac28dbf44bfd00.tar.gz
gentoo-2-0d57cd97f1df4d1e536d73d71bac28dbf44bfd00.tar.bz2
gentoo-2-0d57cd97f1df4d1e536d73d71bac28dbf44bfd00.zip
Applying gcc-4.1 patch to close bug#124956
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.4.1.ebuild4
-rw-r--r--sci-astronomy/celestia/files/celestia-1.4.1-gcc-4.1.patch28
3 files changed, 36 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index f29d74cb20f6..b448157c958b 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.12 2006/02/17 05:51:50 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.13 2006/03/07 02:49:15 morfic Exp $
+
+ 07 Mar 2006; Daniel Goller <morfic@gentoo.org>
+ +files/celestia-1.4.1-gcc-4.1.patch, celestia-1.4.1.ebuild:
+ Applying gcc-4.1 patch to close bug#124956
*celestia-1.4.1 (17 Feb 2006)
diff --git a/sci-astronomy/celestia/celestia-1.4.1.ebuild b/sci-astronomy/celestia/celestia-1.4.1.ebuild
index 3d47734232fc..4fd8227a7ebc 100644
--- a/sci-astronomy/celestia/celestia-1.4.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1.ebuild,v 1.1 2006/02/17 05:51:50 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1.ebuild,v 1.2 2006/03/07 02:49:15 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -72,6 +72,8 @@ src_compile() {
export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
fi
+ epatch "${FILESDIR}/celestia-1.4.1-gcc-4.1.patch"
+
econf \
--with-${mygui} \
--with-pic \
diff --git a/sci-astronomy/celestia/files/celestia-1.4.1-gcc-4.1.patch b/sci-astronomy/celestia/files/celestia-1.4.1-gcc-4.1.patch
new file mode 100644
index 000000000000..515b429fc2f1
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.4.1-gcc-4.1.patch
@@ -0,0 +1,28 @@
+--- src/celengine/star.h.old 2006-03-06 20:29:28.000000000 -0600
++++ src/celengine/star.h 2006-03-06 20:30:26.000000000 -0600
+@@ -30,7 +30,7 @@ class StarDetails
+ // orbits and StarDetails objects. Currently, it's assumed that they
+ // have lifetimes that continue until program termination.
+ public:
+- StarDetails::StarDetails();
++ StarDetails();
+
+ inline float getRadius() const;
+ inline float getTemperature() const;
+--- src/celengine/command.h.old 2006-03-06 20:29:47.000000000 -0600
++++ src/celengine/command.h 2006-03-06 20:30:35.000000000 -0600
+@@ -94,10 +94,10 @@ class CommandGoto : public Instantaneous
+ class CommandGotoLongLat : public InstantaneousCommand
+ {
+ public:
+- CommandGotoLongLat::CommandGotoLongLat(double t,
+- double dist,
+- float _longitude, float _latitude,
+- Vec3f _up);
++ CommandGotoLongLat(double t,
++ double dist,
++ float _longitude, float _latitude,
++ Vec3f _up);
+ ~CommandGotoLongLat();
+ void process(ExecutionEnvironment&);
+