summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-06-12 20:00:51 +0000
committerJim Ramsay <lack@gentoo.org>2007-06-12 20:00:51 +0000
commit8a981095b542bcc821f7a6086e7af707b9600ff4 (patch)
treeadc53fd19f937ece4ff2f5450f0a89ee6658212c /rox-base
parentGPL-2 -> BSD (diff)
downloadgentoo-2-8a981095b542bcc821f7a6086e7af707b9600ff4.tar.gz
gentoo-2-8a981095b542bcc821f7a6086e7af707b9600ff4.tar.bz2
gentoo-2-8a981095b542bcc821f7a6086e7af707b9600ff4.zip
Updated to use $(get_libdir) instead of hard-coding /usr/lib
(Portage version: 2.1.2.8)
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox-clib/ChangeLog7
-rw-r--r--rox-base/rox-clib/files/digest-rox-clib-2.1.9-r13
-rw-r--r--rox-base/rox-clib/rox-clib-2.1.9-r1.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/rox-base/rox-clib/ChangeLog b/rox-base/rox-clib/ChangeLog
index 4dce569d47f0..ca66b49c0b16 100644
--- a/rox-base/rox-clib/ChangeLog
+++ b/rox-base/rox-clib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for rox-base/rox-clib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/ChangeLog,v 1.17 2007/02/09 22:02:10 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/ChangeLog,v 1.18 2007/06/12 20:00:51 lack Exp $
+
+*rox-clib-2.1.9-r1 (12 Jun 2007)
+
+ 12 Jun 2007; Jim Ramsay <lack@gentoo.org> +rox-clib-2.1.9-r1.ebuild:
+ Updated to use $(get_libdir) instead of hard-coding /usr/lib
09 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
rox-clib-2.1.9.ebuild:
diff --git a/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r1 b/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r1
new file mode 100644
index 000000000000..6fc0e751d372
--- /dev/null
+++ b/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r1
@@ -0,0 +1,3 @@
+MD5 cc494b5763613e9f58a27855f1729cec ROX-CLib-2.1.9.tar.gz 569820
+RMD160 d88f9e35924b8921cd199c7f645cf50925e0a36e ROX-CLib-2.1.9.tar.gz 569820
+SHA256 7cd8aea53948552d940d2a6d9a24b9e65798371e99ea50cb77f7eecd65b1c33c ROX-CLib-2.1.9.tar.gz 569820
diff --git a/rox-base/rox-clib/rox-clib-2.1.9-r1.ebuild b/rox-base/rox-clib/rox-clib-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..917f650d16cb
--- /dev/null
+++ b/rox-base/rox-clib/rox-clib-2.1.9-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/rox-clib-2.1.9-r1.ebuild,v 1.1 2007/06/12 20:00:51 lack Exp $
+
+inherit multilib
+
+MY_PN="ROX-CLib"
+DESCRIPTION="A library for ROX applications written in C."
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="http://www.kerofin.demon.co.uk/rox/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0.1
+ >=dev-libs/libxml2-2.4.0"
+
+DEPEND="$RDEPEND
+ >=dev-util/pkgconfig-0.20"
+
+S=${WORKDIR}/ROX-CLib
+APPNAME=${MY_PN}
+
+src_compile() {
+ chmod 0755 AppRun
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "Could not make ROX-CLib. Sorry."
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
+}
+
+src_install() {
+ local baselibdir="/usr/$(get_libdir)"
+
+ # clean up source instead of remove it!
+ ( cd src && make clean )
+
+ # remove silly .cvs files
+ find . -name '.cvs*' | xargs rm -f >/dev/null 2>&1
+ dodoc ${baselibdir}/${APPNAME}
+ dodir ${baselibdir}/${APPNAME}
+ cp -r . ${D}${baselibdir}/${APPNAME}
+ (
+ cd Help
+ dodoc Authors Changes ToDo COPYING README Versions
+ )
+}