summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-09-14 20:13:51 +0000
committerJim Ramsay <lack@gentoo.org>2008-09-14 20:13:51 +0000
commit75d6f9dac2d24fe1bab3e097c687c76997bc59ef (patch)
tree02f9cee92da4d099437103818aa5035370837263 /rox-base
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-75d6f9dac2d24fe1bab3e097c687c76997bc59ef.tar.gz
gentoo-2-75d6f9dac2d24fe1bab3e097c687c76997bc59ef.tar.bz2
gentoo-2-75d6f9dac2d24fe1bab3e097c687c76997bc59ef.zip
With the advent of split gnome-python-desktop, we only need the libwnck portion, not the whole ugly mess of gnome apps. So remove the gnome USE flag and always use libwnck.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/devtray/ChangeLog9
-rw-r--r--rox-base/devtray/devtray-0.4.1-r1.ebuild29
2 files changed, 37 insertions, 1 deletions
diff --git a/rox-base/devtray/ChangeLog b/rox-base/devtray/ChangeLog
index 70ee5345df2e..5c361878c445 100644
--- a/rox-base/devtray/ChangeLog
+++ b/rox-base/devtray/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for rox-base/devtray
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/devtray/ChangeLog,v 1.7 2008/08/30 20:01:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/devtray/ChangeLog,v 1.8 2008/09/14 20:13:51 lack Exp $
+
+*devtray-0.4.1-r1 (14 Sep 2008)
+
+ 14 Sep 2008; Jim Ramsay <lack@gentoo.org> +devtray-0.4.1-r1.ebuild:
+ With the advent of split gnome-python-desktop, we only need the libwnck
+ portion, not the whole ugly mess of gnome apps. So remove the gnome USE
+ flag and always use libwnck.
30 Aug 2008; Markus Meier <maekke@gentoo.org> devtray-0.4.1.ebuild:
x86 stable, bug #236057
diff --git a/rox-base/devtray/devtray-0.4.1-r1.ebuild b/rox-base/devtray/devtray-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..070035441638
--- /dev/null
+++ b/rox-base/devtray/devtray-0.4.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/devtray/devtray-0.4.1-r1.ebuild,v 1.1 2008/09/14 20:13:51 lack Exp $
+
+ROX_LIB_VER=1.9.6
+inherit rox
+
+MY_PN="DevTray"
+DESCRIPTION="DevTray is a rox panel applet which shows HAL devices."
+HOMEPAGE="http://rox4debian.berlios.de"
+SRC_URI="ftp://ftp.berlios.de/pub/rox4debian/apps/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cddb alsa"
+
+# TODO: When pycups is available, depend on it too (probably conditionally)
+
+RDEPEND=">=rox-base/traylib-0.3.2.1
+ dev-python/dbus-python
+ sys-apps/hal
+ dev-python/libwnck-python
+ || ( sys-apps/pmount gnome-base/gnome-mount )
+ cddb? ( dev-python/cddb-py )
+ alsa? ( dev-python/pyalsaaudio )"
+
+APPNAME="${MY_PN}"
+S="${WORKDIR}"