summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-05-04 09:49:47 +0000
committerTorsten Veller <tove@gentoo.org>2009-05-04 09:49:47 +0000
commit75274201f49ee1d9b22697736aa2e8decc0b5ad6 (patch)
treec6f7b97f0a08cd609e8f8eba001db85538481fe8 /perl-core
parentAdd missing dependencies, see bug #227747. (diff)
downloadgentoo-2-75274201f49ee1d9b22697736aa2e8decc0b5ad6.tar.gz
gentoo-2-75274201f49ee1d9b22697736aa2e8decc0b5ad6.tar.bz2
gentoo-2-75274201f49ee1d9b22697736aa2e8decc0b5ad6.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Module-Build/ChangeLog7
-rw-r--r--perl-core/Module-Build/Module-Build-0.33.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index 87d46f8b61f6..bb4d5c3d0b56 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for perl-core/Module-Build
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.8 2009/03/13 21:17:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.9 2009/05/04 09:49:47 tove Exp $
+
+*Module-Build-0.33 (04 May 2009)
+
+ 04 May 2009; Torsten Veller <tove@gentoo.org> +Module-Build-0.33.ebuild:
+ Version bump
13 Mar 2009; Torsten Veller <tove@gentoo.org>
-Module-Build-0.28-r1.ebuild, -Module-Build-0.30.ebuild,
diff --git a/perl-core/Module-Build/Module-Build-0.33.ebuild b/perl-core/Module-Build/Module-Build-0.33.ebuild
new file mode 100644
index 000000000000..18a6967c2282
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.33.ebuild,v 1.1 2009/05/04 09:49:47 tove Exp $
+
+inherit versionator
+MODULE_AUTHOR=EWILHELM
+MY_P=${PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09
+ >=virtual/perl-Test-Harness-3.16"
+
+SRC_TEST="do"